Thread Tools
Jan 31, 2009, 12:17 PM
Registered User
turnbui's Avatar
Discussion

EP100 ESC blown. Tried King2's ESC but not enuf power? What's a good replacement?


My EP100's Nodia 30Amp ESC blew. I tried the 25A EK1-0350 King 2's ESC but it doesn't give motor full speed.
Can anyone recommend a good replacement ESC please?
Sign up now
to remove ads between posts
Jan 31, 2009, 02:58 PM
Registered User
turnbui's Avatar
Very strange. I first used a 7.4v on the ESC. It bee[pd very quietly. Motor never got good speed. I then plugged in an 11.1v to the ESC. Loud beeps motor got to high speed. Then after a while tried 7.4v again and now loud beeps and motor got a lot faster but still not fast enough. Wierd. Now either 11.1v or 7.4v gives loud beeps!!
Jan 31, 2009, 08:00 PM
road wart
racie34's Avatar
if you fried your esc....and the next one doesn't give enough rpm....maybe the motors toast...causing the esc to struggle...........just a thought


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold GWS Brushed ESC's (Used but Cheap) RC4_LIFE Aircraft - Electric - Power Systems (FS/W) 2 May 10, 2007 11:58 AM
Sold Three Brushless Outrunners, 2 ESC's, Used But Not Dead ndflicks Aircraft - Electric - Power Systems (FS/W) 6 Apr 18, 2006 06:14 AM
FEDA 3 in 1 problem, but not the esc's! Goodychrischild Micro Helis 8 Nov 15, 2003 01:12 AM
Why ESC works 4 1, but not other? Daddio Power Systems 0 Jul 22, 2002 02:27 PM
Servos working, but not ESC JamesD Power Systems 6 Dec 21, 2001 10:59 AM