New Products Flash Sale
Thread Tools
Old Mar 06, 2010, 04:50 PM
mandrew is offline
Find More Posts by mandrew
Registered User

Ouch


I had my 11th flight on my 500 when I found out the hard way that I must have missed the thread about checking the head and reapplying lock tight. The long linkage ball screw fell out and the heli started doing nice uncontrolled loops. I must say it look cool, but thatís not how I wanted to start doing loops. I think it got 3 loops in before I cut the power and let it drop. The good news is the damage is not as bad as it could have been or worse if it was low and close to me.
Sign up now
to remove ads between posts
Old Mar 06, 2010, 04:54 PM
jcervantes11 is offline
Find More Posts by jcervantes11
Registered User
jcervantes11's Avatar
Quote:
Originally Posted by Tumbler View Post
I can't find the battery to my video camera, but my girlfriend was nice enough to shoot some video with her regular camera for me. The quality is not the best, but shows some of what this thing can do with cheapo stuff.

Turnigy 930 cyclic servos
hs-82mg TR servo
GY48 Gyro
Hobbymate Motor
Flyermate 80a ESC
6s 3000 20c Turnigy battery

http://www.youtube.com/watch?v=_50dUrd5Hl4
Wow nice flying.
Old Mar 06, 2010, 05:03 PM
jcervantes11 is offline
Find More Posts by jcervantes11
Registered User
jcervantes11's Avatar
Quote:
Originally Posted by thunderfrog View Post
I can see by some photos that people are leaving the stickers on there motors.
I've read in a couple of difference threads of stickers coming undone and screwing up the motor.
Just a thought.

I like your flying tumbler especially the piro/flips. I can do a loop, roll, and some inverted flight.
But anything else I try on the simulator usually ends with a crash.
I'll keep practicing.
I heard about that but i'm to lazy to take the label off also it takes away the looks. LOL but i took it off already. Well that damn hk 401b gyro kick ass then my xmhobbies g401b i used last. I'm going to check if the gyro is loose inside with the xmhobbies. Their both the same gyro just different label also.
Old Mar 06, 2010, 05:33 PM
thunderfrog is offline
Find More Posts by thunderfrog
Registered User
thunderfrog's Avatar
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?
Old Mar 06, 2010, 05:56 PM
Melnic is offline
Find More Posts by Melnic
Team Wack-a-Mole
Melnic's Avatar
Quote:
Originally Posted by thunderfrog View Post
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?

Flashing AR6100 or 6200 lights means it rebooted in flight. It could have been static or a power drop. Do you have a switching BEC supplying power? Using digital servos?
Old Mar 06, 2010, 06:03 PM
MikeHRC is offline
Find More Posts by MikeHRC
Team Mulikow 3D
Quote:
Originally Posted by thunderfrog View Post
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?
The flashing lights mean that your Tx lost contact with your Rx, what probably happened was that you flew one flight, changed batteries and then flew another with out turning the DX6i off and on again.

To avoid this ....... turn Tx on, Connect battery to heli, fly, disconnect heli battery, Tx off then on again, fit and connect new heli battery, fly, disconnect heli battery etc etc. etc.
Old Mar 06, 2010, 06:31 PM
jcervantes11 is offline
Find More Posts by jcervantes11
Registered User
jcervantes11's Avatar
Quote:
Originally Posted by thunderfrog View Post
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?
Get the align upgrade kit that comes with paddles, landing gear and tail blade. Under 10 bucks.
Old Mar 06, 2010, 06:45 PM
mainblades is offline
Find More Posts by mainblades
What is a plank?
mainblades's Avatar
Quote:
Originally Posted by Melnic View Post
mainblades, that a fusonic 9257 on the tail?
Is it the digital or analog version?
Let me know how it performs.
Yes it is and digital. So far break in batts. Here is a video, gain is a bit high.
http://www.youtube.com/watch?v=zTI5AB-SZVo This was before i got my replacement parts from xheli. Got them in and installed. All was perfect. Boom holder and seesaw.
Old Mar 06, 2010, 08:00 PM
jcervantes11 is offline
Find More Posts by jcervantes11
Registered User
jcervantes11's Avatar
Quote:
Originally Posted by Melnic View Post
Flashing AR6100 or 6200 lights means it rebooted in flight. It could have been static or a power drop. Do you have a switching BEC supplying power? Using digital servos?
Melnic ever baught the linkage rod? If so does it come with both small plastic link and longer one? They all look one side, when i baught the linkage rod and plastic link, it was all smaller one, even smaller then what the kit have.

http://ep.yimg.com/ca/I/yhst-9458232..._2093_20117778
Old Mar 06, 2010, 09:08 PM
thunderfrog is offline
Find More Posts by thunderfrog
Registered User
thunderfrog's Avatar
Quote:
Originally Posted by Melnic View Post
Flashing AR6100 or 6200 lights means it rebooted in flight. It could have been static or a power drop. Do you have a switching BEC supplying power? Using digital servos?
Im using the turnigy plush 80a w/ubec and turnigy 930 servos.
Im not using an external bec.
Im sure I turned off the transmitter after the first flight.
I rebound it and going to have to keep an eye on it.
I think the motor rpms dropped a little during flight, thats why I landed, then I noticed the lights flashing.
Old Mar 06, 2010, 11:20 PM
anton831 is offline
Find More Posts by anton831
Registered User
[QUOTE=thunderfrog;14526345]Im using the turnigy plush 80a w/ubec and turnigy 930 servos

your having static problems thats what the 500 helis are known for. they came out with the tt for one of those reasons if you keep flying it that way its going to get a mind of its own, the simply fix is running a gound wire thats in early post if you herd the motor lose power it was going into failsafe for a split second,with helis everything happens so fast
Old Mar 06, 2010, 11:24 PM
jcervantes11 is offline
Find More Posts by jcervantes11
Registered User
jcervantes11's Avatar
Quote:
Originally Posted by thunderfrog View Post
Im using the turnigy plush 80a w/ubec and turnigy 930 servos.
Im not using an external bec.
Im sure I turned off the transmitter after the first flight.
I rebound it and going to have to keep an eye on it.
I think the motor rpms dropped a little during flight, thats why I landed, then I noticed the lights flashing.
Thunderfrog I have no issue with my dx6i with ar7000.
Old Mar 07, 2010, 12:11 AM
SAC - MAN is offline
Find More Posts by SAC - MAN
Registered User
SAC - MAN's Avatar
what do most of you fly in fixed end points or governor mode ?? I have been flying my 500 in gov mode but have always flown my 400 in fixed end mode ?? I like the way both fly. does one work better for 3d flying ? Im not doing much 3d yet so dont know...
Old Mar 07, 2010, 12:29 AM
Melnic is offline
Find More Posts by Melnic
Team Wack-a-Mole
Melnic's Avatar
Quote:
Originally Posted by thunderfrog View Post
Im using the turnigy plush 80a w/ubec and turnigy 930 servos.
Im not using an external bec.
Im sure I turned off the transmitter after the first flight.
I rebound it and going to have to keep an eye on it.
I think the motor rpms dropped a little during flight, thats why I landed, then I noticed the lights flashing.
I had a static issue once. I think it was static, but never sure. I normally silicone spray my belt every 5 or so flights. That time, it was dry outside (fall) and I had not sprayed the belt in a while.
Old Mar 07, 2010, 06:37 AM
mainblades is offline
Find More Posts by mainblades
What is a plank?
mainblades's Avatar
What do you all have your low voltage cutoff set to on your esc? 3.0v or 3.2v


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product EXI 500 Carbon Edition RC Helicopter & 450/500 Fiberglass Canopies starting $12.95 xheli XHeli 2 Oct 06, 2009 05:03 PM
Discussion Official Trex 500 Thread? learninginverted Electric Heli Talk 0 Mar 17, 2008 11:57 PM