RealFlight G4.5 - RC Groups
Thread Tools
Jan 13, 2009, 01:16 PM
Registered User

RealFlight G4.5

I hope there are some computer gurus on this forum because I am having a problem starting RealFlight G4.5 which I just purchased. I'm not new to computers, but am new to the RC world. I am running windows vista home premium, which came with directx 10. When I installed G4.5 it stated that it requires directx 9 or later (I think that is the way it was worded) so I did not install the version 9 which was on the installation disk as I already had direct x 10. Here is the problem I'm having.
When I try to launch the sim it comes up with this message. Cannot find import; dll may be missing, corrupt, or wrong version. File "d3dx9-36.dll error 126. From looking at the file it appears that it's trying to find a directx 9 file, which of course I'm assuming would not be there because of directx 10 being the version that comes with vista. I've googled for information pertaining to this file and here is where I'm getting confused. I do not want to screw up directx 10 because of it being the latest version and my video card supports it. Some of the sites I've visited said that installing version 9 would not overwrite any of version 10 files and both versions could co-exist under vista. Some sites say no, while still others say it will only install certain files and I would retain version 10.
Has anyone else run accross this problem with G4.5 and vista? And if so does it still show version 10 when you run dxdiag?
I've had RealFlight installed since last Saturday and am really wanting to start using it, so any help will be greatly appreciated.

Sign up now
to remove ads between posts
Jan 13, 2009, 03:20 PM
3D Soon-To-Be....
Marcinb's Avatar
Have you tried to reinstall the program? Seems to me that some file must have not been installed. I'm thinking the installation got disrupted at one point, which didn't install something. I would try to reinstall it, and if that does not work, call them up at customer support. They should know what to do.
Jan 13, 2009, 04:07 PM
Failure is an option !
austin13's Avatar
I have EXACTLY the same issue. So that i just emailed the tech support with data log. Will post when going forward on the issue.
Jan 14, 2009, 12:54 PM
Registered User
Originally Posted by austin13
I have EXACTLY the same issue. So that i just emailed the tech support with data log. Will post when going forward on the issue.
Would love to hear what they have to say about this issue. Keep us informed.

Jan 14, 2009, 02:08 PM
Failure is an option !
austin13's Avatar
Here is their answer :
I did what they said and you know what : it works !!

so :
1- Uninstall G4.5
2- Reinstall it
3- accept directX 9 installation
4- it works now !!

i launched DXDIAG afterwards and saw that Direct X 10 is still active and present. So that it is all fine !!

Now just have fun. G4.5 looks cool (10 minutes test for the moment )


Please be aware that the file "d3dx9_36.dll" is a Windows system file,
specifically that file belongs to Microsoft's DirectX (DirectX is the
part of Window that offer the software tools for running 3D games). If
d3dx9_36.dll is currently missing, corrupt, or the version of that
file is too old under Windows, RealFlight G4.5 will not launch
successfully since the new graphics and visual effects introduced with
G4.5 do utilize that file (G4.0 did not use d3dx9_36.dll). To help
restore function to that file, here is a link to the Microsoft
Downloads page where you can find a DirectX End-User Runtime Web
Installer that should update your installation of DirectX and
fix/replace the "d3dx9_36.dll" error:

You have to download directx 9, this file is in directx9.

PLEASE REMEMBER to attach all previous correspondence (and dxdiag
information if previously requested) with our responses to any follow up
e-mail you may send. This will allow us to better track our attempts to
troubleshoot your problem. Unfortunately, due to the volume of e-mail we

You can also reach our product support technical team at 217-398-8970
during our regular business hours Monday through Friday 8am to 7pm
Central time. Be sure to have your computer specifications and serial
number for your software available at the time of your call.

In an effort to provide you with the fastest, most up-to-date support
available, we have developed a new web site dedicated specifically to
answering your questions or concerns regarding all versions of our
software. Most of the difficulties users have running our software are
related to problems we have already seen many times before, and have
consequently developed reliable solutions to correct. Please try
visiting this new resource we have developed for you. Most likely your
problem or concern has already been encountered before and the fix or
answer you need is already there waiting for you! You can visit this new
site at . Please give it a try!


Mubanga C -PS9003
Product Support
Great Planes Model Distributors


o/ \o
Jan 14, 2009, 04:39 PM
Registered User
Thanks Austin. Going to do as you've shown per their instructions and hope I get the same results.

Jan 14, 2009, 05:14 PM
Registered User
Austin. One question. Did you leave the controller plugged into the usb port during the reinstallation?

Jan 15, 2009, 11:38 AM
Failure is an option !
austin13's Avatar
My pleasure
I unplugged the TX just in case and replugged after full installation.
Jan 15, 2009, 01:04 PM
Registered User
RealFlight installed and working great as far as I can tell. And directx 10 is still being displayed also. Austin, I reinstalled before reading your last post about unplugging the TX and then plugging back. I did my reinstallation with the TX plugged in from the initial install, but as I said everything seems ok. I don't know if this happened to you though, but after this install when I clicked on RealFlight G4.5 Launcher it loaded without me having to enter the serial numbers from the disk case and the TX controller.
Only been at this RC hobby for about 6 weeks and I'm not doing too bad at the flying field, but this simulation program is bound to inprove my skills.
Thanks for the information you provided Austin.

Jan 15, 2009, 01:34 PM
Registered User
It doesn't matter if the InterLink is plugged in or not during installation.

One of the uninstall options removes the serial numbers if it's checked. You probably didn't select that when you uninstalled (and in a case like this there is no need to remove the serial numbers), so they were still on your computer after reinstalling.

To fix the original missing d3dx9_36.dll problem, rather than reinstalling you also could have followed the instructions in the email you posted from tech support and used this link to fix the DirectX installation.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion RealFlight G4.5 redlined_b16a Electric Heli Talk 16 Nov 12, 2009 03:30 PM
Discussion RealFlight G4.5 vs Aerofly Pro Sword7 Simulators 10 Nov 05, 2009 04:19 PM
Discussion 4 axis slope setup RealFlight G4.5 rsalar Simulators 3 Aug 04, 2009 12:22 AM
Sold Brand New Realflight G4.5 RichR Aircraft - General - Miscellaneous (FS/W) 1 Dec 27, 2008 12:47 PM
Discussion realflight G4.5 Streamers elrock Simulators 1 Dec 25, 2008 11:47 AM