Esky Lama V4 won't fly: Red & Green flashing lights - Page 2 - RC Groups
Thread Tools
Apr 15, 2009, 09:06 PM
Fly like they're cheap to fix!

$ in 1 flashing red/green,red/green.

Just a tidbit of info, from my own experiments. If the throttle stick and throttle trim slide is not all the way down, the 4 in 1 will not initalize, BUT it WILL not go red/green. The LED will just STAY red continually,till the throttle stick or trim slide is moved down. Without doing anything other than just moving the throttle stick or slide down,no reconnecting the battery or anything,the status LED will go steady green after flashing green several times. Move the throttle up now and you have rotor RPM.
Taking the crystal OUT of the transmitter and connecting the battery results in the dreaded red/green flash everyone is discussing. Taking the crystal out of the 4 in 1 results in the same red/green flashing LED.
Nothing I have tried with the transmitter settings results in the red/green flashes,only solid red. I have tried this on all three of my birds and all react the same. My best guess is the crystals or the 4 in 1 is causing the red/green, not the trans settings. HTH.

Sign up now
to remove ads between posts
Dec 14, 2009, 05:03 PM
Registered User
I am experiencing the same red/green blinking light problem. The only difference is that I have these problems because my v4 found the bottom of a creek.

At any rate, I just received a new 4 in 1 and motors and replaced all of them and connected them to a fresh battery along with the servos and am getting the same result. The only things I did not replace were the servos. I guess those are next. If I still have red/green blinking lights, I'm not sure what to do other than buy a new TX just to be sure.

Does anyone know if there is a way to link my transmitter with a new 4 in 1 or does all of that happen automatically when I connect it to a battery with the TX already turned on?

Dec 14, 2009, 11:54 PM
Fly Runaway Fans
Brian, is your transmitter MHz or GHz? MHz only has to match crystals (and modulation scheme, varies some between brands). GHz RX has to be 'introduced' to its TX in a formal procedure. It's in the book under "binding". The instructions are scant (like all Esky) and the bind button is a little hard to find.

Yes the servos could be damaged by water. Once you get binding, confirm servo response. I might go a step further/safer. Bind with motors and servos unplugged. Depending 'how bad' the servos may be, they could kill the BEC and the longer they're energized the greater the risk. Connect one at a time. If it doesn't respond, remove power immediately, replace servo(s).
Dec 16, 2009, 08:26 PM
Registered User
VaNDAL_UK's Avatar
I have a Lama V3 I don't have the original TX EK2-0404. I'm trying to use a
Futaba T6EXA. I have a set of single conversion Futaba crystals and a set of GWS single conversion crystals. I'm still getting the Red / Green flashing LED!!

Some times I get random servo movements follwed by a random spool up. I know the Futaba TX and crystals work as I used them on an Esky Honey Bee with the Futaba crystals fine. I have since sold that.

I'm at a loss here I don't want to have to buy an Esky tx as I have two perfectly good Futaba T6EXA's right here.

I have two 4 in 1's One is new and other is older. Both are doing the same. I either get flashing LED or random servo jitter. Makes no odds weather my throttle is high, low, mid, reversed or normal. same for mixing the futaba and GWS crystals.

It is like the 4 in 1 isn't getting a signal from the TX at all.

Dec 16, 2009, 10:35 PM
Fly Runaway Fans
Can't advise about mixing radioset brands, I never tried that.

Does seem that if it worked with another Esky MHz RX it should work with the present one. But yes, the twitching servos and random spinups sound like the RX sees no TX at all.
Dec 17, 2009, 03:33 PM
Registered User
VaNDAL_UK's Avatar

Ive done the only thing left to do! I bought this

If it don't work after this I may just piss on it from a great hight! Rinse it under the tap and sell it on fleabay.
Dec 17, 2009, 05:49 PM
Registered User
VaNDAL_UK's Avatar
Here is a video of whats happening

ESKY LAMA V3 4 in 1 Red / Green not initializing EK2-0705B Futaba T6EXA (3 min 24 sec)
Dec 30, 2009, 02:40 PM
Registered User
Thank you very much for answering my post...

I do have a GHZ system. I looked in the manual at the binding instructions and you are right. THEY SUCK. I don't have a clue what to do by looking at those instructions. The picture in the book doesn't look like any part on the heli or the transmitter.

Any more details on how to bind my heli to my transmitter?

Thanks again,
Dec 30, 2009, 11:26 PM
Registered User

UPDATE: I did successfully bind my 2.4 GHz transmitter to my receiver on my Lama V4. However, it only lasted for one flight. Once I ran down the battery and shut the heli down, I plugged up the battery and left things alone for a few hours. I came back to it with a fresh battery and found that it was unresponsive once again. I went to bind them again and realized the signal indicator light on the transmitter was not blinking upon powering it on. Thus, it doesn't seem the transmitter is sending binding information to the receiver.

Do you know if Esky is known for over all crappy transmitters? This is the second one I've had and this was is right out of the box! Any help or advice would be great.

Dec 30, 2009, 11:34 PM
Real name's Teja :)
teha99's Avatar
for original problem, you need another transmitter. I had the same problem, the esky 2.4ghz tx's do not have the best reputations. They just randomly stop binding to the 4in1. I just bot new tx from some place online for about 30 bucks and it solved the problem.
Feb 27, 2010, 12:59 PM
Registered User
I had the red/green problem too. It means that the receiver is not bound to the transmitter. It took a while to figure out, but you need to unbind and rebind the receiver and transmitter. The instructions in the manual are... not very helpful. I have created a page with very clear, step-by-step instructions, with photos, that folks can follow to unbind/rebind their Esky Lama V4 (and probably other similar models like the v3?). It worked great on my V4 and now I'm happily flying it and breaking blades!

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Lama v4 doesn't fly anymore... QuErorZ Electric Heli Talk 1 Oct 06, 2008 10:50 PM
New Product NEW 2.4GHz Esky Lama V4 Ready To Fly Helicopter Kit Quah Micro Helis 2 Mar 19, 2008 10:11 AM
Discussion Esky won't fly esky rookie Micro Helis 4 Oct 15, 2007 11:54 AM
Discussion Phoenix CP Heli Charged Battery 2 Lights(Red Green Flashing) No Response dhillonbros Micro Helis 5 Feb 10, 2006 11:12 AM
Lil Hornet is a dog, then won't fly Al P Parkflyers 7 Sep 09, 2001 04:22 PM