Motor isn't working, everything else is. problem? - RC Groups
Thread Tools
Dec 28, 2008, 01:18 AM
Registered User

Motor isn't working, everything else is. problem?

I bought a used RTF zagi for a friend in the classifieds, and the motor is not working. It worked when I first got it, but since then it has not.

I can't figure out what's wrong- I've tried two transmitters, I swapped motors, and even the reciever. This lead me to believe it was the esc, but I still have elevon control so the built in BEC is working. I dont' see how the esc could have gone out so fast when I havne't even flown the plane yet either?

Any help is appreciated,
Sign up now
to remove ads between posts
Dec 28, 2008, 03:51 AM
Registered User
It's possible the BEC part of the ESC is working while the speed control part isn't.

First of all, what kind of ESC and motor is it -- brushed or brushless?

To check that the throttle channel of your receiver and transmitter is working, unplug your motor from the ESC then plug your ESC into any spare receiver channel, and plug one of your servos into the throttle channel. The servo should then respond to transmitter throttle stick movements.

(Or, if you've got a receiver battery lying around, uplug the ESC from the receiver, plug in a charged receiver battery to any receiver socket, and then plug one of your servos into the throttle channel.)
Dec 28, 2008, 06:46 AM
Registered User
Unfortunately, iv'e already tried using another reciever. Same result.

The setup is the stock zagi 400x- brushed speed 400, 20 amp esc, 9.6v nicad.

Anything else?
Dec 28, 2008, 06:56 AM
Registered User
Originally Posted by 7ender
Unfortunately, iv'e already tried using another reciever. Same result...
It still could be a transmitter problem Using a servo in the throttle channel would rule that out. Since you've already had it working okay, I'm also ruling out another common cause of motors not running, which is the throttle channel on the transmitter needing to be reversed.

Other possible problems are the ESC has died, or the motor has some kind of problem like a broken wire or a bad brush. The motor's the cheapest component to replace, so have you got another one you can try in its place?
Dec 28, 2008, 08:01 AM
Registered User
flypaper 2's Avatar
First off, take the prop off so that when it does work you don't cut up vital parts. If it's Futaba trans., the throttle needs to be reversed, although you say it was working at first. Most ESCs need to be armed before they'll operate. Some need the throttle stick to be put at the top for a few seconds, usually giving a beeping noise for recognition, then put the stick back down to the bottom. Another setup needs the throttle point low enough to arm. Try lowering the throttle end point, and/or the throttle trim to the bottom. There again it usually gives a beep when it arms.
Dec 28, 2008, 09:08 AM
Registered User
smurf's Avatar
My guess is it is one of the above mentioned ideas. If you rule those out:

Since you have a brushed motor, it can be tested directly with the battery leads. Be sure the prop is off, unplug the motor from the ESC and connect one battery lead to one end of the motor lead and the other lead to the other motor lead. It will not hurt if you run the motor backwards for a few seconds if the leads are reversed.
Dec 28, 2008, 10:28 AM
Registered User
Challenger 413's Avatar
Check the solder joints on the male/female bullet connectors.

Dec 28, 2008, 04:48 PM
Speed cost money.
highflier's Avatar
The Stock Zagi ESC have a high failure rate, I had a similar issue that was intermitent, I swap ESC and have not had a problem since. I have a upgrade ESC for a brushed Zagi. It could be yours cheap if you need one. Also make sure you arm the ESC properly.

Throttle off
Plug battery in.
Go full throttle
Wait for the beeps,
Go 0 throttle.
Wait a few seconds now you are live
Throttle up and test.

If that does not work, Check servo reverse

Oh make sure that throttle trip is set real low that could cuase it to not arm also.


PS. PM me if you want a brushed esc cheap. Of course I will tell you right now a cheap brushless setup will br so much nicer then the brushed setup.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Ed! Your email isn't working? U812 Electric Ducted Fan Jet Talk 1 Jun 25, 2004 09:48 PM
Help! my new setup isn't working....... lightbarguy Micro Helis 4 Jan 18, 2004 11:42 AM
Throttle isn't working properly with Berg 4 DSP Wings Radios 5 Sep 02, 2003 09:24 PM
E-Streak motor (stock motor isn't good enough for me) CrazyMike Sport Planes 207 Nov 22, 2002 06:27 PM
RFS-100 isn't working for me? Crasher Scratchbuilt Indoor and Micro Models 29 Mar 14, 2002 01:01 AM