Another new 2.4GHz system! - Page 348 - RC Groups
Thread Tools
Jun 28, 2013, 09:12 AM
Registered User
Thank you for the link to RC caclulator. Its defenately very useful.

I think I had programmed correctly. Actually i'm sure and even several times. I used program card for programming my ESCs for my motors. I programmed as per instructions given for the firmware developer. And yes, I always suspected for ESC programing. some of significant reasons:
1. Break- Even i always choose OFF, we can see in above video its shows hard break.( for one experiment, i used soft break, that time it was soft break. )

2. many times feel that motors are not working expected like, for roll movement, if we expect right motor should speed up- than there is no peticular change can be noticed, means change in speed of any of four motors will not similar for similar control stick movement.

3. In this latest setup(???) motor #4 is the most powerful motor. it starts almost immediately after very little application of throttle stick and almost very low decrease in speed even complete up throttle.

I on very first attempt i programmed ESC for Lipo as i am going to use it. But after that I was strongly recomanded by many experts to be with developers suggestion that battery should be choosen as NiMH

Sorry to say but i didnot understood your doubts-
- one of them cuts-off power for wrong battery count programmation
- one of them enter in throttle-calibration mode

Try disconnecting the stopping esc, connecting it directly to your rx throttle channel and verifying if it behaves normally as if it was in a plane And yes, I tried many times to check if any misbehavior of motor - ESC without flight control board for all of four motors, but found they are working as fine as new.

please also check
Originally Posted by drpiyush

.................I also tried your desktop verson for competability. I need little explanation for my understnding. Herewith I attached a few screenshots.
first screenshots are showing stick readings something like 512(@throttle stick near 60%).... for all sticks, second shows similar- just changed the throttle to zero position and its reading is 103. can i understand what is this figure exactly showing? I dont think it should be the pulse size in usec....

third image shows that when i attemtp to save the settings, sw needs mix 3 settings also, rightnow actually i'm trying to set this tx for my custom quadcopter, and i never heard about any mix is necessary for quad. then how can i skip mix3 or is there any value for mix3 which will not affect my flying?
Thank you for all previous and future help.
Sign up now
to remove ads between posts
Jun 28, 2013, 09:57 AM
Registered User
willy163's Avatar
I own same kind of esc on my quad X but it is still under construction.

While trying esc one by one with a servo tester, I noticed an unconstant power reponse because each time ESC entered in throttle calibration mode (ESC learn minimum and maximum throttle values).
Try to connect a servo instead of an ESC and watch at the initialization sequence.

I'm afraid we're going off-topic.

Jul 02, 2013, 11:00 AM
Registered User
Thak you agin Will for nice update and good explanation.

I'm sorry but can not understood little "an unconstant power reponse & the initialization sequence" Infact, at now, i should doubt on eighter ESC or FC board's output on M#1 to #4.

Yet, ESC are working very normal if join direct to throttle ch of Rx and gives very smooth responce on Tx. Did you feel an unconstant power reponse in my video?
MVI 0318 (1 min 19 sec)

Is there any method that i can check the pulse (signal) controling the ESC coming from FCboard? Actually i'm limited to use multimeter only- don't have facility and experiance to use oscilloscope. If oscilloscope is the only option I can ask some of known to borrow, but still need little info how to use it.

Or if anything else that I'm missing to check please guide me how to check set by step.
Jul 02, 2013, 12:36 PM
Registered User
Originally Posted by drpiyush
Is there any method that i can check the pulse (signal) controling the ESC coming from FCboard?
Which flight control board are you using?
Jul 03, 2013, 02:56 AM
Registered User
Originally Posted by iksbob
Which flight control board are you using?
its KKmulticontroller V5.5 Controller Board V2.2 hopefully its the popular blackboard. and more thing- i was supplied V2.3

I used different fw from lazyzero's depository to some from rcgroups different forums- but i used most the KK Software for Original Board with Stick Centreing

Originally Posted by drpiyush

First of all, thank you for your kind guidance towards this thread.

Thank you for this very nice development. I'm impressed with reviews others stated here. I installed Xconfig KK_QuadX_V4_7_SS5_SC_M168.hex using, with USBasb. Earlier my tri fw on this same board was also sucessfully installed, and this time also i was very secessful to install your fw.

But following your instruction, to center the sticks- I didn't find any blink of LED or any tipe of responce from the FC board as expected. this thing was attempted while yaw and roll pots are zero(full ccw).

How to process further?
Jul 09, 2013, 09:45 AM
Registered User
Finally i reach at another forward steps
VID_20130709_144910.3gp (0 min 9 sec)

VID_20130709_144348.3gp (0 min 11 sec)

Lot of thanks to expert over here on RCG.
Jul 17, 2013, 02:56 AM
Registered User
Originally Posted by willy163
I can't see your video now. But... if channel position "jumps" while moving sticks, you can use some contact cleaner spray inside potentiometers (you must disassemble cover to do this).
I had to do this because one of four potentiometers had some spike issue.

still i can not achieve trims on center after recalibration. I tried to mechanically set the pot -trim in center but failed. Think, i must clean the contact of the potentiometers.

I opened the cabinate but found potentiometers, but problem is i don't want to open the pot to clean, and i can not find spray contact cleaner on any online store, can you suggest any?
Jul 17, 2013, 11:31 AM
Registered User
Thank you a lot.
Jul 19, 2013, 09:21 AM
Registered User
Tried more than 8-10 times with one offline contact cleaner (for electronics circuits and componant contacts) and tried to recalibrate the sticks. Yet not get satisfactory results. Here are the screen shots for after last recalibrate.

Should i replace the pot? In my view, the major issue is with the yaw stick. If its not DANGERIOUS as i know only little soldering compare to the electronics experts, I like to know the circuit diagram. the other alternate i think to put a register between center and a last contact of the pot........ if yes, I don't know the value should be!!!!!!
Jul 19, 2013, 01:50 PM
Registered User
The pot should have 0V at one end (ground), 5V at the other, and the center contact voltage will depend on stick position.
Jul 20, 2013, 06:24 AM
Registered User
I tried many times to clean the potentiometer using contact cleaner spray but failed every time- no expected result second option to replace the pot with new one is also didn't seems practical for me as its very hard to find exact that sized / shaped pot from my market.

another option came in mind is to put a parallal register between two the pot's pin. I found that the pot would be of 5kΩ.

Originally Posted by MoFl
Yes, it is, see photos at post#149. Could be operated independently as soon as you feed it with +5V. In fact, I'm thinking of extracting it from the turborix and installing it in
now pl see the image pot.jpg, if I have recalibrated and still the trim comes between e.g. R and X point of the point- Can i make the trim center using some fixed value register between R and X (or B and X)? if yes, what value should be tested? ( i mean which different value of registers to be tested to make the trim exactly on center?)

will this work?
Jul 20, 2013, 07:05 AM
Registered User
Ultimately i cheat my radio and recalibrate exe.

I followed several trial and error method to cheat the recalibrate exe to make the trim in the center. I really don't know will this helpful for my quad flying . but let me tell you what i did and before i say what i did, let me tell in details what exactly the trim error.

Ch-1 trim wasbit left about 4-5points from physical center of trim
ch-2 trim was bit high.. about 3 points from physical center of trim
ch-4 trim was almost @ 50% from physical center and left of trim

I followed several trials...... In process of recalibrate, its strictly told to put joystick + trim extream left and low to extreem right and up. here i cheat that instead of extream left joystick(in case of ch-4) i leave little space i.e. didn't put the joystick to extream left. In case of the ch1 and ch-2 as there was little offset, so i left space in case of the trim. here is the screenshot for the center of ch1,2,4 with low throttle.
Jul 21, 2013, 06:54 AM
Registered User
I do not really understand how you recalibrate the sticks.

Normally you start 'Adjust'. then you move every stick (including the trim) and the pots to it's maximum left/right/up/down/end position without using any force at the limits and then you 'Stop Adjust'

This allows the radio to measure the analog values of the stick extremes and calculate the middle value that then gives the neutral position.

If your throttle stick does not center or skips when moved, I would as a first check, open the radio and verify, that the pot of the stick does not move, when the stick is moved.
Next step was to measure the voltages on that pot. Find a good ground spot and measure against that. The two outer pins of the pot should have stable 0V and +5Volt.
As next, find a good +5volt spot and measure the ground pin of the pot. Voltage must be stable. This ensures, that ground signal is ok also.
Then check the middle pin against ground. It should vary smoothly without skipping between values from (I suppose) near +5V down to near 0 volt ; could also be from around 3.5v to 1.5 volt (I'm not sure about the range, but you could compare it with a working pot/stick).

If the middle pin fails, unsolder the wires from the pot and measure the resistance. This should give skipping values also. That would verify, that it is really the pot that is failing.

As contact spray did not resolve your problem, you should think of disassembling the sticks. Before you open the pot, check the mechanical contact of the pins versus the body of the pot track. I had a pot where the pins were riveted to the trace and that rivet was loose. You can try to really carefully tighten such a rivet.

Jul 22, 2013, 01:58 AM
Registered User
Resp Reinhard

Thanks a lot for the deep explaintion of faultfinding. I was from biology and totally dumb in electronics but you explained very carefully that i was much happy now.

Originally Posted by ReSt
I do not really understand how you recalibrate the sticks.
Sorry for my poor explaination. I will try to make a video for it, just need little time.

Next step was to measure the voltages on that pot. Find a good ground spot and measure against that. The two outer pins of the pot should have stable 0V and +5Volt.
As next, find a good +5volt spot and measure the ground pin of the pot. Voltage must be stable. This ensures, that ground signal is ok also.
What stands for this good...?

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product X8---new 2.4GHz Radio System ASSAN Radios 5745 Mar 15, 2017 11:31 AM
Yippee! New 2.4GHz DSM radio - New standard? PrasadL Scratchbuilt Indoor and Micro Models 12 Jun 03, 2013 08:03 AM
For Sale NEW - 2.4GHZ 2 channel Pistol R/C system SRM Cars - Cars and Parts (FS/W) 0 Oct 22, 2008 10:39 AM
FS: 1x Used 1x New 2.4ghz Wireless video cameras with receiver Nik-rc Aircraft - Electric - Airplanes (FS/W) 4 Nov 30, 2004 07:21 PM