just bought a king 2 its not working - RC Groups
Thread Tools
Sep 10, 2008, 03:06 PM
Registered User

just bought a king 2 its not working

Hi guys i just got a esky honeybee king 2. I flew it last night well first time flying a helicopter so i got it off the ground but nothing fancy.
This after noon i went to try again after having charged the battery and nothing happened the light on the reciever flashed twice then went out.

The trans just keeps flashing and so does the gyro. Reading the manual i gathered the two needed binding so i reset the rx but now i cant get them to rebind

Was that the prblem in the first place and how do i rebind the tx and rx

Many thanks

Sign up now
to remove ads between posts
Sep 10, 2008, 03:38 PM
Idle up!
This may not be a binding problem.. The stock rate gyro is sensative to humidity levels.. it could be that the gyro is not locking in.
Sep 10, 2008, 03:41 PM
Registered User
cheers for that reply mate if that is the problem how do i fix it do i need a new one and what would be a good replacment

also i still need to rebind the controller i followed the instructions but it dosent seem to be working

cheers again

Sep 10, 2008, 03:45 PM
Idle up!
Basically you need to put the heli in a dry place for 30minutes or so..

The king II has some absolute changes you need to make to it.

You need to go brushless motor/esc
T-rex 450 tail blades
and a better gyro is also a good idea

The worst case scenario is that your esc has blown.. this is a VERY common problem with this heli. You would know if it went. Smell of burnt electrics..etc..
Sep 10, 2008, 04:04 PM
Registered User
ok there was no burning smell the amber light is still flashing slowly but dosent stop on the receiver

the transmitters led also flashes and dosent stop

i have tried many times to bind the two but to no avail i have an esky ek2-0406g

Sep 10, 2008, 04:09 PM
hover happy
spinup's Avatar
Originally Posted by PLATINUM
The stock rate gyro is sensative to humidity levels..
LOL, that's a funny one.

Plati, I think you mean temperature levels. Even the cheapest piezo gyro sensors are packaged so humidity is not a factor. But anyway, temperature does not affect initialization.

On the surface, this sounds like a radio issue. e.g., the throttle stick/trim is up or the idle-up switch is on, so the radio will not initialize.

Sep 10, 2008, 04:20 PM
Registered User
lol right i have tried that all switches are off everything is at zero and it still wont work

also the instructions keep telling me to disconnect the 4 in 1 mix controller what is this i have no idea and the instructions say nothing about it other than in the rebind instructions
Sep 10, 2008, 04:21 PM
Idle up!
I noticed this mostly when its humid.. I have flown in 80-90 degree days with no/low humidity.. and it popped in fine. This particular gyro is rate only .. and seems more sensative then the other HH piezo gyros to heat/humidity..

Definately could be trim on the throttle or idle up switch on..

Bind plugs might not be secure?
Sep 10, 2008, 04:24 PM
Idle up!
4-1? lol... there is no 4-1 on a King II..
Sep 10, 2008, 04:46 PM
innocent victim
Blade_Killer's Avatar
you know, I dont remember binding the TX on a stock king2 being an option, and it doesnt have a 4 in 1, are you sure you have a King2??
Sep 10, 2008, 04:57 PM
hover happy
spinup's Avatar
ek2-0406g is one of the new 2.4ghz esky radios, which does have a binding process.

Not sure about the 4-1 reference though. Matt, what manual(s) are you reading for this info?

Sep 10, 2008, 05:19 PM
Registered User
ok its definatly a king 2 the transmitter is the 2.4 g and the manual is the manual that came with the helicopter and there was not a manual for the tranny itself and me not knowing where this 4 in 1 mix controller would be explaind by me not having one lol

Ok so shoulod i send the king 2 back to be sorted or is there something else i can try

Many thanks for the replies

Sep 10, 2008, 05:33 PM
innocent victim
Blade_Killer's Avatar
k, didnt know the 2.4 kings were out.......cool
Sep 10, 2008, 05:36 PM
Registered User
Throttle trim?

Move your throttle trim to full down before you turn on anything.

Turn on TX.

Plug in battery pack.

Do it with the heli on a level surface.

If that doesn't work, you may need to rebind your 2.4 TX to the rx.

BPhobbies have an Esky 2.4 manual available for download on their site.

Esky 6 channel 2.4ghz

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! 6EXHP plugged battery in backwards now its not working BowerR64 Radios 5 May 09, 2008 01:23 AM
Discussion i added a g90 gyro to my cp pro ... but its not working andrew sport Mini Helis 5 Feb 29, 2008 11:48 AM
Help! Honey Bee King 2 Using 30A ESC, 5V/6V Switchable BEC, Brand New, Servo not working? RcSuperSales Micro Helis 5 Aug 04, 2007 01:39 AM
Question Help - just bought an OEM power supply. Not sure how to check and set up. Peter Young Batteries and Chargers 11 Jun 16, 2003 08:02 PM
Helicopter Parkflyer..Sort of..Just look..its not in wrong forum.. SpaKack Parkflyers 8 Oct 13, 2002 11:53 AM