Zagi 400-X climb performance - RC Groups
Thread Tools
Aug 03, 2001, 11:56 AM
He wasn't always evil
AirVenture's Avatar

Zagi 400-X climb performance


I have to say I'm a little dissapointed in my Zagi 400X's climb performance. Its just slightly heavier that 25oz by 0.4 of an oz. What teqniques to you guys use to climb. It takes several climbing circles at full throttle to get maybe 40 feet high. Is there something I can do with the CG to help? What about changing the prop? Let me know what you think!
Sign up now
to remove ads between posts
Aug 03, 2001, 12:10 PM
Registered User
Cheech's Avatar
Lay off the turning during the climb. That's when a flying wing is least efficient, particularly in the bank and yank type turns. With a stock setup that's about all you can do.

I now run the $60 ProMax 4014 cobalt motor on mine. And with lighting for night flying my 400X is 1 1/2 oz heavy. Stock it flew fine, with the 4014 it got a 40% performance improvement, mostly evident in the newfound steep climb rate.
Aug 03, 2001, 03:27 PM
Registered User
toddp's Avatar
A stock setup should climb much better than that. I would guess the prop, bad connection or battery isn't fully charged.

Good Luck
Aug 03, 2001, 03:28 PM
Registered User
Checking prop is the first to start with. Also, What battery are you using? I found that if you run NiMh cells, the internal resistance is higher resulting in lower voltage out. When I used a NiMh, I needed to do alot of circling to gain altitude. I solved problem by going with 1700 Nicad's and a brushless motor. It won't take off from standing on the winglets, but it does have quite a climb rate now!

Mark
Aug 03, 2001, 05:16 PM
Registered User
mattk17's Avatar
With a completely stock setup, my 400x climbs 40 feet in less than 100 yards. My plane is not particularly light, I am using hs-81s and a 555 receiver.

[This message has been edited by mattk17 (edited 08-03-2001).]
Aug 03, 2001, 10:22 PM
He wasn't always evil
AirVenture's Avatar
Hey. I noticed that that the lettering on the prop is facing forward (while standing behind the plane). The thing is that the prop that came with the 400X (white with black spinner) has a spinner on it. But I did manage to turn the prop around so that the text is facing me (standing behind the plane). Cool guys I think this might have been the problem!

Thanks for the Help!
-Brett

(I'm running the stock 8-cell 1700mAh Nicads in her, hopefully this prop thing makes a difference!)

[This message has been edited by AirVenture (edited 08-03-2001).]
Aug 04, 2001, 01:09 AM
Registered User
Check and make sure that your prop is on the correct way. The side with the text needs to be facing backwards. If you are looking at the back of the plane you should see the text on the prop.

This will make a huge difference. I bet this is what is going on because it has a decent climb rate...