Mar 05, 2013, 02:56 AM
Registered User

quick question... cycle setting


when setting icharger to cycle, and connecting balance tap, is the "charge" part in balance mode, or straight charge mode?

i cannot tell.

pls advise, steve
Sign up now
to remove ads between posts
Mar 05, 2013, 09:42 AM
Registered User
robj's Avatar
Not pretty but works..
Mar 05, 2013, 01:39 PM
Registered User

BALANCE PORT CELL HIGH VOL error


Hi all, I looked inside my 206 charger, and couldnt see any burn marks or smell anything.

So can I get this straight: when I checked continuity between the top electrodes and the pins, there WAS continuity between the same numbered electrode and pin? and this is NOT normal? This is as described in the "bal err" document (written in stilted English). Seems like this would be NORMAL to find contnuity not ABNORMAL.

See the pics attached of my unit... no burns etc seen.

(Help appreciated, I cant use this charger right now, because pin #2 always reads high on the lipo monitor.)

Ben
Mar 05, 2013, 01:54 PM
Registered User
Quote:
Originally Posted by skinnydoc View Post
So can I get this straight: when I checked continuity between the top electrodes and the pins, there WAS continuity between the same numbered electrode and pin? and this is NOT normal?
It says that 0 Ohm (continuity) is normal.

Picture shows that there was an attempt to repair this already.

Fred
Mar 05, 2013, 02:07 PM
Registered User
Quote:
Originally Posted by robj View Post
Not pretty but works..
Very nicely done Rob!! Good doesn't need to be pretty.

Mark
Mar 05, 2013, 02:21 PM
Registered User
Quote:
Originally Posted by flarssen View Post
It says that 0 Ohm (continuity) is normal.

Picture shows that there was an attempt to repair this already.

Fred
thanks Fred. Ok, sorry for idiocy, so 0 resistance, so I see the current flow on my multimeter (needle jumping). That is what I see, so there IS continuity.

I put that little jumper wire shown in my pic a few years ago, when I was getting an error, I actually cant remember the details now. The wire jumper is intact now, there is continuity between the connected poles.

What else can I do to get my cool little charger working again? I'll need it soon.

thanks, tips appreciated

Ben
Mar 05, 2013, 07:14 PM
Registered User
toolman18's Avatar
So my 106 is not working. I can't find anything burnt. Went ahead and bought another. Is there a market for his charger? I have heard they are repairable. Thanks
Mar 05, 2013, 11:15 PM
Registered User

pic...


here is what I'm seeing on the voltage monitor.
Mar 06, 2013, 12:05 AM
Registered User
Quote:
Originally Posted by skinnydoc View Post
here is what I'm seeing on the voltage monitor.
Is the offset in voltage always the same? If so, it could be a calibration issue. I believe burned tracks gives more random numbers.

Fred
Mar 07, 2013, 01:16 PM
Registered User
I have an 106b, not the plus one, and after replacing all the mosfets the unit keep shorting the PS, when a use a short protection power supply, and try to charge any battery, the psu disarm.
When i use a non protected power supply, the charger simply reboot.

Any sugestions ?
Mar 07, 2013, 08:47 PM
iCharger
junsi's Avatar
Quote:
Originally Posted by gustavo_123 View Post
I have an 106b, not the plus one, and after replacing all the mosfets the unit keep shorting the PS, when a use a short protection power supply, and try to charge any battery, the psu disarm.
When i use a non protected power supply, the charger simply reboot.
Please check the PM we have sent to you.

Junsi
Mar 09, 2013, 03:36 AM
Glow 😡 no no no
Problem fixed
Last edited by aeromaniac; Mar 09, 2013 at 11:02 AM.
Mar 11, 2013, 09:06 PM
Registered User
I have 2 106b chargers that need a few buttons...

Does anyone sell them, or am I going to radioshack tomorrow?
Mar 12, 2013, 09:17 AM
Registered User
rizky_p's Avatar
My Friends 106+ Fan just stopped working, can anyone be so kind to tell me what is the specification?
I need to replace Start button on mine it is now need to be pushed really hard to trigger anything any advice?

thanks.
Mar 12, 2013, 11:29 AM
Registered User
Hi junsi,
I have bought icharger 3010b it is a very good charger for my LIPOs, but accidentally i burnted it (bad power supplier was used). I need to replace whole deck(board) with fets. Is it possible to purchase it or get scheme to make by myself.
Excuse me for my english i am from Russia


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Best charger/discharger $ can buy namancio Batteries and Chargers 30 Jan 31, 2010 02:52 PM
Power Pacer Battery charger/discharger ACE_McCOOL Batteries and Chargers 4 Oct 22, 2002 12:39 PM
NIB Hitec CG-325 Charger/Discharger/Cycler for 4-9 cells - $39! Jason M Aircraft - Electric - Airplanes (FS/W) 0 Oct 03, 2002 03:29 AM
WTB Good charger/discharger 10 + cells WickedFunRC Aircraft - Electric - Airplanes (FS/W) 0 Sep 05, 2002 08:55 PM