Thread Tools
This thread is privately moderated by Jack Crossfire, who may elect to delete unwanted replies.
Jan 21, 2008, 12:13 AM
Registered User
Jack Crossfire's Avatar
Thread OP
Discussion

The Taiwannosaurus lives


Well, it has become quite clear that the Mega doesn't have enough RPM to do the job. More notably, there isn't enough tail rotor authority. The tail rotor problem can be solved in software but it should be more effective.

Through translational lift & collective overclocking, got her in the air, but the tail control was hopeless.

Discovered the minimum throttle must be way above minimum or the motor won't stop immediately in the failsafe modes. It always shut down, but it took 3 seconds longer when throttle was completely cut off.

A 3rd idle-up mode for debugging throttle was useless. It was easier to calibrate the throttle curve by plugging in numbers until she had enough RPM to take off. For the Mega, that was 100%. Also, it was too hard to hit engine kill with 3 positions.



The Taiwannosaurus has much more stable orientation than the Corona and much less stable position. It doesn't automatically slow down like the Corona did.

Now we have Vicacopter II's first revolutions at Corona speed, followed by maximum speed on the Mega 16/15/4, followed by blade tracking.

Vicacopter II's first revolutions (2 min 31 sec)
Last edited by Jack Crossfire; Jan 21, 2008 at 12:22 AM.
Sign up now
to remove ads between posts
Jan 21, 2008, 01:10 AM
Registered User
Realize that the default speed control mode for the Trex speed control is governor mode.
so the 100% is RPM, the speed control will regulate power to maintain a constant RPM.
I Run my Trex at about 95% throttle with a flat throttle curve.
All the Up/down is collective.


What was your RPM/head speed? (did you move that sensor across?)
Jan 21, 2008, 12:38 PM
Registered User
Stupid comment #2 Looking at your pictures

Is the box on the right side with GWS on it the tail rotor gyro?
If so isn't your gyro oriented incorrectly?
Jan 21, 2008, 01:49 PM
Registered User
Jack Crossfire's Avatar
Thread OP
On the starboard side, we have the GWS. On the port side, we have the IMU. The yaw was working normally but does not have enough counter torque. There never was a rotor tachometer.

The next problem is reprogramming for the RCE-BL35X. Invalid duty cycles shut the Phoenix 45 down after a certain delay. The RCE-BL35X never shuts down.


Quick Reply
Message:
Thread Tools