Converting TowerPro 25A type 2 ESC's from PWM to TWI/I2C control - Page 4 - RC Groups
Thread Tools
Dec 12, 2007, 06:08 PM
Registered User
Hi Bernhard,
My TP25A type 2 (W)'s have the 8114s. These came with round red sticker with a thick "W". The older version without the 5V breakout board had a thin "M" (easilly confused with a "W" of course) on them. I still have 8 TP25-W's which have to be converted. Haven't yet opened the jackets but they all have the "W" so I-m expecting them to be from the same series.
Sign up now
to remove ads between posts
Dec 21, 2007, 09:01 AM
Registered User
A little update. Bernard's tests have not yet identified a solution to the ESCs overheating that some people have encountered, other than replacing the FETs (which isn't very expensive to do).

I hadn't really tested the ESCs after prolonged runs, hadn't had any time until this afternoon. But on my short tests, and even on burning out motors due to the original conversion error, they had not been warm at all while I always tested with 3S.

I just ran an unconverted 25A ESC with a 8x3.8 APC-E prop on 3S for several minutes using my last A20-20L clone, pulling 10-12A at sustained full throttle. Motor got warm but ESC hardly. So I then switched to a GWS 10x8 prop --way too much for the poor little motor and throttle up to about 20A continuous for 1-2minutes after which the ESC was just handwarm and the motor quite hot. Throttle down to 15A but after another minute or so the motor burned out. ESC was still just handwarm, no more than 35 degrees Centigrade at most. Motor of course was very hot.

This raises several questions: Why isn't my ESC overheating at all? Were the tests by others done with no or excessive loads and did they thus exceed the ESC specs???

And a clear conclusion: No more A20-20L clones for me. They burn out too quickly, are not always properly round, have too much vibration. I think I-ll switch to the Turnigy's. Haven't really test run those but their look and feel suggests better quality at a marginally higher price. I still have some A20-22L's which I-ll test on one of my frames, but once they die, the remainder will be delegated to bench-testing.
Dec 26, 2007, 09:40 AM
Registered User
brashley's Avatar

Need Help

repost from Mikrokopter thread but this time with pictures:

I am having problems with the TowerPro 25A conversion. I did all the drilling/wiring, ohmed out all connections to make sure I didnít have any shorts, ohmed out from the PCB to the SerCom to make sure I had all the ISP connections and caballing correct, checked the 5V on the PCB, green light is on SerCom but I still cant get PonyProg to see the device. PonyProg reports back the ďDevice is not present or is unknownĒ If I hit ignore it reads but returns all 00, I cant even read or write the fuse bits. Writing fails as well. I even changed the .ini files with the suggested settings for ATMEGA8.

Any suggestions on trouble shooting this one?


Dec 26, 2007, 12:38 PM
Registered User
Working back on your pics from the SerCom:
1 = Mosi = Brown
2 = 5V = Red
5 = RST = Green
7 = SCK = Violet
9 = Miso = White
10 = GND = Black

At your the ESC connector:
Mosi = Blue
5V = Red
RST = Green
SCK = Yellow
Miso = Orange
GND = Brown

At the intermediate connector the connections should be:
1 = Mosi = Brown -> Blue
2 = 5V = Red -> Red
5 = RST = Green -> Green
7 = SCK = Violet -> Yellow
9 = Miso = White -> Orange
10 = GND = Black -> Brown

As far as I can tell from the pics that is how you've wired it, so that should be OK.

I assume you're using the latest version (2.07beta) and that you've also been able to connect with PonyProg to the FC controler, i.e. that your PonyProg port is set up correctly to Com1 and to serial SI Prog API, and the correct processor chosen (AVR Micro, ATmega8). And I assume that you have put the jumper over the programming connector on SerCom when trying to program the ESC (on the pics it's off). And have you tested this ESC with a normal RX to see whether it is functioning over PPM ? If all that is the case, I-m a bit at a loss....

As a side remark, I would always either heatshrink or put connectors onto the ends of those motor wires. An accident is easilly made and shorting out those wires might not make for a happy ESC.
Dec 26, 2007, 12:43 PM
Registered User
brashley's Avatar
One update, I get this on PC_MOSI and PC_SCK lines once I plug in the SerCom board into my RS232. I dont know if this is normal or not (see photo) I know the SIO port on the SerCom works because I am able to comunicate with the MK fltctr but I have not used any of the ISP SerCom connections yet until now. Maybe I have some SerCom/cabling issue.

Dec 26, 2007, 01:30 PM
Registered User
Looking at the bright side: something's alive and creating some form of clock pulse. Have you tested resistance between the MISO, MOSI and SCK pins at the ATMega8 end without anything else connected ? That should be quite high as they should not be directly interconnected.

Haven-t looked at my scope images, but logically SCK and MOSI should be flat on SerCom as long as the ESC is not connected. And logically as long as you're not sending any serial data MOSI should be flat even if connected. Check the SerCom and the MISO, MOSI and SCK pins on both the SerCom and the ATMega8 without either being connected to the other. That may help identify whether and where you have a short somewhere.

I remember I once had a similar problem with one of the ESCs, eventually removed all wiring and redid it after which everything did work. Sometimes solder bridges behind the pins can be hair-thick and very difficult to spot.
Last edited by Arthur P.; Dec 26, 2007 at 01:39 PM.
Dec 26, 2007, 04:06 PM
Registered User
brashley's Avatar
I checked resistance between MOSI, MISO, and SCK : without anything connected Ė complete open, with SerCom connected ~15Meg to 20Meg between all of them.

One point of insignificant progress, I had been using a stock serial cable that needed a NULL Modem adapter two change pins back around. I ohmed it all out and found that Pin 1 and 6 were shorted together (should not have made any difference) so I made my own cable and double checked that everything was hooked up correctly. I reconnected the SerCom to the FltCtr through the SIO and using the MikroKopter tools and that worked ok. Of coarse SIO is just using Pins 2 & 3 (RXD & TXD) with GND through the MAX232CPE chip and that works.

I tryied using PonnyProg with ISP2 and the FltCtr and again had the same problem as with the ESC. PonnyProg wont see the ATMega device. I reinstalled PnnyProg to the latest version without any changes to my luck. I am wondering now if I am having problems with my SerCom. For the Zener Diodes on MOSI and SCK I ended up using they looked the same as specked but I am not an EE. That and the resistor network are about the only thing between the PC and the ATmega for both ISP1 and ISP2. (and my cabling)

And yes, I tried it with and without jumper. No, unfortunately, I did not try the ESC before I started the conversion.

Should I be able to read the the ATMega8 device or should I just expect to be able to program it. Perhaps I am expecting too much. I was assuming that to validate the programming that PonnyProg would have to be able to read/detect it as well. (for me the connecting/reading was the confirmation that I had it all working correctly)

Good point about covering up the exposed leads. I will fix that.

This is killing meÖÖ..
Dec 26, 2007, 10:24 PM
Registered User
brashley's Avatar
Now I have a bigger problem. In my attempt to figure out what was happening with the SerCom, I hooked up the FltCtr again to the ISP2 on the SerCom. I rechecked (ohmed out) all connections all the way back to the RS232 and found no problem. Plugged it all back in and flipped it on. PonnyProg still could not detect the ATMega644 device on the FltCtr. I plugged in the SerCom jumper and then when I hit read device on PonnyProg it found the device and started reading. The data I got back though seemed a little bit repetitive (looking at the HEX code it looked like a lot of information was being repeated every 15 or 20 lines) I was suspicious so I hit reed again to see if I would get the same information back. This time PonnyProg did not recognize the device. I unplugged the SerCom and re-powered the FltCtr. Now the FltCtr just shows a green light and is unresponsive in MK-Tools on SV1 (the red light used to come on and it used to beep because I donít have a receiver plugged in) . I tried to use the Bootloader from MK-Tools to reload the software but the FltCtr did not respond. I even tried to re-flash the boot loader using ISP2 and Mk-Tools (AVRdude) but it reported that the device did not respond. Now I donít have a FltCtr or an ESC. (&$&$^#&#(@)(#$*$^&#@*@)(#$*#*#&@)

I really think I have an issue with either the SerCom or Serial port on the PC. I suspect what happened is that since I had the jumper plugged in and even though I requested a read only that the signals are messed up (excuse the non technical term) and that what ever noise/junk on the MOSI line ended up being programmed into the ATMega and since the ISP connection is not working correctly I cant recover. The MOSI and SCK part of the circuit on the SerCom are so simple how could it go wrong? I have checked the resistances in the resistor network and they are fine (and independent). With my multimeter the diodes check ok (cant check the Zener part with that though) and the cathode is in the correct orientation. I have ohmed out across all pins from the lines on the FltCtr all the way to the end of the RS232 cable (MOSI and SCK show 4.7K and MISO shows short, all as it should be, open between all of them). I am at a total loss. I am not sure what signal levels I should be seeing on the RS232. Perhaps that is the next step.


(if the fuse bits get set wrong because of the JUNK data can they be reset?)
Dec 27, 2007, 04:50 AM
Registered User
At a loss as well. Would be strange if the SerCom was defect. Isn't much on that which can go wrong. I noted you posted a help request in the MK Forum. Let's see what the techies there come up with.
Dec 27, 2007, 10:39 AM
Registered User
brashley's Avatar
the RS232 port I was using was on the my laptop docking station and the voltages were 0v to 6v. when I took the laptop off the docking station and went directly to the back of the laptop, the voltage levels were -6v to 6v (so 12v range). I dont think that should make any difference, the Zener should clamp it down to 5V anyway.

I never seem to get anything out of the FltCtr on the MISO line. The AVR chip does not respond to any requests from either AVRDude or ponyprog. Now I just want to get my fltctr working again.....
Dec 27, 2007, 05:56 PM
Registered User
For trying to (re)program the flight controler did you use the Mini-ISP 6-pin adapter or the ISP1 on the SerCom ?

I didn't have any time today, but will hook up my SerCom to by desktop and see what tracings and voltage levels I see. I-ll be trying to upgrade from v0.64 to 0.67 as well using SerCom for one FC and using my USB based programmer (MySmartUSB) and AvrDude with a GUI on my laptop for another. If the latter works I-m going to be switching to that completely as it has a serial interface as well as the programming interface and even a TWI interface all in one on a handy USB2 based programmer. Should allow me to replace the SerCom and be able to do some tweaking on the go with my laptop computer. Hope you can be little patient....
Dec 28, 2007, 03:52 AM
Registered User
Any update on the conversion? Im having the same problem with the PonyProg not recognizing the TP25A (Type 1)...I also use a laptop with a docking station for serial port.

Dec 28, 2007, 09:00 AM
Registered User
Do either of you have access to a desktop computer with a true RS232 interface? I know PonyProg cannot work with USB based RS232 converters as it needs to address the RS232 pins directly. I would expect a true docking station to work, but no guarantees. If the RS232 on the docking station requires some special driver it may not be directly addressable. In that case AVR Dude could still work and there is a GUI for that (not as easy as PonyProg).
Dec 28, 2007, 03:28 PM
Registered User
I tried it on a desktop with a true RS232 and still no go. I got the instruction to do the mod for TowerPro 17A here . I checked the wiring and even modded a second ESC and still I can't read nor write the configuration bits. What do you guys suggest I should try next?

Last edited by bt408; Dec 28, 2007 at 03:35 PM.
Dec 28, 2007, 05:49 PM
Registered User
brashley's Avatar
Tony, no luck yet here. I took a small break; family was getting upset at all the time I was spending.

The fact that I took a good/working FltCtl board and messed it up makes me believe itís not my ESC I am having problems with (although that still could be a problem once I get the ISP working)

I am seeing noise on my MISO line whenever I force ponyprog or avrdude to try and read or write (only with SerCom connected), its as if something is coupled to it. As a mater of fact it aligns with the SCK clock puls and has some artifacts in between. If you look at the schematic (and the board) itís a straight shot (mine ohms out OK) from the RS232 to the MISO on the ATMega. I could not measure anything abnormal from the pin on the computer end of the RS232 cable through to the chip on the board (no shorts, strange ohm reading etc. )

I am in the process of building my own ISP stand alone circuit to try that. Using the sparkfun schematic as a guide (almost the same as what is on SerCom just without the RS233 TTL stuff)

I will report back when I get done (and have some pictures of the noise)


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
2 Electro Fusion Motors & CC esc's from Coronas for sale mthomson Aircraft - Electric - Airplanes (FS/W) 7 Mar 18, 2004 07:13 AM
FS- FMA M5 dual conv Rx and 2 esc's- all NIB Etonic Aircraft - Electric - Airplanes (FS/W) 3 Nov 17, 2003 02:27 PM
How do I hook 2 esc's into 1 receiver ? Al P Power Systems 2 Aug 30, 2002 06:38 PM
EBAY Brushless Motor & 2 ESC's S Anastasio Aircraft - Electric - Airplanes (FS/W) 0 Aug 12, 2002 07:41 AM
WTB: 2 Hitec Feather Recievers and 2 ESC's Ryan Nau Aircraft - Electric - Airplanes (FS/W) 6 Jul 03, 2002 08:13 PM