Flycamone will not charge from Mac - RC Groups
Thread Tools
Aug 17, 2007, 06:33 AM
Registered User

Flycamone will not charge from Mac

My new Flycamone will not charge from my Mac. (MacBook Pro laptop)
It will charge from my IBM ThinkPad laptop at work.

Any suggestions for fixing this?
Thanks for the help - a really sweet camera, but would currently does not charge on my Mac!
Sign up now
to remove ads between posts
Aug 17, 2007, 09:48 AM
Proud To Have Served 1983-1987
SEMPERFI8387's Avatar
Are you sure it's a "powered" usb port and not just a xfer port ? Just a thought.
Aug 17, 2007, 11:00 AM
Registered User
Thanks for the suggestion...the USB port is one of those on the left side...i have used the same port today to access a pendrive whose LED lit up....does this mean it is powered? Perhaps I should phone Apple and ask them if the USB drives on a MacBook are powered or not
Aug 17, 2007, 11:24 AM
Winging It
petej's Avatar
The USB ports on a MacBook Pro are powered, but the Flycamone may be trying to draw excessive current from the port. Your ThinkPad may be more tolerant of current demands.

You could charge the camera using an iPod USB charger, or a number of other alternatives.
Aug 17, 2007, 11:32 AM
Registered User
Was on the line to Apple...just hung up after waiting 30min. Apple UK phone service is a bit of a hit and miss (they can be very good sometimes)

Will try to chare on my Apple Airport Extreme which has a powered USB port...
let's see what happens...

too windy to fly in London anyway this weekend
Aug 17, 2007, 02:53 PM
Registered User
problem fixed - thanks to all!
Aug 18, 2007, 07:44 AM
Proud To Have Served 1983-1987
SEMPERFI8387's Avatar
Originally Posted by arukum17
problem fixed - thanks to all!

Was the powered port the issue ?

Aug 18, 2007, 06:00 PM
Registered User
Not sure what fixed it... it started working on its own

After I charged it at work on my PC it started also charging at home on my Mac laptop. I think one reason could be that it takes about 4-5 seconds to actually register and begin charging and when I first tested this I did not what that long thinking it was a problem. Also I may have had it switched off when I tested it.

After the charging problem was solved I now have a problem with my memory card causing the device to switch off.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Am I the only person that will not buy from a vendor that dosen't have a physical add Wild Bill Vendor Talk 35 Sep 15, 2005 03:07 PM
Rant NIMH will not charge. Please help. plane crashed! Julian537 Batteries and Chargers 10 Jan 03, 2005 03:42 PM
Help, Apache 2500 will not charge... FredericG Batteries and Chargers 15 Nov 22, 2004 02:47 PM
Lipo will not charge after one flight please help! jug Batteries and Chargers 7 Nov 02, 2004 11:29 AM