Thread Tools
Nov 01, 2002, 05:43 PM
RC-Nut-Job!
Lv2Fly's Avatar

Static or No Static on my LOGO-10 Don't want to Blow my Controller Again..


Hello All:

Question, am I headed for disater with this idear?

I'm using silver strip tape,from tail to the front were the motor would be.

Its 1 continues strip. And were ever i want to either use a brush type contact piont or just solder to a piont (Like motor)
and any other part I want to bond and ground.

I have some photo ( this idear is still proto type and is not completed) I just wanted to post the idear to see if it's worth doing.

After I bond everything I then will connect it to the Negative term on my battery lead to absorb any static that the Heli might produce.

I'm concerened that I might be doing something wrong, or I might turn my Heli into some type of lighting rod!

Am I on the right track at STOPPING static?
Or am I'm going to generate static?

Any thoughs ...
here's some photos to show what I'm doing.




Last edited by Lv2Fly; Nov 01, 2002 at 06:27 PM.
Sign up now
to remove ads between posts
Nov 01, 2002, 06:22 PM
Das Universus Elektrikus
Albig's Avatar
It looks a little rough but if you get everything connected it will stop the discharges. I really dont think you need to put anything that will rub on the belt. Just get the tail boom connected to the motor and a mainshaft bearing. That is what worked for me. I put a metal pulley on my tail but I don't think it was necessary. No more ESC problems at all now.

Albig