Thread Tools
Apr 24, 2007, 08:52 AM
Registered User
Thread OP
Help!

Having Problems with Smart Charger 2020 (Apache 2020)


I've been using my AnyRC Smart Charger 2020 for over a year now with no problems. (It's the Apache 2020 in generic form - actually says "Powered by Apache" right on it). Anyway, it seems to have stopped working. After attaching to my power supply, the green power light comes on, but the cell count lights are not turning on as usual. Also, when attaching a LiPo to charge, the charge light does not come on.

I've tried moving the jumper pins around with no effect and also double checked the polarity, verified the output voltage on my power supply (12.25 volts) and inspected the wire leads on the charger for loose connections or shorts. No luck. I'm thinking it's probably a goner, and not sure why.

Anyone have any ideas?

Thanks,
Nunny
Sign up now
to remove ads between posts
Apr 24, 2007, 08:39 PM
Registered User
check for continuity on the output leads from the board end to the plug end.
I have the 2025 and have had to reattach the leads 3 times in the last 2 years, every time the wire was broken just far enough under the insulation to not be visible.
Apr 25, 2007, 07:38 AM
Registered User
Thread OP
Good thinking Broncomech - both my leads have a funky little bend in the wire right where they come off the board, so I see exactly what you're talking about.

Unfortunately, continuity is good on both of my output leads, even jiggled them around a bit while testing. Still no lights except the power light.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Help With My New Smart Charger 2020!!!! Please!!!! Draven Batteries and Chargers 29 Mar 03, 2010 12:07 PM
Is the Ezone having problems with the server? GregG Site Chat 28 Aug 09, 2001 07:38 AM
I put a gb on my T-52 but am having problems with the motor. s_sanders Foamies (Kits) 13 Jul 16, 2001 09:45 PM
Having problems with Cockpit master cheapflyr Electric Plane Talk 7 Jun 13, 2001 04:53 PM
Having problems with Honey Electric? hmhoshi Electric Sailplanes 3 May 27, 2001 03:03 PM