One R4P GWS Reciever Glitching and another Not - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Oct 12, 2002, 02:06 AM
Registered User
Manchild's Avatar

One R4P GWS Reciever Glitching and another Not


I have 2 different planes and 2 R4P GWS receivers (one in each). One of them glitches like crazy and the other is rock solid. Both have the "Azarr" 72-U (something like that) on it. When I swap the receiver between the planes, the glitching follows the receiver. I swapped the crystals and the glitching doesn't follow the crystal but remains on the same receiver. So I know it's the receiver. Why is one of the receivers glitching a lot and the other not? I don't get it, if it's interference, wouldn't both be glitching when I fly around the same area? Could I have a defective receiver? Thanks.
Sign up now
to remove ads between posts
Oct 12, 2002, 11:35 AM
York Electronics
Gary Warner's Avatar
Sounds like a bad receiver.

I'd say it's now a paper weight, but it's too light.
Oct 12, 2002, 11:38 AM
Registered User
Most likely that is your case, do a search here on the Zone, many threads have been started over this very problem. Some times with the problem being solved, like the antenna shorting out on pin at the base.
Good Luck
Philip
Oct 12, 2002, 11:47 AM
Registered User
Flying Cat's Avatar
Fill is right, check where the antenna wire is soldered to the receiver. It is likely that the antenna wire is touching another component.

Also, remove the Azarr antenna and put the regular antenna to find out if the glitching goes away. Or swap Azarr antennas and find out if the glitching follows the antenna or the Rx.

Good luck,

Flying Cat
Oct 12, 2002, 12:19 PM
Registered User
Manchild's Avatar
Yeah, I've switched the Antenna.... so I guess I have a bad receiver. I'll check the connections on the antenna on the receiver. Thanks....