Picco Z (Havoc Heli) stopped working after 6 flights? - RC Groups
Thread Tools
Feb 25, 2007, 06:37 PM
Registered User

Picco Z (Havoc Heli) stopped working after 6 flights?

I looked everywhere for this picco z, and could only find the Air Hogs clone, the Havoc at Toys R US. It worked for a little bit, but this morning I turned it on and nothing. It's been charged, but still nothing. I plug the charger in, and no green light. I tried tapping on it, and even opened it up. The little LiPo looks okay as far as I can tell. Nothing smells burnt, and all the wires appear intact. I went back to get another one, and even though they had about 10 on the shelf and a more in the back yesterday, today they didn't have one!! So I'm forced to try and repair it. Anyone know what could be wrong?
Sign up now
to remove ads between posts
Feb 28, 2007, 08:50 PM
Registered User
same problem here, any ideas? mine's been a little modded as far as the tail section goes so i don't think i could bring it back... the blue light blinks, but at first when i tried to give it throttle it would die(the light would go off)... now it makes somewhat of a clicking sound and doesn't move

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Picco Z : COULD NOT be HAPPIER! (after some tweaks) :) melcrose Micro Ready-to-Fly 89 May 02, 2007 08:35 PM
Discussion hobbytron picco z goes up in flames after..... lilmc53 Micro Helis 15 Jan 11, 2007 06:17 PM
Discussion Win a Picco Z Micro Heli!!! tlex3 Other Websites 0 Dec 20, 2006 12:28 AM
Ok, just had the weirdest thing happen, heli stopped working... dacaur Micro Helis 3 Jun 09, 2005 01:16 AM