Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Dec 20, 2006, 08:28 PM
kctrading is offline
Find More Posts by kctrading
Registered User
kctrading's Avatar
Discussion

Need help setting up Hitec Flash5 sys-x on wing with elevons!


I have a Hitec Flash5 sys x
Radio on Arco. I have elevon mix on.

What plugs do I use for elevons? Channel 1 and 2?

Here is what it is doing....I get up and down correct when moving the stick forward and aft, but when turning, left to right it is backwards!

Funny thing is I tried flying it this way today...LOL...I did learn that this wing is tough as it hit pretty hard with out any damage...got to love epp foam!

Thanks!

Ken
Sign up now
to remove ads between posts
Old Dec 20, 2006, 11:44 PM
Probedude is offline
Find More Posts by Probedude
Registered User
Probedude's Avatar
I had the same problem with my UFO at first. You do use channel 1 and 2. It took me a few tries, but I ended up having to reverse channels 1 and 2 AND swap the servo plugs between ch1 and ch2.

Dave
Old Dec 21, 2006, 11:36 AM
Sparky Paul is offline
Find More Posts by Sparky Paul
Ascended Master
Sparky Paul's Avatar
On any elevon/vee-tail setup, get the elevator function working properly.
Then if the right-left is backwards, all you have to do is swap the channels.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion need help setting up dual ailerons on 7202 Catkicker Radios 7 Feb 12, 2007 10:23 PM
Discussion Need help setting up radio on Wild Wing! kctrading Flying Wings 4 Dec 23, 2006 06:59 PM
Discussion Hitec Flash5 Sys-x won't keep memory on models!? kctrading Radios 3 Jul 05, 2006 10:07 PM
Really need help setting up separates on CP2 brianb10 Micro Helis 9 Sep 17, 2005 02:20 PM
Need help setting up servo linkage on a foamy Sky_Dancer 3D Flying 3 Oct 14, 2004 11:23 PM