Thread Tools
Sep 04, 2002, 09:34 AM
SKINNI MINI flyer
Barrett's Avatar

Problems with my C-20 ESC please help


Hey guys, Ive got a Great Planes C-20 speed control that is giving me a few problems. I just finished a home-built S400 flying wing that also uses a C-20 ESC with no problems. Ive got a few Johnson 250s (15 of them) and a couple of COX viper props. So i decided to test out a couple or them hooked up parallel on 7 600AEs. I know its to much battery but ive got 15 of the little boogers!

Here is where it gets wierd.....
Whenever I hook the battery to the ESC the motors come on at full power. The transmitter has no control whatsoever. The C-20 has an arming feature that requires you to move the TX stick to full for a few seconds and then move it back to off before the throtte will work.

I havent tried this system on a different TX or RX yet. What should I try in the meantime?

Thanks guys.
Sign up now
to remove ads between posts
Sep 04, 2002, 09:42 AM
Horrible Test Pilot
Send it back as defective. I have a GP C-30 ESC and have never had problems with it coming on until I did the arming procedure.
Even with your radio turned off the ESC should not put any power to the motor.

Jason
Sep 04, 2002, 11:52 AM
SKINNI MINI flyer
Barrett's Avatar
Thanks Jason. Thats what ill do. Just hope i dont have any problems because i bought two of them at the same time. One went into my S400 wing and the other just sat in a draw for a while.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help with Electrifly C-20 ESC doublesixes Power Systems 7 Jul 01, 2013 01:15 PM
Help! C-20 ESC programming help...PLEASE?!? toolguy420 Power Systems 2 Jul 22, 2007 11:20 AM
Problems with my Slow Stick ESC Flybyguy Power Systems 7 Jul 18, 2003 09:54 PM
Electrifly C-20 ESC with more then 2 servos help rcman Power Systems 1 Dec 13, 2002 11:49 AM
Having radio problems with my new Zero. Help please? TurboRacer Radios 4 Nov 12, 2002 05:17 PM