RC-USB Joystick Files - Page 4 - RC Groups
Thread Tools
This thread is privately moderated by Malc C, who may elect to delete unwanted replies.
Jul 28, 2006, 06:01 PM
Registered User
Originally Posted by nyxtech
I made download of the archives rcjoy and tried to compile, but it appeared these errors. I do not know as to proceed! I am using MPLAB 7.21
Yes, upgrade to the latest version of MPLAB, It's a free download - I'm sure Mark compiled the code using the same version as myself which is 7.31.

Edit : - looks like the latest version is 7.41 !! so we are both seevral versions behind the current one

Sign up now
to remove ads between posts
Jul 31, 2006, 08:31 AM
Registered User
Ok, gave certain. I obtained to compile asm and occurred all good. I generated the HEX and I recorded in pic. The only problem that I perceived is that the retractable landing gear if closes half command. It does not close complete, somebody knows to say me what it can be? I tested with one another HEX that I had and in it he functioned.
Aug 01, 2006, 04:57 PM
Registered User
I made the alteration in the ASM to jumper it that he selects as much Futaba as Jr and obtained to record pic successfully. However I noticed that the landing gear does not function correctly. It closes until the half in the radio futaba, somebody can help me?
Aug 03, 2006, 10:56 AM
Registered User
if your setting the channel for a landing gear in a sim, it should work fine, as i know ive used a switch as landing gear with no probs.

did you run the configuration setup in the game controller for the interface? as its always best to calibrate the interface channels etc so that it gets full throws etc (then if possible, do the calibration within the simulator if the sim you use has calibration)

I made sure when i did the calibrations, i had 2 switches setup0 on the Tx for the additional channels, and then when in the game controller calibration, just flicked the switches to allow windows to register the full throw values (ie 0 - 100 0= switch pos 1, 100= switch pos 2)

Aug 03, 2006, 12:46 PM
Registered User
Yes, I calibrated and exactly in the calibragem I perceived the problem. All the commands go of 0% the 100% normally, only the landing gear when I set in motion only goes of 0 50%. I tested in 4 radios and this happened in all. I modified the ASM to qualify jumper jp4 I to select when I go to want JR or Futaba. He will be that he can be this?
Aug 06, 2006, 04:25 AM
Registered User
Hmmm. thats very odd, as i reinstalled my pc the other day and had to rerun through the setup etc, and was fine again.
The fact that youve tried with 4 different radios and they all do the same has got me scratching my head as to the reason.
which code are you using? as with you saying that your using the jumper method to switch between the JR and Futaba Tx's makes me think your not using our code as from memory, I did it so that you compile to which radio you use etc (ie JR OR Futaba) rather than using the jumper method to allow you to change it from the board with a jumper.
Aug 07, 2006, 07:35 AM
Registered User
I used codigo that I found here in this fórum exactly. I found that I could make an only interface that functioned with Futaba and JR through a selector key!
Aug 10, 2006, 08:27 AM
Registered User
I must compile a HEX for each control? One for the JR and another one for Futaba? I have I still doubt! I modified the ASM and removed “; ” of the referring code to the Futaba and I generated a HEX. For the JR I must generate another HEX? e I must make some thing in the plate to function with JR?
Aug 10, 2006, 10:10 AM
Registered User
I'm hoping Mark will correct me if I got this wrong

If you look at the ASM code you'll notice that the part that assigns the channels to either JR / Futaba has some parts remmed out

;	btfsc		PORTB, 7, ACCESS		; RB7 low
;	goto		ReadChAssignFutaba		; no, Futaba radio
ReadChAssignJR							; yes, JR radio
	; prepare table pointer
;	movlw		low JRAssignment
;	movlw		high JRAssignment
;	movlw		upper JRAssignment
;	movwf		TBLPTRU, ACCESS			;TBLPTR points to first byte of table
;	goto		ReadAssignTable
	; prepare table pointer
	movlw		low FutabaAssignment
	movlw		high FutabaAssignment
	movlw		upper FutabaAssignment
	movwf		TBLPTRU, ACCESS			;TBLPTR points to first byte of table
	goto		ReadAssignTable
If you want to have a jumper selectable arrangement so that you have one HEX file that fits both you'll need to change the lines

;	btfsc		PORTB, 7, ACCESS		; RB7 low
;	goto		ReadChAssignFutaba		; no, Futaba radio

	btfsc		PORTC, 0, ACCESS		; RC0 low
	goto		ReadChAssignFutaba		; no, Futaba radio
and then remove all the ";" from the "ReadChAssignJR" lines. This is because Allessio's original code used RB7 as the jumper pin, but the original schematic I used for the PCB used RC0 (pin 11) as the jumper.

I'm sure if you follow these notes, and re-compile the code you'll be able to select the channel assignments for both TX's via a jumper between pin 11 and GND
Aug 19, 2006, 02:35 PM
Registered User
Does this interface work under Linux? More to the point: Why is there no good Linux Model Simulator out there? Gah!

(I run Fedora Core 5, and I do not have a PIC programmer yet, but I can purchase one if need be. I needed a reason to get one anyhow.)
Aug 19, 2006, 04:29 PM
Registered User
I couldn't really answer your question as I don't run Linux. But I do have an old form of linux in the form of Knoppix (version 3.6) that runs from a CD so I stuck it in the CD drive and re-booted.

Now having never used this OS before, I can't say if it would be possible to "install" the game controller or not, as it wasn't detected when the software searched for devices (the power up LED even failed to light). My USB mouse worked fine though.

It may be something related to the flavour of linux I used for this test, or it might be that the code is "biased" to windows... I simply don't know.
Aug 20, 2006, 04:43 AM
Registered User
If you have a newer version of Linux, it SHOULD detect the interface IF Linux has a HID device driver (been a good while since I had Linux installed) but from what I remember, Linux has a pretty good plug n play setup now.

As for a sim, hmmmmmm the only one i could possibly think that would work at the mo (dont quote me on this though lol) is possibly Clearview as its written in Java so in theory SHOULD work under Linux.
Aug 22, 2006, 01:29 PM
Registered User
Then I do belive that it is time for me to break down and purchase a PIC programmer then. Now if I could only remember where my cupric chloride and PCB are... At any rate, I will post my success/failure here, if I do indeed get around to making the interface.
Aug 23, 2006, 01:54 PM
Registered User
bitmaniac's Avatar

Trying to compile with 7.41 MPASMwin and getting errors...
Are there any compatibility issues between 7.31(Mark used) and 7.41?

[asm + error text included]
Last edited by bitmaniac; Aug 23, 2006 at 02:23 PM.
Aug 23, 2006, 03:17 PM
Official Old Git!
Originally Posted by bitmaniac

Trying to compile with 7.41 MPASMwin and getting errors...
Are there any compatibility issues between 7.31(Mark used) and 7.41?

[asm + error text included]

It gives those errors if you do a Quick build - but if you assemble the asm file it works OK i.e. set up a project with these files, right click on the .asm file and click assemble.

I have 7.41 (I think it might be related to the fact that it can't find out where the correct build tools are as it tries to use the paths that Malc / Mark used)

Last edited by Norman Adlam; Aug 23, 2006 at 03:27 PM.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question JW24RC - Model RC to USB joystick converter chip skratchbilder Radios 0 Dec 16, 2004 08:43 PM
Quattro USB adapter: RC, Analog Joystick -> USB PiNa Simulators 2 Sep 22, 2004 02:09 PM
Radio Shack USB joystick adapter. HankF Simulators 0 Jul 23, 2003 02:46 PM