Anyone else having problems with Align 35A ESC's? - RC Groups
Thread Tools
Mar 18, 2006, 04:28 PM
Hold my beer.....
sharky47's Avatar
Rant

Anyone else having problems with Align 35A ESC's?


So I spent a crapload of money to upgrade to the SE - I love Trex's so I figured this would be the ultimate version....... I have yet to have a flight where something does not go wrong.

Had some glitching issues, but was able to get that ironed out. Then I had the 35A ESC that came with the kit go skitzo on me - governer mode just freaks out after a few minutes of operation. So I throw in a new one I bought from someone here on RC Groups who had bought it new and never used it. I was flying around and the governer had a hiccup and then the motor went silent. Since I had a Medusa BEC, I was able to auto it down undamaged - as soon as it landed I heard the ESC reboot. Upon closer inspection I could see two of the mosfets had exploded on the red phase.

So here's the situation - I have three T-rex's and a couple thousand dollars of equipment I can't fly because I have been stealing parts off the other ones so I could enjoy this new SE. I have modified these ESC's by cutting the shrinkwrap around the heatsink so it actually works as well as cutting the postive wire on the servo lead for use with the Medusa BEC - can I return them? Who do I call? Man this is getting old.........
Sign up now
to remove ads between posts
Mar 18, 2006, 04:58 PM
Registered Perpetual Noob
Kill_A._Byte's Avatar
Hmmm, seems strange you keep burnin the ESC. Check solder connections, maybe motor. I wish you luck
Mar 18, 2006, 05:06 PM
Old new guy
TheX's Avatar
Odd that it would fail but all things are prone to it. Personally I've had great experiences with them. The CC35's gave me more grief.

I doubt they can be returned, especially after being modified but the person that you purchased them through would be the best place to ask.
Mar 18, 2006, 06:09 PM
But Honey..It was only $$
kookboy's Avatar
I had a much more enjoyable experience with the Align compared to my CC35's.

There will always be some bad one's unfortunately, but that's part of this electronics business.
Mar 18, 2006, 06:33 PM
/bin/ksh
Steve_C's Avatar
In keeping with the other thread you started about your trex SE, I think you may have a setup problem. (motor/gear combo) When using governer mode it is important to have your throttle curve at 85% or more (ie 95.90.90.90.95), and fly only in idle1 and 2. Spool up in normal though.

Also governer may not work right if your rotor speed is not sufficient and/or poor battery discharge capability.

I would try setting up in non governer mode just to check things out.
Mar 18, 2006, 06:43 PM
X-Ikarus
Reflex1's Avatar
Just seen this post
It would tend to confirm a MOTOR problem.
see my post in your other thread.
Mar 18, 2006, 07:01 PM
Hold my beer.....
sharky47's Avatar
Motor problem huh - great, now I have to spend another $150 to replace stuff I have already paid for......
Mar 18, 2006, 07:08 PM
/bin/ksh
Steve_C's Avatar
Sharky, your at post 666... throws wholly water on your rex.
Mar 18, 2006, 07:15 PM
Hold my beer.....
sharky47's Avatar
Not any more!

Seriously though, guess I will see what my LHS guy can do with his distributer about getting me fixed back up.....
Mar 18, 2006, 07:37 PM
Cumulus Altimus
FASTBEN's Avatar
maybe its us in texas only cuz i also had no luck w/ align esc,but never w/cc35/25/or10.so i just fly with 35 solved my heating problem.
ben
Mar 18, 2006, 08:27 PM
Registered User

Esc


i had trouble and fried 4 Align ESC's (2x25A and 2x35A) then bought a Quark 33A and i am loving it.

its worth the extra but i am still figuring out how to set it up fully but the basic settings in "heli" mode are great
Mar 18, 2006, 09:05 PM
Its all fun
Tonystott's Avatar
Quote:
Originally Posted by helirascal
i had trouble and fried 4 Align ESC's (2x25A and 2x35A) then bought a Quark 33A and i am loving it.

its worth the extra but i am still figuring out how to set it up fully but the basic settings in "heli" mode are great
Without being unkind, the odds against factory faults in 4 in a row must be huge.. perhaps your next statement might be relevant "but i am still figuring out how to set it up". Are you sure you weren't doing something wrong?
Mar 19, 2006, 12:29 AM
Keep 'em Flying
freddy warbird's Avatar
I hate the Align controller!

What the heck is the fifth program for?
♪♪♪♪♪ ♪♪♪♪♪ ♪♪♪♪♪ ♪♪♪♪♪

♪♪♪♪♪
♪♪♪♪♪
Last edited by freddy warbird; Mar 19, 2006 at 01:21 AM.
Mar 19, 2006, 07:32 AM
Registered User
Go check out the stickies... Trex build videos / Tutorials - FREE
There are videos there and one cover the setup. Very informative. It will tell you about the fifth tone.


Thanks again finless for the videos

Bill
Mar 19, 2006, 01:52 PM
Registered User
Blackbird's Avatar
I have over 100 flights on an Align 35A ESC using a 450T...I'd buy another in a minute!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Anyone Else Having Problems with the GWS Videos? aeronca GWS (Grand Wing Servo) 4 Aug 22, 2004 07:00 PM
Anyone else having problems with little kids interrupting? Lynxman Micro Helis 33 Jul 05, 2004 11:55 PM
Has Anyone else had Problems with CC ESC`s and Mega Motors? kushal_22 Castle Creations 9 Jun 29, 2004 05:40 PM
Has Anyone else had Problems with Castle creations ESC and Mega Motors ? kushal_22 Power Systems 18 Aug 12, 2003 12:11 PM