Thread Tools
Feb 11, 2006, 03:31 PM
Registered User
BeechSkipperDude's Avatar
Thread OP
Discussion

Help - Can't figure out what's wrong...


I have an e-flight 370 outrunner and it's compliant esc. after rigging all electronics in a new plane...all the motor does is beep once when i plug it in. for a few tries, the servos moved and everything seemed fine. then after trying to get the servo leads in the correct ports - now the servos only jitter once when i plug in the battery....

I tried 4 different rx's just to make sure but it did the same thing with all of them. is my esc blown? what do i do!?

thanks

Rick M.
Sign up now
to remove ads between posts
Feb 11, 2006, 04:57 PM
Battery charged? Servo plugs in right and not backwards?
Feb 11, 2006, 06:33 PM
Registered User
Dr Kiwi's Avatar
Is it a Futaba Tx - in which case throttle servo will need to be reversed.
Feb 12, 2006, 05:07 PM
Registered User
BeechSkipperDude's Avatar
Thread OP
no, no, no. (answering your questions)

I made sure the servo's were plugged in correctly, i was narrowing down where they went...i.e aileron servo in the elevator port.. i had two lithium batteries i was using for testing, both of which were charged. and no, there is nothing futaba about my setup...

The problem is. I've used this configuration in a sorta tensor for months... and now once i hook it all up to a new foamie, nothing works. any more viable suggestion? keep in mind i'm not a dumb***. i just would rather ask for advice before purchasing new, un-needed equipment. Thanks.
Feb 12, 2006, 05:45 PM
Registered User
Dr Kiwi's Avatar
All I can suggest is trying one thing at a time - beg, borrow or steal, then try, a different motor, different Tx, different Rx, different ESC until you find a combo which works - then you'll have the answer.
Feb 12, 2006, 07:58 PM
Rick, It sounds like your electronics do not like foam. That is why all of my planes are balsa, Ply and MonoKote.
I am sure you have tried this, but wire a four cell ni-cad or dry cell battery pack up and plug it in to your reciever with out the ESC and see if the reciever and servos work.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Help me figure out what went wrong PROACE Racing Boats - Internal Combustion 3 May 01, 2006 10:43 PM
Question Can't figure out how to setup an EF radio for any sim, help.. RisingSunn Simulators 0 Feb 26, 2006 06:33 PM
Discussion HELP!! - Can't figure out how to get new scenes from rc-sim.com working in Reflex?? kenmalecki Simulators 3 Feb 22, 2006 10:27 PM
Help! Can't figure out what to do. rcnutt Electric Plane Talk 9 Mar 17, 2003 06:23 PM
My Endo lost it punch and I can't figure out what to do Balin Sport Planes 25 Jun 16, 2002 10:07 PM