Please help me with my zero throttle respone from my Futba Skysport Radio - RC Groups
Thread Tools
Jun 14, 2002, 08:25 PM
Registered User

Please help me with my zero throttle respone from my Futba Skysport Radio


O.K., I have a conversion American Airlines plane that I am builing. 2x EDF-50 in parallel, worked before, now zero throttle respones.


Setup:

Bench Testing with ICS-50(Checked to see if it was toasted because of amp draw, not the problem, works on mini max with different radio)
Futaba 4channel Skysport Radio T, E,R A:everything works except the throttle. I have zero response with the above radio, even after checking other crystals. I then tried Futaba radio in the mini max with the same ESC as above and again same response NO THROTTLE. Tried out my
Hi-tec Focus III radio with same ESC in the mini max and it worked!! Then I tried one EDF-50 with Hitec 3 channel radio with same (ICS-50) ESC, and that worked perfect.
I then tested the Futaba Radio with the same ESC, in the same setup as the Focus III: No throttle response, but servo control is good. I had both motors working fine earlier, and then ran out of battery power, thought that I burned up the ESC, but it still works.

Is it possible to damage the radio in any way?? I tried another servo on the rudder/Throttle stick on the Futaba radio, and again no throttle, but rudder control worked.


I am running out of possibilities, please help me because I don't have to tools or the experience neccessary to figure this out on my own.


Thank you for your help,


Michael Arnoult
Sign up now
to remove ads between posts
Jun 14, 2002, 08:27 PM
an earth bound misfit, I
Basketcase's Avatar
Does the Futaba have servo reversing? If so, try reversing the throttle channel.

BC
Jun 14, 2002, 08:40 PM
Registered User

Tried it?


I have tried it, but I will try it again. I just tried out the Futab Radio on my GWS 2 amp ESC, and Direct Drive Motor, and it would not respond. I am really conserned that it may be the radio, BUT HOW?!?!?!?

any more advice, please help!!


Mike
Jun 14, 2002, 09:27 PM
an earth bound misfit, I
Basketcase's Avatar

Re: Please help me with my zero throttle respone from my Futba Skysport Radio


Quote:
Originally posted by mike93
Futaba 4channel Skysport Radio T, E,R A:everything works except the throttle. I have zero response with the above radio, even after checking other crystals. I then tried Futaba radio in the mini max with the same ESC as above and again same response NO THROTTLE. Tried out my
Hi-tec Focus III radio with same ESC in the mini max and it worked!! Then I tried one EDF-50 with Hitec 3 channel radio with same (ICS-50) ESC, and that worked perfect.
I then tested the Futaba Radio with the same ESC, in the same setup as the Focus III: No throttle response, but servo control is good.
Is it possible to damage the radio in any way?? I tried another servo on the rudder/Throttle stick on the Futaba radio, and again no throttle, but rudder control worked.
Hi Mike, are you using the same receiver in both examples above? Are you also saying that when a servo is plugged into the receiver channel that you still get no movement? Or does the servo work?

I think you've proven it's not the speed control, if all the other channels work and just the throttle is out I'm lost.

BC
Jun 14, 2002, 10:43 PM
Registered User
Problem solved. I am not sure how I did it, but after re thinking everything and trying it all again (close to 2 hours of rethinking) I fixed the problem. Everything works now.


Thanks for your advice,

Mike
Jun 14, 2002, 10:45 PM
an earth bound misfit, I
Basketcase's Avatar
Glad to hear you got it going, that's all that counts.

Have fun,

BC