Spektrum Radio Throttle Problem. - RC Groups
Thread Tools
Jan 23, 2006, 01:15 PM
Suspended Account
Help!

Spektrum Radio Throttle Problem.


I have a new Spektrum Radio and I cannot seem to get the throttle to work correctly. The BL motor will not turn on until 1/4 way up on the stick. It makes things difficult when trying to hover without smooth throttle range on the stick. Any Ideas. Thanks.

David
Sign up now
to remove ads between posts
Jan 23, 2006, 01:35 PM
FPV Enthusiast
martinic's Avatar
It sounds like you may not have your throttle ATVs set up correctly for your ESC. If the ESC isn't arming until 1/4 throttle, then set your throttle stick to 0% (bottom), go to the TRV ADJ screen, scroll down to THR and adjust the - value upwards until the throttle arms (motor not spinning, but throttle armed - most will indicate arming with a light or sound). You should also set the upper limit based on your setup/preferences.
Jan 23, 2006, 04:01 PM
Suspended Account
I think that is the problem. I will give it a try. Thanks Martinic.
Jan 25, 2006, 03:48 PM
Registered User
ATV's should be set at 100%
Jan 29, 2006, 04:42 PM
Suspended Account
Just to follow up in my Situation is the ATV's are set to 100% as instructed. No matter what I do I cannot get a throttle response unless I have the stick 1/4 way up. My Castles BL controllers responge good at all throttle positions but this Great Planes BL ESC just isn't playing. It serves me right to go cheap.
Jan 29, 2006, 05:05 PM
Send Money, Women & Guns!
fritzthecat's Avatar
Remove main blades or setup a pitch curve with 0deg all accross. Throttle curve must be 0% on bottom, 100% on top.

Set both up and down throttle ATVs to 100%.
Plug in battery.
Arm the ESC - you don't mention what model you have so you have to figure it out yourself.
With throttle stick all the way down, reduce ATV until motor starts. Then add 5%.
Go to max throttle. Adjust ATV until rotor rpm reduces then add 5%.
The ATVs are now adjusted to your ESC.

The Castle controllers automatically adjust to your radio, the GP needs manual adjustment.

Fritz
Jan 29, 2006, 08:40 PM
NSDQ!
mess with the throttle trim....click the button up and down...cant remember which does what. And see if that helps.
Jan 30, 2006, 08:59 AM
Suspended Account
Fritz I will try what you have suggested.

Chase I have messed with the Throttle trims and it get to a point where I have good throttle control but after I have to re arm the system again its messed up.

Thanks for the Help Guys.
Jan 31, 2006, 01:40 AM
Registered User
Futurase's Avatar
I have a Jeti controller and it does the same thing. I just click up the trim a few times before every flight as I have been too lazy to tweak the end point. It is a SC issue as I have some high end SC's and they do not do it. My Jeti is a $200 77A controller and excellent, but does require manual adjustment.

Norman Ross Jr.
Jan 31, 2006, 01:04 PM
Suspended Account
Fururase yes I could keep adjusting the Trim for Every flight if the End Point Adjustments doesn't work.

Let me add my E-Flite BL controllers work fine also. So no problems with Castle and Eflite controllers with the Spektrum TX.

David


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Problem with my Futaba Radio Throttle stick kuzko Radios 8 Jan 17, 2007 12:07 AM
pixie 20 throttle problem echoplanar Parkflyers 11 Dec 12, 2002 05:50 PM
radio glitch problem rycomm Radios 2 Aug 11, 2002 11:39 AM
Huge hitec radio range problem Thomas Manson Electric Plane Talk 10 Jun 20, 2002 09:19 PM
Sky Scooter throttle problem GooberVA Foamies (Kits) 4 Jun 02, 2002 03:49 PM