Speed control problem for wattage crazy max - RC Groups
Thread Tools
May 26, 2002, 01:29 PM
One of the Deplorables
Colt SAA's Avatar

Speed control problem for wattage crazy max

I just put together a crazy max with a wattage 30 amp sc and the motor wont run. The servos work fine but the sc apparently isnt putting out any power to the motor. I have tried reversing the tx output for the throttle control. The sc just sets there light blinking rapidly and the directions dont say anything about that. HELP!
Sign up now
to remove ads between posts
May 26, 2002, 01:51 PM
Making Cuisinarts Fly!!!!
Try adjusting the trim and reversing the servo.

On my futaba TX I have to reverse the servo for My Hitec RX and sometimes pull the trim tab down to get it to arm.

Good luck!
May 26, 2002, 02:08 PM
Registered User
If your radio has throttle ATV, make sure they are turned up to maximum "travel".

It is an arming issue. Moving the trims/ATV/reversing to the correct position to match the ESC should solve the problem.

If it doesn't, call me Tuesday at work and I'll help you with it.

May 26, 2002, 02:09 PM
Registered User

Work phone:
714 964 0827 ext 308

May 26, 2002, 02:11 PM
Crash Site Instigator
sheerLuck's Avatar
Had the same problem initially using a Pixie 20 ESC. Fussed around with it & it started working - not sure what fixed it. However, I have to have the throttle trim all the way down for it to run, and the travel between off and full throttle is only about half the stick travel. This doesn't seem optimum, but as long as it flies....
May 27, 2002, 12:53 PM
One of the Deplorables
Colt SAA's Avatar
Found out what the problem was......................I had the esc plugged into the battery channel so the servos worked but reversing the throttle channel did nothing! Plugged the esc into the throttle channel on my JR 8103 and now it flies great! a blast but the kit was minus one pushrod so my rudder got taped strait for now cant wait to get a pushrod and had rudder also!