Post Your Corona Building Pics - RC Groups
Thread Tools
May 11, 2002, 12:54 AM
Registered User

Post Your Corona Building Pics


Well, my Corona kit is coming together and starting to look like a helicopter :-)

I spent a whole day on smoothing out any binding or friction down to the best I could get it. I will just have to see when I flight test. Right after this pic was taken I mounted the main gear and set the mesh. I started to do some soldering, but my iron is craping out, so I'll be stopping by Radioshack tomorrow to get a new tip or a better one.

This is fun stuff!

Sign up now
to remove ads between posts
May 11, 2002, 12:56 AM
Registered User
Earlier this week....
May 11, 2002, 12:57 AM
Registered User
The pic...
May 11, 2002, 01:01 AM
Registered User
Heres what comes in the box....
May 11, 2002, 01:04 AM
Registered User
the naked crutch...
May 11, 2002, 01:18 AM
Registered User
Tail Plastic tubing mod... I used three pieces between the bushings and the ends. Got it at the local hardware store for 75 cents....
May 11, 2002, 01:48 AM
Powered by ThunderPower
Chachin's Avatar
Hey that's really nice work you're doing there.

Keep the pics coming!! This is the only way for us to get familiar with all the e-helicopters out there.

Chachin..
May 11, 2002, 02:10 AM
Registered User
gliderdude's Avatar
My atomic force died today after about 40 flights..brushes were gone.......I tried a Monsters of Touring 13 turn motor that I had and it flew great for about 5 minutes then just stopped in the air
(luckily I was landing)dropped from about 5 feet,no damage,but it got so hot that one of my motor leads came unsoldered,so tommorow im trying a 19 or 17 turn Monsters of touring motor ,these are cheap at hobbypeople $18.99.......will let you know how it works out......40 flights on a $20 motor is not to bad really but they are so hard to get ,........
May 11, 2002, 06:26 PM
Registered User
Thanks Chachin, I am having fun building. I picked up a 40 whatt soldering iron today, so I can get some more done this weekend.

gliderdude, sorry to hear about the AT going out on you. What do you think the problem is? Are you using the Castle Pegasus 35 aand a heat sink? That does not sound consistant with Tom's AT. Can the brushes be replaced on this motor? Is heat causing these to go out quicker....I wonder

I fly my Tiger Moth this morning (3 mins) and 3 packs on the Partenavia this afternoon. It was windy today but not too much for the KP! The moth will have to wait till late tonight....
Last edited by cactus; May 11, 2002 at 06:50 PM.
May 11, 2002, 10:41 PM
Registered User
gliderdude's Avatar
I have the pegasus from castle and run a heatsink.....Mine never ran hot .......only thing I can think of is that I never broke the motor in properly,just pulled it out of the package and oiled it and stuck it in.......never messed with the timing either.......actually in all reality 40 - 10 minute flights on a brushed motor is not bad.....
Thats 6 hours and 40 minutes of flight time,im really satisfied with that........you can change brushes,but its better to turn the comm first.......overall im happy with it,I have ordered another one......in the meantime im using my 17 turn Monster of touring motor with ok results..........though after my last flight it was pretty hot.....
May 12, 2002, 11:42 PM
Registered User
gliderdude, how did you oil yours? Did you take the sicker off before putting the heatsink on? Others did not break this motor in.... wondering if I need to? I don't understand timing and I'm not sure I know what to look for on mine. Here is a pic I took just now showing the way it came out of the box....
May 13, 2002, 02:42 AM
Registered User
gliderdude's Avatar
yes my timing is the same as yours.......no I did not take the sticker off,maybe I should.I put a drop of oil on top and bottom bearings.........your corona is coming along nicely,bet you can't wait to try it out......
May 13, 2002, 05:09 AM
Registered User
My AF died last night, after 389 flights, one thread broke. The crash was spectecular! From 10m in full spead the rotor just stopped spinning, my Corona dived straight in the ground, bounced 3 times up and down, then finally stopped.

The AF is going to be replaced today, and what happend to the rest? NOTHING!!! Well, allright, the skids got bent... fixed that in 5 secs....
May 13, 2002, 07:21 AM
Registered User
gliderdude's Avatar
Tom how many sets of brushes did you go through?Yea these coronas are tough,glad to see that yours came through OK.
May 13, 2002, 07:55 AM
Registered User
I went thrue 3 sets, but i changed them more for "service".


Thread Tools