Thread Tools
Jul 03, 2001, 01:40 PM
Flying high since '85
rdogg32's Avatar

Help with speed control please!


I am in the process of makeing a new creation put pf all my lite stik parts. It is really cool, but I ran into a problem. I got a new reciver, a GWS 4 channel. I plugged it in, and nothing happened except for glitching. I worked all night, and then I figuered that it must be the crystal. I would get no response at all. So I got a Hitec 555 out of my mustang, and tryed it. No gliching, but no response. I then figuered that the glitching was because the GWS is only single conversion, and that the same problem still exsited. So it must be in the speed control right? It is a pixie 14. Any help would be appreiciated.
Sign up now
to remove ads between posts
Jul 03, 2001, 02:20 PM
Space Coast USA
hoppy's Avatar
Check the plug orientations. (-) on the outside, yellow (signal) towards the guts of the GWS. AND more importantly, does your GWS have an "F" on it??? That works with Futaba and Hitec, or a "J". They cannot be interchanged! A "J" wil not work with Hitec of Futaba.
hoppy
Jul 03, 2001, 03:58 PM
Suspended Account
Shouldn't you use a special design micro crystal with the GWS Reciever made from GWS. I was just wondering because I have A GWS reciever and it called for a GWS crystal.
Jul 03, 2001, 04:09 PM
Flying high since '85
rdogg32's Avatar
I have the gws crystal.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help with SPEED 400 CAN MOTORS please.. rumme Electric Plane Talk 20 Jan 04, 2005 07:27 PM
New Multiplex 4 Engine Cargo with speed control !!!! Looks like a B-17 Joe Pierson Aircraft - Electric - Airplanes (FS/W) 0 Sep 06, 2001 01:48 AM
Help with current draw please Al P Electric Plane Talk 5 Jun 29, 2001 11:20 AM
Help with EZ 30 please Al P Power Systems 0 Jun 18, 2001 07:18 AM