Radio Problems with Trex - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Jul 04, 2005, 11:06 PM
Registered User

Radio Problems with Trex

I was checking control throws while doing some repair work on my Trex after a crash. I was getting enough forward cyclic control but almost no reverse. I thought I had stripped a servo gear, so changed it and the same problem exists. I then changed the receiver out to a brand new one, and still no difference. I then checked my right and left cyclic and I have more movement in one direction than the other. I thought maybe something was binding, so I checked the servo without the arms attached and it still shows the same problem. The last item I could think of is the transmitter. The transmitter is only a couple months old and I haven't dropped it or hit it hard. The transmitter is an Hitec Optic 6 and the receiver is a Hitec Electrom 6. Has anybody else had this type of problem? Any suggestions? I think this was the cause of my last crash, I went into a turn and it wouldn't pull up or pull out of the turn.


Terry Throop
Sign up now
to remove ads between posts
Jul 04, 2005, 11:10 PM
Registered User
I had a simular problem with my Futaba CHP. I reset the program, started from scratch, and that fixed it.
Jul 05, 2005, 07:37 AM
Registered User
CrocEnd's Avatar
Just a thought dose your Tx have aircraft memory you may tripped another memory or not on the correct one.been there done that. Cheer's
Jul 05, 2005, 08:00 AM
Registered User
ukgroucho's Avatar
Check that the endpoints in the TX are set correctly... I have a 7CHP and I use NiMh AAs in a 'holder' instead of the stock NiCAD. I can pull teh AAs from the holder, replaced with charged ones and be back flying without waiting for a charge... but sometimes it resets the endpoint on the aeleron right stick to 0. I guess it's lack of voltage for a minute....Always check my throws before any flight so I catch this if it happens.

If that does not work then look into recentering your servos.

Set all trims to 0, set any subtrim to 0.

Remove the servo arms and put them back on so the swash is level. Then check for left and right, fore and aft, movement.

You will not get the swash perfect so adjust with subtrim / trim when you're done.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Radio problems with the Blade Jim Frahm Micro Helis 10 Jul 16, 2005 06:07 PM
JR Radio: Problems with buddy cord usage HookedOnPF Radios 2 Jan 22, 2005 07:44 PM
Help! Help! Radio problems with my Absolute. Flint High Performance 49 Jan 12, 2004 09:03 PM
Radio Problems with an Electrajet aeajr Foamies (Kits) 7 Nov 02, 2003 07:47 PM
Having radio problems with my new Zero. Help please? TurboRacer Radios 4 Nov 12, 2002 06:17 PM