Thread Tools
Old Jun 14, 2005, 06:05 PM
UAVProducts is offline
Find More Posts by UAVProducts
Registered User

ECO 8: keep breaking Head bolt (jesus bolt) and Phx 45 start up problem?


I have my brothers Eco 8 for trimming and tunning. I have the latest Phx software 1.14 installed on the Ph45 in gov mode and start up set at softest. When I spool up it does a quick "jerk" and then spools up slowly to set throtlle setting of 90% before switching to idle 1 of 90%.

I would assume that the head bolt is breaking due to the start up problem.

Any thoughts/help?
Sign up now
to remove ads between posts
Old Jun 14, 2005, 09:07 PM
DavidB. is offline
Find More Posts by DavidB.
X-Era Motors
DavidB.'s Avatar
The head bolt is garbage. Replace it with something harder and you shouldn't have problems.
Old Jun 14, 2005, 09:53 PM
TMorita is offline
Find More Posts by TMorita
Registered User
Quote:
Originally Posted by rerazor
I have my brothers Eco 8 for trimming and tunning. I have the latest Phx software 1.14 installed on the Ph45 in gov mode and start up set at softest. When I spool up it does a quick "jerk" and then spools up slowly to set throtlle setting of 90% before switching to idle 1 of 90%.

I would assume that the head bolt is breaking due to the start up problem.

Any thoughts/help?
I'll bet you have a Mega 22/20/3H.

I reported this problem to Castle Creations many times in the past, went through about three firmware versions waiting for it to be fixed, was never fixed, so replaced it with a Schulze 18.46k.

This was three years ago...looks like they still haven't fixed it.

Toshi
Old Jun 14, 2005, 10:11 PM
UAVProducts is offline
Find More Posts by UAVProducts
Registered User
I'm running a Hacker B50 14L. I switiched to fixed throttle and didn't change any other settings and I do NOT get the 'jerk".

So it has to do with the Gove mode.
Old Jun 14, 2005, 10:33 PM
Art Newland is offline
Find More Posts by Art Newland
CD-ROM Junkie
Art Newland's Avatar
I couldn't get mine to stop the "jerk startup" (Px-45) until a softened the throttle curve on the low end, now it starts very smooth. But I'm using fixed throttle mode.
Old Jun 15, 2005, 10:09 AM
UAVProducts is offline
Find More Posts by UAVProducts
Registered User
I guess I will just have to set it at Fixed pitch. In Gov mode the startup is so violent that it eats the main gear and breaks the bolt. Its to bad I really wanted to use Gov mode.

I'll just set the TC at 100 95 90 95 100 in idle 1
Norm will be 0 inn 90 90 90

Thanks
Old Jun 15, 2005, 01:34 PM
Chachin is offline
Find More Posts by Chachin
Powered by ThunderPower
Chachin's Avatar
Hello, it sounds like you guys need some Kontronik ESC's . They're as smooth as they get in soft starts and just about everything else. I've used the garbage bolt together with this ESC and never broke it during start up.

When I first started though I had a real violent JetiESC/Phasor combo. My fix was to spool up the blades by hand (just a bit) and then start up the throttle. Much better; should work with your CC too.

Good luck!

Chachin..


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Ikarus ECO 8 Red Aluminum Head Spidious Aircraft - Electric - Helis (FS/W) 0 Jul 10, 2007 11:36 PM
Sold IKARUS Eco 8/16 alum head and swash w/ hardened shafts on E-bay litespeed Aircraft - Electric - Helis (FS/W) 0 Mar 12, 2006 08:43 AM
Dragonfly - Keep breaking head links Shanman3us Micro Helis 4 Jun 08, 2004 01:59 AM
Eco 8 rotor head bolt P-bar Electric Heli Talk 4 Apr 12, 2004 09:59 AM
Eco 8 max rotor head speed BillH Electric Heli Talk 2 Mar 03, 2002 12:40 AM