Thread Tools
Jul 04, 2020, 11:07 AM
Build more, websurf less
FlyingW's Avatar
Thread OP
I now tried three different PCs all in Windows 10.

With all of them I get the disappearing XDP screen. In all cases I tried fresh installs with and without virus scanning enabled, and always in "run as administrator." with and without virus scanning. I also enabled the "app through the firewall." I also added the virus scan exclusion for the XDP folder and also the XDP.exe file.

Since bluemax and Jim are not seeing this same problem, I reckon that I am probably doing something else wrong.

What are the exact steps to configure the XPS-J1 module to talk to the XDP program?
Sign up now
to remove ads between posts
Jul 04, 2020, 11:21 AM
PayPal ONLY with NO F&F
thebluemax's Avatar
Quote:
Originally Posted by FlyingW
I now tried three different PCs all in Windows 10.

With all of them I get the disappearing XDP screen. In all cases I tried fresh installs with and without virus scanning enabled, and always in "run as administrator." with and without virus scanning. I also enabled the "app through the firewall." I also added the virus scan exclusion for the XDP folder and also the XDP.exe file.

Since bluemax and Jim are not seeing this same problem, I reckon that I am probably doing something else wrong.

What are the exact steps to configure the XPS-J1 module to talk to the XDP program?
What virus scan/firewall programs you using?
Latest blog entry: Aegis Aircraft F-117
Jul 04, 2020, 12:03 PM
Build more, websurf less
FlyingW's Avatar
Thread OP
Virus scan and firewall are the ones that come standard with Windows 10 - I've installed no other product.
Jul 04, 2020, 12:07 PM
Build more, websurf less
FlyingW's Avatar
Thread OP
Quote:
Originally Posted by thebluemax
actually, it was here in this picture . still on the same page but further down.
Tried this one, got the same error about a language file missing...

Thanks,

Paul

p.s. Good news - I binded two Nano receivers to the XPS-J1 module and did several short test flights.
Jul 05, 2020, 04:08 AM
Quote:
Originally Posted by FlyingW
What are the exact steps to configure the XPS-J1 module to talk to the XDP program?

Just follow the onscreen instructions. However, I will say that for the JR module you should not use the XDP program. Since XJT mode was added there is no way to change the settings via the XDP. It has to be done via push-button programming. I should probably disallow the JR modules from connecting and pop up a message. You can still use the RSSI program to test the signal strength, it's just the XDP program that is the issue because EEPROM settings no longer match any of our other products (this was a byproduct of having to do some creative coding in order to get XJT mode to even work). This might actually be what's causing the issue for some people.
Jul 05, 2020, 07:46 AM
Build more, websurf less
FlyingW's Avatar
Thread OP
Ok thanks Jim. That explains it. I am flying it already with a small foamy, but have not gone more than 50 feet away because I want to verify the settings and do some range checks first.

These are the current settings in my XPS-J1 unit, can you please tell me if these are best for sport flying in the USA:

Power level (red) = 1, North America (is 1 the strongest, or is 5 the strongest?)
Hopping Mode (green) = 2, FCC Full Time (seems sensible since the FCC is our authority)
Input Mode (orange) = 2, XJT-D16 (This one has to be correct since it is working)

Also, does the reduced power mode work the same as with the Futaba modules - press and hold the button for a range check?

Thanks,

Paul
Last edited by FlyingW; Jul 05, 2020 at 10:23 AM.
Jul 05, 2020, 11:43 PM
Power level 1 is the least amount of power. Power level 5 is the most amount of power. You will want to set that to 5.

Hopping mode is correct.

Input mode is correct.

Yes, HOLDING the PROG button after the transmitter and receiver have connected will drop the power output from what it is set to (power level setting, should be 100mw at power level 5) to .019mw. This is how you conduct a range test. When you release the button it goes back to full power. So, ONLY when the PROG button is HELD is the power dropped. Whenever you press or release the PROG button, the frequency hopping sequence is deliberately randomized so the transmitter and receiver are completely out of sync witheach other and they have to resync together. Experimenting with this gives you an idea how quickly resync works with the XtremeLink system. This was something I did for diagnostics and I just left it that way for the release.
Jul 06, 2020, 07:22 AM
Build more, websurf less
FlyingW's Avatar
Thread OP
Jim,

Ok great, thank you. I changed the power from 1 to 5 (yesterday, guessed correctly) and got a range check with a Nano Rx of over 150 feet with the power button pressed.

Encouraged I set up a simple foamy wing for a test flight at the field. Configured the failsafe positions to be throttle=off and both elevons=up. This is similar to how we got free flight planes to come down at the end of a flight.

Went to the field and flew out far with perfect control. Then flew the wing up high and turned off the transmitter. After about two seconds the Nano went into failsafe (as configured) and began fluttering down. After a bit I turned on the transmitter again. The system regained control in a second or two.

At first the motor did not come back on to the mid-throttle setting it was at when the failsafe kicked in. No worries as the five-ounce machine was gliding nicely. When I turned off the transmitter for the failsafe test I left the throttle stick in its mid-throttle position. After regaining control it was only after I moved the throttle stick low again did the motor respond. Putting the throttle stick low again must have re-armed the ESC.

On the bench I've had the throttle automatically come back to the same mid-throttle setting it was at the time of the failsafe event. I don't know why I had to re-arm this time; I'll check that out with Castle (Castle Thunderbird-9).

All in all a very satisfying test. Thanks for the cool XPS-J1 product.

Paul
Jul 06, 2020, 11:27 AM
Build more, websurf less
FlyingW's Avatar
Thread OP
Did more bench testing.

Turns out that with OpenTX you can set a feature called "Throttle Warning". With Throttle Warning in effect, it looks like the transmitter does not send either a signal or frames to the receiver until the throttle stick is moved to the off/low position.

When I de-activated the Throttle Warning feature the plane came out of failsafe automatically when the transmitter was turned back on - irrespective of throttle stick position.

Always something new to learn...
Last edited by FlyingW; Jul 10, 2020 at 03:32 PM.
Jul 06, 2020, 02:09 PM
Ha! Yeah, I was going to ask about your throttle warning setting!


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Inav Configurator 2.0 No Longer Runs in Windows 10 mmoore112 Beginner Multirotor Drones 2 Dec 07, 2018 05:29 PM
Discussion When you can no longer lie. 62pilot Life, The Universe, and Politics 0 Sep 22, 2018 03:12 PM
Discussion No longer can you see a list of items on each order - Yes You Can Berkie HobbyKing 2 Nov 19, 2016 05:05 AM
Help! UDI 839 can no longer lift off - two rotors overpower others and send it sideways jji79 Mini Multirotor Drones 4 Jan 17, 2016 02:23 PM
Help! CX program box no longer runs servos 2Doggs Electric Heli Talk 0 Feb 20, 2014 09:19 PM