Thread Tools
Jun 30, 2020, 03:10 PM
Registered User
Djodjo's Avatar
Thread OP
Alert

Strange behavior current G-RX8 with ACCESS


I may have a wrong G-RX8 with firmware ACCESS 2.1.0

I measured the no-load current of my G-RX8 and I came to the following measurements and therefore I do not trust it.

all options are unchecked in the receiver menu under " options " no 7ms, no telemetry, no 25mW and no F-port.

The current without load is 35 mA and that is too low ..... only the checkbox "no telemetry" gives a change, if I tick it the current will drop to 30 mA.

I have a G-RX6 and there the no-load current is 80 mA and there it drops to 35 mA without telemetry.

I think Frsky should tell us how it works I don't trust it anymore.
Sign up now
to remove ads between posts
Jul 01, 2020, 02:47 PM
Registered User
Hello Erik,
an RX of thousands
who cares at FrSky
they tell you nothing
Jul 01, 2020, 03:33 PM
Registered User
Djodjo's Avatar
Thread OP
Quote:
Originally Posted by jhammann View Post
Hello Erik,
an RX of thousands
who cares at FrSky
they tell you nothing
I don't know,
I've come across a bit more. If in the diagram the 2.2k resistor is replaced for a capacitor, the HF switch will never work. If antenna A receives a low signal, for example by turning the aircraft, it wants to switch to antenna B, but it does not work because of the capacitor. It has no signal so "telemetry lost" and then immediately switches back to antenna A and "telemetry recovered" due to recovered signal
Jul 02, 2020, 06:39 PM
Registered User
Quote:
Originally Posted by Djodjo View Post
I don't know,
I've come across a bit more. If in the diagram the 2.2k resistor is replaced for a capacitor, the HF switch will never work. If antenna A receives a low signal, for example by turning the aircraft, it wants to switch to antenna B, but it does not work because of the capacitor. It has no signal so "telemetry lost" and then immediately switches back to antenna A and "telemetry recovered" due to recovered signal
Should not be hard to test I guess, just make sure one receiver antenna does not receive any signal and see if you still have control. If you have, try the other antenna. Then I guess no control is possible anymore. You might need to change antenna directions though.
If control is not impacted at all it's probably working differently than in the schematic.
Jul 03, 2020, 03:09 AM
Registered User
Djodjo's Avatar
Thread OP
Quote:
Originally Posted by alm_nl View Post
Should not be hard to test I guess, just make sure one receiver antenna does not receive any signal and see if you still have control.
Yes.... that is a method

or you measure the current and if you then measure 35 mA and no change if you turn the control on or off with "no telemetry" it is also not good ... the current must be around 80 mA at 5 volts with telemetry in operation.
Jul 04, 2020, 06:15 AM
Registered User
Quote:
Originally Posted by Djodjo View Post
Yes.... that is a method

or you measure the current and if you then measure 35 mA and no change if you turn the control on or off with "no telemetry" it is also not good ... the current must be around 80 mA at 5 volts with telemetry in operation.
I'm just more interrested in what you said about antenna usage if that is true or not, as it would also mean that control would be limited by this when the active antenna is not getting enough signal to work with... I have not read anywhere else about it. I have no such receiver myself, so cannot validate.

That you can measure current to see if the receiver is ok or not I do understand, I'm just curious if only Telemetry is impacted or that it also has an impact on control.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! G-RX8 with FrSky Battery Voltage Sensor (FBVS-01) 3Thumbflyer Electric Sailplanes 5 Dec 22, 2019 10:38 PM
Discussion G-RX8 blue led access mode alex998r FrSky 0 Oct 06, 2019 04:33 PM
Discussion G-RX6 receiver - Does it have the same problems as the G-RX8? Miami Mike Radios 12 Jul 07, 2018 08:59 PM
Discussion Strange behavior with Devo 10/frsky beecore Daltron2000 Multirotor Drone Electronics 0 Aug 18, 2017 08:22 AM
Discussion Strange behavior of motors after flashed CC3D with Betaflight sesharim Beginner Multirotor Drones 4 May 08, 2016 03:18 PM