Thread Tools
Jun 15, 2020, 10:11 AM
Registered User

Castle Link wont connect to USB


Cannot get the Castlelink to connect to my USB Port. I have windows on laptop. Castlink software installed. Just the USB and the Castle link interface connected up. Castlelink led comes on.
Later after this is solved I will connect the interface to the ESC.

Anything I should try.
Sign up now
to remove ads between posts
Jun 15, 2020, 05:12 PM
Registered User
doug14's Avatar
Thread OP
I went through this a while back. I tried everything.
I even went to Costco and bought a new laptop. tried several cords
nothing worked . it was very frustrating.
luckily I got a free link with a talon I bought and it connected instantly.
so I contacted castle and they sent me a new one.
I did notice both of mine that work are the bigger usb . the one that didn't work was the micro usb.
and it looks like it was soldered on slightly sideways .
I got several suggestions but in the end it should just work.
I got a red led when it was connected to laptop..and nothing happened when connected to esc . now it connects instantly and I get a green flashing light.
it's a pretty straight forward system. and works with all 9 of my castle escs surface and air
Jun 15, 2020, 05:28 PM
Registered User
Sounds like same thing about the USB cables happened to me. Turns out that some USB cables are dedicated for charging things and do not have the data wire in them that we need. Went thru my stash of cables to swap it out. First one I tried worked right off the bat. Thanks.
Jun 15, 2020, 08:32 PM
Registered User
doug14's Avatar
Thread OP
hey. that's why I started this thread.
hoping it helps more people and saves starting new threads that can have answers found here.
Jun 20, 2020, 02:07 PM
Registered User
doug14's Avatar
Thread OP
with these hot temperatures I'm mounting one of these on all my 5 escs.
servo screws work perfect
spacing is perfect. almost like it was meant to be
Jul 07, 2020, 09:11 AM
Registered User
doug14's Avatar
Thread OP
so this happened today.
started with erratic voltage readings from my telemetry.
6s dropping to 16.9v then jumping to 30v.
thought it might be a bad connection so I checked everything.
then thought it was a bad battery.
next 2 packs did the same thing.
esc temps never exceeded 102deg F .
motor was 96deg after every flight.
thought it might be my ar6600t.
last flight I heard a weird noise from motor. so I dead sticked it. nice smooth landing.
as I spooled up motor to taxi ...everything died. !
I'm so glad I didnt touch throttle after 1st sign of trouble or I'd have a bag full of 60" balsa parts right now.
this is my oldest most used esc. so I'm going to chalk it up to extended use and not complain to castle. although they might warranty it ..its hard to say what this issue is .
I'm only running 70amps on this set up on the bench . so less in the air.
I have fans on all my escs and none go past 110deg F even on hot days.
I might msg castle and see if they know what would cause it. luckily i have a bnib as a back up. tested motor and it seems fine.
Last edited by doug14; Jul 07, 2020 at 09:35 AM.
Jul 07, 2020, 10:48 AM
Gravity is a harsh mistress.
Tim Wolff's Avatar
Looks like you are missing a capacitor. I'd send it in. It is probably worth half off a replacement.
Jul 07, 2020, 08:48 PM
Registered User
doug14's Avatar
Thread OP
ya it popped right off when I opened it up. the 2nd one is almost off too.
waiting for castle to respond. but dont expect much.
I have alot of castle stuff and it's all good stuff. this was just a fluke .
I have a 10yr old sidewinder esc that is still working flawless after many yrs of abuse.
i have 4 more talons so if they replace or give discount it will be kept as a spare.
Jul 09, 2020, 06:15 AM
homo ludens modellisticus
Ron van Sommeren's Avatar
A bad soldering job Doug, metal fatigue, or did they desolder themselves?

Vriendelijke groeten, en wees voorzichtig, Ron
Jul 09, 2020, 08:58 AM
Registered User
doug14's Avatar
Thread OP
hard to say.
it could have been bad solder job on the xt90
I flew 16 packs today with new esc and everything was perfect.
so I'm glad the motor and RX weren't the issue.
no voltage spikes temps stayed cool never passing 95deg. even with 80deg feels like 98 with humidex up here in Ontario. the air flow and cooling fan are really good on this plane. I flew my other plane a few packs but temps were hitting 140deg so I parked it and just flew this one..
Jul 11, 2020, 02:59 AM
Registered User
Castle is not fixing the capacitors , I also lost one capacitor in flight.
Replaced it and a few flights later,the ESC shorted out, and the destroyed two 6s 6200mAh.
And we are not the only one, hard 3D fliers seem to have this problem more often.
Jul 11, 2020, 06:44 AM
Registered User
doug14's Avatar
Thread OP
good to know.
is it from the intense vibration from hard flying?
I dont get my stuff very hot.
Jul 11, 2020, 10:34 AM
Registered User
I think so the leads to the capacitor break of.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Download DragonLink Advanced - dedicated firmware thread Dennis Frie FPV Equipment 15 Jan 19, 2017 01:17 PM
Alert DJI Event Nov 15 - Dedicated Thread cali_drone Multirotor Drone Talk 0 Nov 10, 2016 06:55 PM
Suggestion Dedicated subject threads chatter pudknocker Site Suggestions / Complaints 3 Nov 10, 2015 05:22 PM
Dedicated Thread for Himax 2015-5400 Michael Heer Power Systems 83 Jul 05, 2004 05:38 PM
Dedicated TIPSY thread (?) oldcoot88 Foamies (Kits) 6 Dec 16, 2002 02:15 PM