Phx-Link gone bad? - RC Groups
Thread Tools
Mar 27, 2005, 02:15 PM
Registered User

Phx-Link gone bad?

I picked up a Phx-25 and Phx-Link yesterday at my LHS. Got home, loaded the software and driver on my XP machine and it worked fine. Today, I figured the old 98se machine ought to to the basement shop where it might get some use. After software installation, 98se recognized a new USB device, but did not identify it as a Phx-Link.

Moving the Phx-Link back to the XP machine gave the error message: USB Device Not Recognized. Device Manager now shows "Unknown Device" and updating drivers gives the message "The wizard could not find a better match than the software you currently have installed." Lights on the Lnk operate the same as before. I've tried different ports on the XP machine, yet different devices work in the same ports. I've even installed the software on a second XP machine with the same results. Does anyone have any other ideas?

Thanks for any help,
Sign up now
to remove ads between posts
Mar 27, 2005, 05:15 PM
Registered User
Problem fixed! Disconnected the Link from the cable and reseated. It's a happy board! Pure coincidence that it happened right after trying 98se.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Dog fight gone bad Joe_in_AZ Aircraft - Fuel - Airplanes (FS/W) 2 Jul 25, 2002 05:07 PM
Dual conversion Rx gone bad. Pierre Audette Power Systems 12 May 28, 2002 02:54 PM
"View all sponsors" link is gone Bill Germanson Site Chat 7 May 10, 2002 11:51 AM
Good Neighborhood gone bad Soarhead49 Life, The Universe, and Politics 3 Aug 04, 2001 01:21 PM