Thread Tools
Jan 24, 2020, 04:16 PM
Registered User
Quote:
Originally Posted by Temporal Flux
Sounds like you are maxing out the CPU usage somehow. Are you running Dshot300? What is your Gyro/PID loop frequencies?

Are you using RPM filters? JESC should work with BF3.5.7 but you won't have RPM filters.

Did you try going back to the normal BLHeli-S ESC firmware?

Make sure that you are using a clean configuration between Betaflight versions. Don't use a diff or a dump from BF3.5.7 on BF4.1.x (or vice versa). When you are flashing firmwares make sure that full board erase is on.

What radio are you using and which firmware version is on it?
Im running Dshot300 on 4k4k, not rpm filter. CPU was at about 20% . I always erase, for some reason when I came back to BF from EMU the emu splash logo is still on, so does this mean it did not erase entirely?

Ill try reverting back to normal esc firmware and see.
Sign up now
to remove ads between posts
Jan 24, 2020, 04:43 PM
Registered User
Quote:
Originally Posted by jcgandiaga
I got my Mob6 and it was awesome out of the box, range was spectacular on D8, video always great! I decided to move to 4.1.2 and JESC 48khz. Now I have drop outs and range is poor. Got in here and saw that 4.1.2 had issues, dialed back to 4.1.1 and the same thing. Switched to EMI flight 0.1 and 0.2 and it was worst, it would fall out of the sky after 25 feet. Now I went to 4.1.3 on D8 JESC 48khz and I get ok range but after 70 feet its skipping inputs, i.e. I make a roll and it will not stop were I want it to stop or it freezes the same input for like half a second and if I can make my way back closer to me it perfect.

Should I go back to 3.5.7? Also would jesc48khz work with 3.5.7?
Can you actually go back to 3.5.7. I dont think they have it listed anymore. Not sure how you would revert back to old FW. I guess it's stored on GitHub somewhere?

JESC 48khz is not dependent on BF version however RPM Filtering is.
Last edited by Fidy$Trainer; Jan 24, 2020 at 04:50 PM.
Jan 24, 2020, 04:53 PM
Registered User
Temporal Flux's Avatar
Quote:
Originally Posted by jcgandiaga
Im running Dshot300 on 4k4k, not rpm filter. CPU was at about 20% . I always erase, for some reason when I came back to BF from EMU the emu splash logo is still on, so does this mean it did not erase entirely?

Ill try reverting back to normal esc firmware and see.
Those seem fine. Just check the ESC firmware.

You don't happen to be using a Jumper radio or multiprotocol module do you? Because if so, your freq.fine may need calibrated.

Reupload the font in the Betaflight OSD tab. That should fix your splash screen.
Jan 24, 2020, 04:56 PM
Registered User
Temporal Flux's Avatar
Quote:
Originally Posted by Fidy$Trainer
Can you actually go back to 3.5.7. I dont think they have it listed anymore. Not sure how you would revert back to old FW. I guess it's stored on GitHub somewhere?.
It is listed in the firmware flasher, you just need to select the Legacy target.
Jan 24, 2020, 09:27 PM
Registered User
Quote:
Originally Posted by neo2001
I've had some problems with the provided lipos falling out midflight.

Is there something, like a rubber band, that wasn't supplied or does the battery sit very loose for all of you?

Anyway, I've designed and printed some kind of a holder thingy for mine, which works fine:
https://www.thingiverse.com/thing:4118481

I also added a 9 mm buzzer, since I like to get audible battery alerts from the drone itself.
I also found that my batteries were a little loose and I saw on some video that someone put a very small strip of the fuzzy side of a velcro strip on the side of the battery holder. I did the same, and it works well for me with very little extra weight.
Jan 25, 2020, 05:22 AM
Team WarpSquad
Phoboss's Avatar
Quote:
Originally Posted by Gozzz
Meteor65 frame and replaced the stranded antenna with a solid core copper for the 2.4ghz. Stationary range check seems about the same as the stranded antenna but I haven't flow it yet as the batteries are still charging.

I have a question though, why is there a ST Micro F05 chip on the board? I recognize what everything else on it is for but not sure what that one is doing?

Thanks!
It controls the analog video chip.
Jan 26, 2020, 09:47 AM
Registered User
Quote:
Originally Posted by Phoboss
It controls the analog video chip.
Ahh makes sense. Thanks Phoboss.
Jan 26, 2020, 01:05 PM
Registered User
Any luck after that change gozz? I have terrible rx range and fail-safes constantly. I can't even make it 10ft into another room at the moment. I tried swapping for other whoop antennas etc of the same length with no luck. My ur65 doesn't drop out anywhere. The mob6 was worse from the start but has declined further
Jan 26, 2020, 01:08 PM
Registered User
Quote:
Originally Posted by jcgandiaga
I got my Mob6 and it was awesome out of the box, range was spectacular on D8, video always great! I decided to move to 4.1.2 and JESC 48khz. Now I have drop outs and range is poor. Got in here and saw that 4.1.2 had issues, dialed back to 4.1.1 and the same thing. Switched to EMI flight 0.1 and 0.2 and it was worst, it would fall out of the sky after 25 feet. Now I went to 4.1.3 on D8 JESC 48khz and I get ok range but after 70 feet its skipping inputs, i.e. I make a roll and it will not stop were I want it to stop or it freezes the same input for like half a second and if I can make my way back closer to me it perfect.

Should I go back to 3.5.7? Also would jesc48khz work with 3.5.7?
I'm having the same problem with skipping inputs and fail safes. I've tried the same things as you posted here. Did you ever find anything that worked?
Jan 26, 2020, 01:11 PM
Registered User
Quote:
Originally Posted by Thraid
Any luck after that change gozz? I have terrible rx range and fail-safes constantly. I can't even make it 10ft into another room at the moment. I tried swapping for other whoop antennas etc of the same length with no luck. My ur65 doesn't drop out anywhere. The mob6 was worse from the start but has declined further
With the solid core copper antenna I am still getting lower RSSI than the betafpv board in my basement. I'd assume in an open room there are no issues but I'm not back at work until Monday to test the library environment so I won't know what the level of improvement is until then (I'll post an update).

For racing in an open room I don't foresee a problem but with any solid obstacles (like bar room racing/house cruising?) it could be pretty bad. It's a bummer because the quad flies amazing besides this...
Jan 26, 2020, 01:12 PM
Registered User
Quote:
Originally Posted by Gozzz
With the solid core copper antenna I am still getting lower RSSI than the betafpv board in my basement. I'd assume in an open room there are no issues but I'm not back at work until Monday to test the library environment so I won't know what the level of improvement is until then (I'll post an update).

For racing in an open room I don't foresee a problem but with any solid obstacles (like bar room racing/house cruising?) it could be pretty bad. It's a bummer because the quad flies amazing besides this...
Agreed. The thing flies amazing if it's directly in front of me, but as soon as it gets around a wall it's laggy then fail-safes. Good luck !

Sent from my Pixel 3 XL using Tapatalk
Jan 26, 2020, 01:17 PM
Registered User
Quote:
Originally Posted by Thraid
Agreed. The thing flies amazing if it's directly in front of me, but as soon as it gets around a wall it's laggy then fail-safes. Good luck !

Sent from my Pixel 3 XL using Tapatalk
If you're on d8 try binding on frsky_x and use 1-8 channels for the latency improvement, that's what I did in my betafpv aio and it works flawlessly, I'm going to try that on my mobula6 frsky standard edition and see if that helps before I solder on the solid core wire
Jan 26, 2020, 01:20 PM
Registered User
Quote:
Originally Posted by jay_206
If you're on d8 try binding on frsky_x and use 1-8 channels for the latency improvement, that's what I did in my betafpv aio and it works flawlessly, I'm going to try that on my mobula6 frsky standard edition and see if that helps before I solder on the solid core wire
I've tried both D8 and D16 Chan 1-8 no telemetry. For me they behave exactly the same unfortunately.

I might try to go back to old BF firmware and revert to blheli 16.7 too. I'm currently on 4.1.1 with jesc 48k. I've tried with and without the rpm filter as well. All else fails I might try to stick an sbus receiver on it..

Sent from my Pixel 3 XL using Tapatalk
Jan 26, 2020, 01:28 PM
Registered User
Quote:
Originally Posted by Thraid
I've tried both D8 and D16 Chan 1-8 no telemetry. For me they behave exactly the same unfortunately.

I might try to go back to old BF firmware and revert to blheli 16.7 too. I'm currently on 4.1.1 with jesc 48k. I've tried with and without the rpm filter as well. All else fails I might try to stick an sbus receiver on it..

Sent from my Pixel 3 XL using Tapatalk
It's not looking well for me then... Fiddy seemed pretty content with spi performance on 4.1.1 so I don't think that's a problem, I wouldn't mess with ESC firmware if you're on jesc maybe if you're running jazzmaverick I would go to jesc. If I have to put a full RX on this thing I'm going to be pissed, that'd negate all the weight savings of an onboard vtx, if it comes to that I'll just have to convert to a 75 frame and hit happy model up after they admit to spi and eeprom issues
Jan 26, 2020, 02:01 PM
Registered User
@Thraid I just did a quick test at the house. Flying from the basement, 3 floors, to opposite end of the house. Min RSSI 51%. Seems better than the stock antenna for sure as I was skipping frames previously on the 1st floor and didn't bother flying up there.

YT link for what environment I'm testing in (Excuse the state of the house).
Mobula6 Solid Core Receiver Antenna Mod #HappyModel #Mobula6 (2 min 15 sec)


EDIT, FWIW Betaflight 4.2 build 1947, Blheli_s 16.77, RPM filtering, SPI_RX d16 ch 1-8 with telemetry.
Last edited by Gozzz; Jan 26, 2020 at 02:11 PM.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Happymodel Toad 90mm Micro FPV 3K Carbon Fiber Frame Kit with CNC Aluminum Cam Mount Livershifter Micro Multirotor Drones 1 Jul 14, 2017 03:32 PM
News Happymodel VMR40 5.8G Mobile Video Receiver Matt Gunn FPV Talk 34 Jul 04, 2017 03:44 AM
Discussion happymodel neo-m8n-1 PINOUT help. flybytim Multirotor Drone Electronics 1 Apr 16, 2016 01:12 PM
Discussion Happymodel Ready to Use Gopro3 Brushless Gimbal No Program Needed copterstar Multirotor Drone Talk 2 Jul 29, 2013 10:07 PM