Thread Tools
Oct 22, 2019, 06:50 AM
Registered User
Thread OP
Discussion

UMX GEE BEE Red Flashing LED????


I got the UMX Gee Bee yesterday and everything went PERFECT for its maiden and I was even able to land it successfully! However, once I tried to fly it again a few hours later, I noticed the receiver now always just flashes a red LED, and doesn't respond to any control inputs. The brushless motor makes a few beeps initially, but then goes silent. I am unable to locate any other person that has had this issue, but i'm hoping someone out there knows.
Sign up now
to remove ads between posts
Oct 22, 2019, 08:26 AM
Lifetime Member
JohnM's Avatar
Try rebinding. Also make sure your throttle is at zero or negative. When binding or initializing, move further away from the aircraft.
Oct 22, 2019, 03:34 PM
Registered User
Thread OP
tried everything....Returned to Horizon and they will send immediate replacement! Gotta love that HH!


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Article E-flite UMX Gee Bee R-2 BNF Basic with AS3X and SAFE Jason Cole Micro Ready-to-Fly 68 Aug 27, 2019 04:33 PM
Discussion Vector Led flashing red and buzzer going on and on and ... chriz___ Eagle Tree Systems 1 Jun 06, 2016 08:14 AM
Discussion naze32 alternate flashing red green leds slow / fast handsomejackuk Multirotor Drone Electronics 11 May 17, 2016 01:26 PM
Discussion Spreading Wings 900 LED Indicator only flashes red adjack Multirotor Drone Electronics 2 Mar 20, 2016 02:07 PM
Question ESC flashing red LED RunAway15 Beginner Multirotor Drones 10 Dec 14, 2015 11:54 PM