Thread Tools
Oct 21, 2021, 05:43 AM
Registered User
Dieter.guenther's Avatar
Expresslrs/ Backpack

Hardware is ok.
Flashed I need help.
I search the right file.

https://github.com/ExpressLRS/Backpack
Sign up now
to remove ads between posts
Oct 21, 2021, 06:23 AM
Discovering the joys of flying
Adilson's Avatar
Quote:
Originally Posted by wazoo22
I"d like to use 1.280G video with 2.4G elrs. What's this about "not play nice"? A reference or more info would be appreciated. Since I'm in Europe, I'd like to stay as close to legal as possible. A wing-wing (Z84) is pretty limited in space, so I'd like to use the 2.4 frequency.
Elaborating a little more on RocketMouse says, the problem is that 1.2 and 2.4 are multiples of each other. When you create an RF signal, you will create harmonics which are secondary signals in the multiple frequencies of the main one which means 1.2Ghz will create signals in the 2.4Ghz region and vice-versa which will interfere with the main signal. Theoretically, one can filter out those harmonics but unless you are using very special equipment and precise (i.e. expensive) components, the interference will still be very significant so, for our purposes, the best is to avoid those combinations.
Oct 21, 2021, 06:45 AM
Registered User
RocketMouse's Avatar
That's a very good explanation!
Oct 21, 2021, 08:21 AM
Registered User
wazoo22's Avatar
Quote:
Originally Posted by Adilson
Elaborating a little more on RocketMouse says, the problem is that 1.2 and 2.4 are multiples of each other. When you create an RF signal, you will create harmonics which are secondary signals in the multiple frequencies of the main one which means 1.2Ghz will create signals in the 2.4Ghz region and vice-versa which will interfere with the main signal. Theoretically, one can filter out those harmonics but unless you are using very special equipment and precise (i.e. expensive) components, the interference will still be very significant so, for our purposes, the best is to avoid those combinations.
Indeed it is. As a long-time ham, I'm embarrassed to have even asked it. X2 ain't higher math.
What I really need to know is this:
Bearing in mind the narrow band size available on 868mhz in Europe, what kind of performance can we reasonably expect from, say, Happymodels' 250mw 868mhz system? Not sure why the LoRa modulation works so well on 2.4, either. Joined the discourse, but still haven't had the time to read up.
Last edited by wazoo22; Oct 21, 2021 at 08:27 AM.
Oct 21, 2021, 08:25 AM
Discovering the joys of flying
Adilson's Avatar
Quote:
Originally Posted by wazoo22
Indeed it is. As a long-time ham, I'm embarrassed to have even asked it. X2 ain't higher math.
What I really need to know is this:
Bearing in mind the narrow bandwidth available on 868mhz in Europe, what kind of performance can we reasonably expect from, say, Happymodels' 250mw 868mhz system? Not sure why the LoRa modulation works so well on 2.4, either. Joined the discourse, but still haven't had the time to read up.
Do you mean performance as in distance? I don't see an issue there. With good antennas, we're talking about tens of km.
Oct 21, 2021, 12:14 PM
Discovering the joys of flying
Adilson's Avatar

Wireless relay - half succeeded


Hi there

For some time I've been thinking about creating some sort of wireless connection between the ExpressLRS tx and the radio so one can mount the TX on a pole to have better range and be more comfortable under the shade or something like that. This is for long-range so delays are really not an issue. I was able to convert the half-duplex serial connection from the radio (Jumper TX16) to the FRSky R9M module to a normal TX/RX serial and it works fine. The idea now is to add some sort of wireless bridge. My first attempt was using a pair to HC-05 Bluetooth modules configured as master/slave so the connection is automatic and configure them to 115200bps. This part, separately, works fine as well, they connect automatically and I can send serial data from one to the other but putting everything together does not work.
Are there any obvious points I may be missing?

ADITIONAL: I am assuming my radio's serial is 115200 because I have an internal bluetooth module and also don't have the serial speed adjust option in the opentx menu. Maybe I'm wrong?

ADITIONAL ADITIONAL (Red Dwarf anyone?): I was able to almost work but looks like the bluetooth's bandwidth can't keep up with the data as the TX connects and disconnects - or at least what I think as they make low-pitch/high-pitch beeps and, a couple of seconds later, the opposite and stays like this in a cycle. I think I'll try ESP-NOW next.

Thanks in advance
Last edited by Adilson; Oct 22, 2021 at 12:14 PM. Reason: Adding information about latest experiment
Oct 22, 2021, 12:09 PM
Registered User
pierrotm777's Avatar
Hello,

I am a newbie with ExpressLrs :-)

I have two board Heltec Lora32
than i want use in 868Mhz.

I have also a BETAFPV nano board than i want use as receiver.

I have build and uploaded into the TTGO board used as TX, but i see nothing on the screen.
I see only an orange led who blinking !
This board is only connected on a usb cable, not on my Transmitter.

If i understand, i need to define a CRSF protocol with inverted or not serial connexion.
1. Do i use the good config for my TTGO as TX ?
2. What config do i need to use for the BETAFPV board as RX?
3. My configurator see only a 1.2.0 official version. It's normal?

Thanks for your helps,

Pierre
Oct 23, 2021, 06:21 AM
Registered User
RocketMouse's Avatar
Quote:
Originally Posted by Adilson
Hi there

For some time I've been thinking about creating some sort of wireless connection between the ExpressLRS tx and the radio so one can mount the TX on a pole to have better range and be more comfortable under the shade or something like that. This is for long-range so delays are really not an issue. I was able to convert the half-duplex serial connection from the radio (Jumper TX16) to the FRSky R9M module to a normal TX/RX serial and it works fine. The idea now is to add some sort of wireless bridge. My first attempt was using a pair to HC-05 Bluetooth modules configured as master/slave so the connection is automatic and configure them to 115200bps. This part, separately, works fine as well, they connect automatically and I can send serial data from one to the other but putting everything together does not work.
Are there any obvious points I may be missing?

ADITIONAL: I am assuming my radio's serial is 115200 because I have an internal bluetooth module and also don't have the serial speed adjust option in the opentx menu. Maybe I'm wrong?

ADITIONAL ADITIONAL (Red Dwarf anyone?): I was able to almost work but looks like the bluetooth's bandwidth can't keep up with the data as the TX connects and disconnects - or at least what I think as they make low-pitch/high-pitch beeps and, a couple of seconds later, the opposite and stays like this in a cycle. I think I'll try ESP-NOW next.

Thanks in advance
I'm not sure but the baudrate there might be 420000 but not 115200.
Can you please share how to convert the half-duplex serial connection from the radio to a normal TX/RX serial ?
Oct 23, 2021, 06:40 AM
Discovering the joys of flying
Adilson's Avatar
Quote:
Originally Posted by RocketMouse
I'm not sure but the baudrate there might be 420000 but not 115200.
Can you please share how to convert the half-duplex serial connection from the radio to a normal TX/RX serial ?
Yes, by default it is 420000 but with edgetx I was able to use 115200.
There are several ways to convert the inverted half-duplex serial, in my case I used 2 x MAX3232 that I had around like the picture attached.
Oct 23, 2021, 01:19 PM
Newsworthy
Quote:
Originally Posted by pierrotm777
I have build and uploaded into the TTGO board used as TX, but i see nothing on the screen.

If i understand, i need to define a CRSF protocol with inverted or not serial connexion.
1. Do i use the good config for my TTGO as TX ?
2. What config do i need to use for the BETAFPV board as RX?
3. My configurator see only a 1.2.0 official version. It's normal?
I'm not sure about all your questions, but:
* 1.2.0 is the latest version
* The TTGO screen doesn't have anything on it in 1.x (I don't think), but does in master (2.0 when released)
* If you're connecting to a regular OpenTX radio, you need UART_INVERTED set
* The BetaFPV RX are ... BetaFPV in the configurator, not sure what you're asking there
Oct 28, 2021, 08:29 AM
Registered User
I have a question about firmware versions.

I have updated the TX and RX to 1.2.0, but on the wifi update website (10.0.0.1) it still says "firmware rev. 1.0".

The connection works very well though, so binding phrase seems to be on both RX and TX firmware.
Does anybody know if this is normal behaviour? Any other method of checking firmware versions?
Oct 28, 2021, 12:07 PM
Donīt grow up, itīs a trap
aMax's Avatar
Quote:
Originally Posted by shangoo
I have a question about firmware versions.

I have updated the TX and RX to 1.2.0, but on the wifi update website (10.0.0.1) it still says "firmware rev. 1.0".

The connection works very well though, so binding phrase seems to be on both RX and TX firmware.
Does anybody know if this is normal behaviour? Any other method of checking firmware versions?
This is ok, 1.0 is not the firmware version.....but something else, lua, webpage or ????.
Already in work for the next page.
Only the transmitter lua showing 010200 counts.
Nov 01, 2021, 06:02 PM
Discovering the joys of flying
Adilson's Avatar
Hi there
As I said before, I've been working on a way to create a wireless repeater for expresslrs and I'm almost there but this is a very simplistic way, just a glorified serial-wireless bridge.
I'm also thinking about a different approach: convert crfs to f-port (or sbus+telemetry) and vice versa thus allowing the use of standard frsky receivers.
Bare in mind the idea here is to use ExpressLRS for long range so latency is not an issue.
And yes, a cable works (I tried) but I don't want to use one
Any thoughts on that?
Nov 03, 2021, 04:19 PM
Registered Plane Crasherx
i have a jumper t12 with r9m2019 flashed with elrs and a r9mx. they bind but i get no sensor data and no channels reflected in inav. help?
Nov 03, 2021, 08:06 PM
Donīt grow up, itīs a trap
aMax's Avatar
Quote:
Originally Posted by dronevate
i have a jumper t12 with r9m2019 flashed with elrs and a r9mx. they bind but i get no sensor data and no channels reflected in inav. help?
TX & RX crosswise at the right pins on the fc? Sensor discover done?

Edit: .... INAV receiver tab: Protocol CRSF and the next two options, inverted and half duplex to OFF.
Last edited by aMax; Nov 03, 2021 at 08:19 PM.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product QCZEK LRS - DIY 433MHz 1W (30dBm) LORA RC LINK with telemetry qczek DIY Electronics 4855 Nov 25, 2021 08:22 PM
Discussion Anybody interested to develop a LoRa based Tx Protocol? courcirc8 Radios 8 Jun 07, 2018 03:01 PM
New Product FPVmodel X160 Pro FPV Racer (Optimized Based on DYS X160) FPV.Model Mini Multirotor Drones 5 May 28, 2016 09:19 AM
Discussion DIY Telemetry System base on TI CC110L RF BoosterPack spy004 DIY Electronics 2 Mar 06, 2013 08:58 AM
Discussion Tucson schools create race-based system of discipline MtnGoat Life, The Universe, and Politics 8 Mar 16, 2012 01:22 AM