Thread Tools
Aug 30, 2019, 08:12 PM
Registered User
Thread OP
Discussion

Omnibus F4 V6 Firmware


Year old tutorials and sketchy manuals instruct users to flash Omnibus Fireworks firmware to this board. Is this still what you should do or do I flash the Omnibus F4 V6 firmware?
Sign up now
to remove ads between posts
Aug 31, 2019, 07:24 AM
Registered User
mlebret's Avatar
Quote:
Originally Posted by WARLocK69
Year old tutorials and sketchy manuals instruct users to flash Omnibus Fireworks firmware to this board. Is this still what you should do or do I flash the Omnibus F4 V6 firmware?
https://blog.dronetrest.com/omnibus-...troller-guide/

Just one year old guide..., Fireworks is for iNav version
Aug 31, 2019, 09:57 PM
Registered User
Thread OP

Thx for reply


Gave the FIREWORKS V2 firmware a whirl with INAV and in CLI the SDA/SCL are mapped too B10 and B11 and mag does not function. Mag automatically connects with omnibus F4 V6 firmware, SDA/SCL mapped to B8 and B9. Couple other things were mapped different from silkscreen on board. Sticking with omnibus F4 V6 firmware.
Sep 02, 2019, 02:54 PM
Registered User
I just tried iNAV 2.2.1 FIREWORKS V2 this afternoon, having had problems with OMNIBUS F4 V6. It installed successfully, but then wouldn't allow me to get out of CLI mode, so I've gone back to F4 V6 to try and get things working -- unsuccessfully so far My other thread gives details of my issue, and what I've tried so far.
Sep 03, 2019, 10:55 AM
Registered User
Thread OP

Bn880


It's been my obsession since I purchased the Tyro99 and some short comings of betaflight to give INav a try. Loops and spins and lots of crashes ran there course and beat the snot out of 2 Tyro99s and a Tero Q215. Tyro99 has no barometer or SDA/SCL, Tero Q215 no SDA/SCL without disabling onboard VTX. Enter the Omnibus F4 V6, Typhoon 30A BLHeli_S, BN 880, R9mm FPort and my search for answers. 1 out of 5 flights end in disaster. One thrilling waypoint mission was the highlight of my INav experience. I also use a Wizard X220s with the BN880, this one was more successful than the one above but also randomly flip out and crashed. As long as we post info resolution will result.
Sep 05, 2019, 06:40 AM
Registered User
Thread OP

Conclusion


INav doesn't run well on my beat up betaflight quads. Although this flight controller is new. Everything else was salvaged from my betaflight Tyro99s. Which still fly well in betaflight but now fly really well since I ditched JST connectors and soldered GPS, Mag, Receiver and VTX. New props and motors on the way. Anyway I'm gonna give INav another whirl.
Sep 05, 2019, 08:18 AM
Registered User

Update


I haven't flown it yet, but I've now got all indicators solid blue using iNav 2.2.1 Omnibus F4 V6 firmware in my FrSky Omnibus F4 V6 board. What has cured my magnetometer problem is the addition of 3.3k ohm pull-up resistors between the SDA pad and 3.3v pad, and the SCL pad and 3.3v pad.

I'd read about pull-up resistors in other threads, but not in relation to this particular board, but didn't really want to mess about adding components to the board. But a post in another thread convinced me it's the way to go, and it works for me. I still don't like the idea that I have to modify a brand-new board to make it work with industry-standard peripherals, but seems I've got no choice
Sep 05, 2019, 04:15 PM
Registered User
Thread OP

Awesome tell us how it goes


Yikes I have a puck style GPS ordered and on its way. Anyway had a brand new Wizard X220s set up with INav, omnibus F4 V3, firmware version LED motor 5 Soft Serial motor 6. Using Soft Serial for smart audio on motor 6 pad disables LED pad but there is like 4 or 5 targets for this board. One of them puts LEDs on motor 5 and soft serial on motor 6. And all was well it seemed til I flew and it just randomly flipped over and hit the ground. Watched Pawel Palowisky video and he is using DShot 600 so I switched to DShot. No problems for like 20 flights I was using alt hold, pos hold, and doing awesome waypoint missions until the last flight just leisurely floating around in alt hold, suddenly throttle maxed, and throttle minimum were my only options, was over grass I worked it up and down until I was near the ground and disarmed. Brand new Wizard X220s ($140), Run Cam 5 ($100), R9MM ($20), smart audio capable VTX ($20) and a 3s 2200mah battery ($20). INav discontinued on the X220s and flashed to quads that have some mileage. DShot worked the best, standard gave me flip overs, multishot devastating crash of a Tyro99, screen went black 50m drop onto cement, 2 motors, frame and omnibus F4 V6 destroyed. I'm gonna keep trying lol... alt hold, pos hold, waypoint and some acro all in one flight was very thrilling for me.
Last edited by WARLocK69; Sep 05, 2019 at 06:14 PM. Reason: more info
Sep 13, 2019, 03:09 AM
Brisbane, Australia
deleted
Last edited by Ian444; Sep 13, 2019 at 04:53 PM.
Sep 13, 2019, 05:18 AM
Registered User

Everything working fine


I flew it last weekend and it flew fine, apart from a bit of toilet-bowling in the final few metres of descent on RTH. I'll be recalibrating the compass outdoors (away from all the metal and magnets in my workshop) before I test it again.
Sep 15, 2019, 09:31 AM
Registered User
Thread OP

Gonna fly today


Going with mutishot but calibrated this time... didn't know about calibrating analog ESC protocols.
Sep 18, 2019, 10:09 AM
Registered User
Thread OP
Toilet bowling solution... I found using trim from my controller was causing toilet bowl effect. When I centered trim the TB went away. I have now disabled trim. Both in inputs and mixer opentx.
Sep 18, 2019, 02:04 PM
Registered User
I never trim when flying quads. Anyway, recalibrating the compass outdoors, instead of in my workshop, eliminated the toilet-bowling.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Omnibus Nano F4 v6 Mayolli Multirotor Drone Electronics 593 Oct 12, 2019 11:37 PM
New Product Airbot Omnibus AIO F4 - V6 josephr Multirotor Drone Electronics 25 Oct 06, 2019 02:01 PM