Thread Tools
Jun 26, 2020, 10:01 PM
Registered User
Smyk's Avatar
Thread OP
Hi Jim '
'That would be simple
it does it well on PPM mode

About these Taranis radios you got separate firmware made for JR module around 2018.
it was a version 4,3 i believe . You got that link above
anyway I am trying to locate the reason what is wrong.
I do have lots old stuff collected from you over the years
I am in the mood to check what firmware they running and what must be updated
I have downloaded the current updater and got stuck on installation
below a picture of the error
Sign up now
to remove ads between posts
Jun 26, 2020, 10:11 PM
Registered User
Smyk's Avatar
Thread OP
and
Manual for JR, futaba modules is outdated too
It doesn't cover things we must do to change to the module's input mode to 2
I do not see color LED blinking at all
But let me do updater to see what is going on
I am aiming on entire flack of XPS thingies . I got tons of it. It served me well
Jun 26, 2020, 10:22 PM
Registered User
Smyk's Avatar
Thread OP
yeah
I need the programmer to be hooked up first
i will know more in the morning

Mike
Thanks for all the good stuff
Jun 26, 2020, 10:45 PM
Registered User
Smyk's Avatar
Thread OP
I got two JR modules version
3.1
3.7
programmer binds on PPM mode , but does't connect to the TX

seems like I have to send these modules to you
Let me check rest of my stuff for a combined service


Mike
Jun 26, 2020, 11:05 PM
Registered User
Smyk's Avatar
Thread OP
It does fine with MPX Tx
Jun 27, 2020, 07:22 AM
Registered User
Smyk's Avatar
Thread OP
Jim

How do you properly download , install and run current version of software and updater of XDP on Windows 10?

I have followed first step from this page and it should have everything current
https://www.xtremepowersystems.net/x...are%20Upgrades
maybe I should download the last version on the list?
Maybe I have to uninstall what ever I have installed last night and try again
While running shows not everything current ( maybe some parts do not have to be current) and it actually did manual update , but doesn't show current version after that. It fails to see XPD device, but it will do Tx ( it sees that). When you try to open the tool menu it shuts the unit ( no IRSS) and lots of other little things. Is hard to overcome entire issue after one night sitting with that
I see I need to update almost every bit of XPS stash, but it is little confusing

I hope there is a easy fix for all that
I would love to have a grip on it .

Mike
Last edited by Smyk; Jun 27, 2020 at 07:28 AM. Reason: spelling
Jun 27, 2020, 07:20 PM
Registered User
Smyk's Avatar
Thread OP
I made little progress with handling XDP software and updater updates

Jr modules are 3.1 and 3.7 and updater wants to do 4.3 , but I will wait what Jim says.
I got 4 first generation Nanos E v1.7 and 17 Nano II V1.0
I still have to figure out how to put nanos in update mode and get them connected with XDP
The other Rxs ( old 8 and 10 channels - I still use them ) RFU, X 10 and X 24 no problem to update.
All other Tx modules updated
Now jumping back to Jumper and Open TX wonders. it is very like MULTIPLEX. I have even put my rusted Profi 4000 on the table again

Mike
Jun 27, 2020, 08:00 PM
You must install and run all of the apps in Administrator mode.
Jun 27, 2020, 08:05 PM
Only the old (pre-v3.x, circa 2008) transmitter modules will work by default with the Tx Diagnostic app. You can change the hopping mode to 1 with v3.x transmitter modules if you want to use that app. However, you should be using the RSSI app to check all transmitter modules having v3.x firmware.
Jun 27, 2020, 11:01 PM
Registered User
Smyk's Avatar
Thread OP
Jim
To take the confusion out
The goal is to make the JR tx module work with Open Tx and handle XJT D16 protocol
By the link in the post #21 it requires modules to be sent to you for a update. from v3.x to v4.3
Maybe it is no longer valid and recent updater could handle it
Yes I do install and run all Apps in Admin mode
if I fix rest of the things I do not know I will take situation under control
two things
1* Make XPS-J1 work with new crop of Open TX transmitters
2* Find the way to update nanos. How to put them in update mode. Probably it is in the manual I still have to re read

Thanks for keeping eyes on us

Mike
Jun 28, 2020, 07:52 AM
Registered User
Smyk's Avatar
Thread OP
All the NANOs are updated

You must be pretty quick in removing that binding plug. Especially on first generation ( E& T) NANOs. NANO II is more tolerant

Only thing left is to upgrade JR module to XJT D16 capability

Mike
Jun 28, 2020, 01:42 PM
You MUST have the JR module in hopping mode other than 1 in order to use the XJT-D16 mode. You must set the JR module to input the XJT-D16 mode.

The timing for the binding plug is the same for all Nanos.
Jun 28, 2020, 02:20 PM
Registered User
Smyk's Avatar
Thread OP
In other words
Upgrade the module to 4.3
Set the hoping mode to 2
set the Tx software option to XJT D16
No need to send it to you

OK
let me do it
Jun 28, 2020, 04:35 PM
Registered User
Smyk's Avatar
Thread OP
Hi Jim

I was hoping all going to the happy end.

I have upgraded JR module to the version 4.3
I have tried to access the hoping mode by buttons, but it seems they do no blink anymore. There is a solid Green , then Red and Orange indicating programming access
I went to XDP computer access ( yes admin mode)
It spotted the module and when I have tried click at setting button , XPS window disappeared with no trace
When trying to restart it, it says XDP program is running
To bring it back I have uninstalled and reinstalled the whole program several times
nothing is to help
pressing the bottom button makes the XPD window gone

Mike
Jun 28, 2020, 08:02 PM
To change the power, hopping mode, or input mode put the module into push button programming mode. To put the module into push button programming mode, press and HOLD the PROG button until you see the LED change from OFF to GREEN to RED. When the LED is red, release the PROG button. Now, you can press and release the button to change the programming mode. RED = power, GREEN = hopping, ORANGE = input mode.

You can use Window's task manager to kill the task if it disappears like that. I am not sure why that would occur though.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Jumper T16 2.4G 16CH OpenTX Multi-protocol Radio rotorsupport Radios 11102 Today 01:14 PM
New Product Jumper T16 2.4G 16CH Open Source Multi-protocol Radio Transmitter w/ JP4-in-1 BG-Wilson Radios 10 May 30, 2019 09:06 AM
New Product Jumper T16 2.4G 16CH Open Source Multi-protocol Radio Transmitter w/ JP4-in-1 RF Modu BG-Wilson Multirotor Drone Talk 17 Mar 22, 2019 08:56 PM