Thread Tools
Aug 16, 2019, 10:29 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Help!

Tricopter Servo Issues


Hello! This a divergence from my build/unveil. Problem is, the servo is being a bugger. I have it soldered the the LED pin on this banggood omnibus F4. I have confirmed with a multimeter that the pad goes to the processor. The servo is powered off 5 volt on the board. When the copter is powered, the servo goes a couple degrees to the right and stops and doesn't lock like a tracking servo. Here was my main thread --> https://www.rcgroups.com/forums/show...g#post42536745

And I have text doc for the CLI dump.
Sign up now
to remove ads between posts
Aug 16, 2019, 11:50 PM
If it flies, I can crash it.
rocketsled666's Avatar
"Doesn't lock like a tracking servo" isn't a sentence that makes sense. Record a video on your cell phone, upload it to Youtube, and post it here so you don't have to try to describe it better...

That being said, some of what you describe is what I would expect. When you power it up the servo should move to wherever the FC is commanding it to move to and stay there. If you expect the servo to move as you yaw the copter, you may need to arm it and crack the throttle a little before it will do so. The FC knows when it's not flying and it doesn't do anything when it's in that state.
Aug 17, 2019, 12:35 AM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Thats too much work. When a servo is on and given a command, if you try to twist it it will resist you're twist. Like an rc plane control surface. The movement I described is random. When it gets powered it goes ~20% to the right everytime it gets powered. I have tried flying it in this stage, the performance is garbage due to the FC knowing something ain't right. Later tomorrow I'll do a vid.
Aug 17, 2019, 10:29 AM
Registered User
Looked at the controller specs, it says it requires the OMNIBUSF4SD target, but from your CLI dump, it looks like the OMNIBUSF4 target is loaded. That could be part of the problem. Might be worth a try changing the firmware. Then defining the servo resource as B06 might work.
Aug 17, 2019, 11:34 AM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Thanks! Here’s vids as requested from other guy.
Here’s problem with batt and armed:
Tricopter problems pt.2 (0 min 34 sec)

And here is just pc:
August 17, 2019 (0 min 53 sec)
Aug 17, 2019, 12:15 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Thanks! That did it! I mapped to B06 and with no other config the servo moves! Quick question though, if the stick goes left should the servo go right?

Edit: now the serial port refuses to open. Need to reboot.
Aug 17, 2019, 12:22 PM
Registered User
Yes, servo goes right, pulls tail right, nose goes left.
Aug 17, 2019, 12:28 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Ok thanks! I’ll give it a test and report back.
Edit: so just sitting on my desk I see that I will need to set endpoints. But the maiden flight should be ok.
Aug 17, 2019, 12:54 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Ok so 2 things, the maiden was kinda a fail. It couldn't get off the ground due to the tail servo shaking violently and I need to set servo end points.

EDIT: Some cli commands i found and pasted got rid of the twitching, but the quad lacks the power to get off the ground. The batts I have are old cheap 1s cells so that could be a thing. Another thing is I might have to chain 2 together for 2s (my setup supports both 1s and 2s)
Last edited by Zentuckyfriedckn; Aug 17, 2019 at 05:27 PM. Reason: terrible first edit
Aug 17, 2019, 06:10 PM
CSU Chico, Flight Club
Test Pilot Mafia's Avatar
Quote:
Originally Posted by Zentuckyfriedckn
Another thing is I might have to chain 2 together for 2s (my setup supports both 1s and 2s)
this can cuase high resistance at low voltage (1 or 2 s), thus low current and poor lift. And buy better batteries.
Aug 17, 2019, 07:54 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
So this is a sad sad turn. I made a 2s lipo. I verified the voltage and polarity. But as soon as I plugged it into the copter, the esc board blew up. Not my fault because the listing said it could take 2s...

EDIT: Board is 1s but listed as 1-2s
Last edited by Zentuckyfriedckn; Aug 19, 2019 at 02:17 AM. Reason: clarification
Aug 24, 2019, 11:57 AM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Banggood is processing a refund! As soon as it goes through I’ll get an esc that can actually do 2s.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Tricopter flipping on take off issue btammes Tricopter Drones 6 Dec 23, 2015 12:16 PM
Help! Tricopter Flight stability issues onboardtherc Tricopter Drones 5 Nov 04, 2015 05:31 PM
Discussion KK2 flight controller tricopter servo issue passatiji Multirotor Drone Talk 7 Nov 19, 2014 05:04 PM
Discussion Tricopter rudder servo issues. Jerryzito Multirotor Drone Electronics 17 Nov 05, 2014 08:25 AM
Discussion Tricopter servo issue achevy21 Multirotor Drone Talk 1 Mar 21, 2013 07:10 PM