Thread Tools
Aug 15, 2019, 08:56 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Discussion

1103 Toothpick Thing


Iím not quite sure what it is, but here it is! Iím hijacking the led signal for the servo. Itís almost ready to maiden, but needs software work. (And to detect my receiver...)
I have an AA for scale.
Sign up now
to remove ads between posts
Aug 15, 2019, 09:51 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
So I got receiver working. Ibus is weird. I had to turn ppm on in the remote and use cli to enable ibus. So my current problem is servo. It has power, because when I turn or it will center itself, it just doesn’t listen. I used resource list and found the led strip to be on A01. So I freed A01 and set servo 1 to it and still nothing.

Edit: I probed the led pin on the processor and found it was b06. Changed it to that, no dice. Maybe the led pin is weird so I’ll try my ppm pin tomorrow.
Last edited by Zentuckyfriedckn; Aug 15, 2019 at 10:56 PM.
Aug 16, 2019, 06:48 AM
Registered User
Wow, interesting aircraft! Looking forward to a flight report!
Aug 16, 2019, 07:21 AM
Registered User
Which FC? How are motors and servo wired?
Aug 16, 2019, 10:12 AM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Thanks. I have heard reports that they suck at smaller sizes but I have seen others do it with brushed quads.
Aug 16, 2019, 10:15 AM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Quote:
Originally Posted by jihlein
Which FC? How are motors and servo wired?
A Banggood omnibus F4. I have motor 3 on the esc in the top left, motor 2 top right and motor 1 on the tail. I have the servo wired up to the 5v spot for an led strip. I plan on moving the signal wire to the unused motor 4 pin.
Link:
https://banggood.app.link/s4K8gDMCcZ (I don’t think this is an affiliate link pls don’t kill me.)
Last edited by Zentuckyfriedckn; Aug 16, 2019 at 10:16 AM. Reason: Trimming
Aug 16, 2019, 10:31 AM
Registered User
Don't move the servo signal to M4, that definitely won't work. The M1-M4 motors are resources B00, B01, A03, A02 respectively. They share 2 timer resources, which means you won't be able to set an ESC protocol for the motors and a pwm protocol for the servo. FWIW, here's the output definitions for the motors:

DEF_TIM(TIM3, CH3, PB0, TIM_USE_MOTOR, 0, 0), // S1_OUT D1_ST7
DEF_TIM(TIM3, CH4, PB1, TIM_USE_MOTOR, 0, 0), // S2_OUT D1_ST2
DEF_TIM(TIM2, CH4, PA3, TIM_USE_MOTOR, 0, 1), // S3_OUT D1_ST6
DEF_TIM(TIM2, CH3, PA2, TIM_USE_MOTOR, 0, 0), // S4_OUT D1_ST1

The LED pin is on a separate timer from the motors, and it's the pin you want to use for the servo signal. There's a number of Omnibus targets, I'm not sure which one this FC uses, but the resource could be either A01 or B06 depending on which target firmware is required. A01 is for the OMNIBUSF4 target, B06 is for the OMNIBUSF4SD target. Setting the servo 1 resource to one of these pin resources looks like it "should" work.
Aug 16, 2019, 01:44 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
I think LED_STRIP 1 is what I was missing I was trying to use the LED_STRIP resource. I need to change wiring, I already tried motor 4 before I saw your post.
Aug 16, 2019, 02:12 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
I moved back to the led pin. No dice. Before soldering I confirmed that the led is connected to the processor. I think it was B06. I mapped servo 1 to one then the other. Nothing. The servo has power and will center itself but wonít communicate properly. I found that when I was Messing with using pin 4 I got the servo to spin. Continuously and uncontrolled. Iím running out of ideas servo tilt and channel forwarding are off.

EDIT: Here it is all buttoned up! Tail still doesnít work, but a test hover showed I can at least fly it headless with no servo.
Last edited by Zentuckyfriedckn; Aug 16, 2019 at 04:53 PM. Reason: Kewl
Aug 16, 2019, 10:17 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Im going to hope into a different thread to fix servo to keep this thread clean for the (mostly) final unveil. When ready I'll delete this message and link to trouble shoot thread. Which is here --> https://www.rcgroups.com/forums/show...s#post42536807
Last edited by Zentuckyfriedckn; Aug 16, 2019 at 10:30 PM. Reason: link
Aug 17, 2019, 07:53 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
So I fixed servo issue but unveil is delays for another 3 weeks... See servo thread.
Aug 20, 2019, 04:36 PM
Just call me Justin.
Are you worried about the servo pulling too much juice off the board 5v pad?
I had troubles with mine,so I added a 2a bec.... and it still struggles. But I'm sure I'm using a bigger servo... mini digital metal gear.....
Aug 24, 2019, 07:37 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
Nah. No concerns. For the short time it flew servo response was snappy. I’m using a little 4 gram analog servo.
Edit: it pulls less then 300 milliamps when stalled according to the seller. To contrast, my TX04 pulls 255-365 milliamps according to seller.
Last edited by Zentuckyfriedckn; Aug 24, 2019 at 11:17 PM. Reason: Current Values.
Aug 25, 2019, 01:50 AM
Tero215
Hi there, what would the total cost be for this please - if I were to make my own?
Aug 25, 2019, 09:06 PM
Build. Crash. Repeat.
Zentuckyfriedckn's Avatar
Thread OP
I paid around 80 bucks for everything except transmitter, for cam and fpv goggles.

Edit: For a beginner though diy quad is probably more suitable. If you are bad at soldering then buy a prebuilt or practice soldering. Trust me. Tricopter is quite advanced and workaround heavy. Aka this thing exists as a challenge. In fact Betaflight is going to axe tricopter support soon I think.
Last edited by Zentuckyfriedckn; Aug 25, 2019 at 10:33 PM.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Большая Бензиновая Бойцовка 32сс Urri Russia 2 Aug 27, 2011 06:22 AM