Thread Tools
Jun 26, 2019, 10:20 AM
Registered User
Thread OP
Help!

Cannot Flash Firmware on new Naze32 Acro Rev 6.


Hi, I'm completely new to Quadcopter building. I just started a month ago.

I didn't know much about Flight Controllers and with very minimal research I decided to buy a Naze32 Rev 6 for about $25.

Right out of the box, I'm not being able to flash the firmware onto the FC from Clean flight. I have scampered around multiple online forums and YouTube videos for solutions, to no avail.

The flashing proceeds and when it gets to verifying it fails showing the error “STM32 timed out programming failed”.
Or the flashing bar doesn't even start and it shows
“Could not connect to Bootloader”

Here is the list of things I've tried:
Changing USB cable, making sure it's a data cable
Changing the manual baud rates
Trying different firmwares (old and latest)
Changing Laptops
I've tried to short the Bootloader Pads (soldering and also just shorting them using a piece of copper wire) and then select “No booting sequence”. I've tried to (a) keep the pads shorted throughout the flashing process (b) keeping the pads shorted while connecting the FC and then removing the short before flashing
I know the Naze 32 Rev 6 uses CP2102. Accordingly I've installed Zadig and the lastest CP2102 Driver installers from Clear Flight home page. I've selected the FC in Zadig and changed it to WinUSB. And then I've gone to “Universal Serial Bus devices” and installed a new driver.
I've tried to use different combinations, adjusting manual baud rates, selecting the option to erase the existing data on the board.

I'm feeling very lost and dejected. Please help.
Sign up now
to remove ads between posts
Jun 26, 2019, 02:39 PM
Registered User
LemonC's Avatar
when you did your 'minimal research' did you see all the replies that said not to buy a Naze32'X'* ?
Jun 26, 2019, 10:11 PM
Registered User
Thread OP
I didn't know about these forums. So I didn't check them. I bought after reading some articles from websites about flight controllers.
Jun 27, 2019, 08:39 AM
Registered User
LemonC's Avatar
Are you able to connect to clean flight and do all of the things? (set up your receiver, pids, etc).

*you said you cannot flash new firmware, can you get in and setup parameters in cleanflight?
Last edited by LemonC; Jun 28, 2019 at 01:04 PM.
Jun 30, 2019, 02:20 AM
Registered User
Thread OP
When I press connect, it takes me to a CLI page. And then I get a warning that the firmware on the device needs upgradation to a newer version.
Jun 30, 2019, 03:56 AM
Registered User
Thread OP
In case I can't fix this FC, do you have any suggestions or advice if I am to buy a different FC?
Jun 30, 2019, 09:15 AM
Registered User
LemonC's Avatar
A Bardwell just bc he has really good documentation on how to set it up. Any f4 or f7 w osd that gels well w your esc setup w prob be good. Mpu 6000 gyro...

I haven’t used clean flight in a long time but I was just gonna suggest just fly it w the firmware that came preloaded, are you sure your doing that jumpers right? Those things are a struggle.
Jun 30, 2019, 11:21 AM
Registered User
Thread OP
I tried soldering the jumpers. I know I'm shorting the bootpads properly because the green LED stops blinking and only the solid blue LED stays on. I'll look into Bardwell, thank you. If not cleanflight, which one do you usually use?
Jun 30, 2019, 11:36 AM
Registered User
Betaflight.
Jul 01, 2019, 08:52 AM
Registered User
LemonC's Avatar
Yes, Betaflight.

https://fpvfrenzy.com/betaflight-vs-cleanflight/
Jul 01, 2019, 12:20 PM
Registered User
Ace12GA's Avatar
Betaflight for sure, but you're limited to an older version, 3.2.x

https://github.com/betaflight/betafl...BetaFlight-3.2
Jul 01, 2019, 07:20 PM
Registered User
if you got this one
https://www.banggood.com/Upgrade-NAZ..._warehouse=USA

it is a Spracing F3 clone
i was able to flash any flavor of betaflight even 4.0.3

you need to solder the jumper pins on the boot holes
and use a jumper like those on the back of pc cdroms

i tried to flash it jumpering the pins with some tape and a piece of foil
and even the red light do not come up and you just get the blue light and i got that timeout error

try with the steady connection of a real jumper and solder those pins on the boot holes of the FC
that worked for me

and if you want to move on
get an F4 Flight controller
any OMNIBUS F4 will do, they are not expensive and works for budget builds
if you want to go luxury get an F7 , but an F4 will do for what you trying to do

https://www.banggood.com/9_4g-30_5x3...r_warehouse=CN


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Accidentaly flashed cc3d firmware on Naze32 Marcel98 Multirotor Drone Electronics 4 Dec 09, 2017 12:29 PM
Discussion Ublox NEO-M8N on a NAZE32 rev 6 (10DOF) Riktar FPV Equipment 4 Mar 14, 2017 01:54 PM
Discussion Acro Naze32 rev 6 speno61 Beginner Multirotor Drones 3 Mar 18, 2016 07:46 PM
Discussion NAZE32 Acro Rev 6 and Cleanflight learn2turn Multirotor Drone Talk 1 Oct 17, 2015 03:12 PM
New Product Rev 6 naze32 acro Uav Tech Ltd Uk Multirotor Drone Electronics 7 Sep 10, 2015 05:58 AM