Thread Tools
Aug 23, 2019, 06:06 AM
Registered User

Wiring/Power Supply Servos and Receiver


Hi all,

I was thinking to use this FC for a ZOHD Nano Talon build. Unfortunately I find the manual a little bit confusing concerning the power supply of the servos and the receiver. I am not sure what "All above interfaces are powered by the external 5v BEC module, and the flight controller does not output 5V to supply power to these interfaces." means exactly. Do I have to connect a 5v source to the servo row to deliver voltage to the servo and receiver connections or is the power from the PMU passed through the FC to power servos and receiver? The Nano Talon uses an ESC with a 5v BEC. The power for the Nano Talon stabilizer is delivered by the servo plug of the ESC. If I would connect the ESC to the FC in a similar way, the servo row would be powered by the BEC of the ESC, but I am a little bit concerned, that this could damage the FC. In the video of Alishanmao he powered the receiver with 5 v directly from the PMU and passed the voltage to the servo row by the connection of the receiver to the FC. I will be using a R9M mm receiver, which has no extra voltage input. Perhaps someone could help me to answer my stupid questions...

Thank you very much for your help and have a nice weekend!
Sign up now
to remove ads between posts
Aug 23, 2019, 06:26 AM
Registered User
Thread OP
Hi DocBiohazard

Use a ESC with BEC to provide power for your RCRX and servos not the PMU.

The video you refer to is not applicable to the LEFEIRC SN-L Sinan FC currently available.

Cheers

Jase


Quote:
Originally Posted by DocBiohazard
Hi all,

I was thinking to use this FC for a ZOHD Nano Talon build. Unfortunately I find the manual a little bit confusing concerning the power supply of the servos and the receiver. I am not sure what "All above interfaces are powered by the external 5v BEC module, and the flight controller does not output 5V to supply power to these interfaces." means exactly. Do I have to connect a 5v source to the servo row to deliver voltage to the servo and receiver connections or is the power from the PMU passed through the FC to power servos and receiver? The Nano Talon uses an ESC with a 5v BEC. The power for the Nano Talon stabilizer is delivered by the servo plug of the ESC. If I would connect the ESC to the FC in a similar way, the servo row would be powered by the BEC of the ESC, but I am a little bit concerned, that this could damage the FC. In the video of Alishanmao he powered the receiver with 5 v directly from the PMU and passed the voltage to the servo row by the connection of the receiver to the FC. I will be using a R9M mm receiver, which has no extra voltage input. Perhaps someone could help me to answer my stupid questions...

Thank you very much for your help and have a nice weekend!
Last edited by jwtfpv; Aug 23, 2019 at 06:59 AM.
Aug 23, 2019, 09:53 AM
Registered User
Quote:
Originally Posted by jwtfpv
Hi DocBiohazard

Use a ESC with BEC to provide power for your RCRX and servos not the PMU.

The video you refer to is not applicable to the LEFEIRC SN-L Sinan FC currently available.

Cheers

Jase
Hi Jase,

thanks a lot for the quick reply! Ok, so I will connect the ESC-plug completely to the FC and the complete row will be fired from the 5v from the ESC BEC if I got you right?

Cheers

Ingo
Aug 23, 2019, 11:18 AM
Registered User
Andy Borys's Avatar
Quote:
Originally Posted by jwtfpv
Hi Andy Borys

The GPS will not get a lock while you are inside.

Cheers

Jase
Hello Jase,

Thanks for the quick reply! The same result in open field. I use EagleTree Vector, and it doesn't have such problem in the same places.
Aug 23, 2019, 03:20 PM
Registered User
Thread OP
Hi DocBiohazard

The ESC servo plug when connected to the FC will provide 5V to all ports illustrated in red.

Cheers

Jase

Quote:
Originally Posted by DocBiohazard
Hi Jase,

thanks a lot for the quick reply! Ok, so I will connect the ESC-plug completely to the FC and the complete row will be fired from the 5v from the ESC BEC if I got you right?

Cheers

Ingo
Aug 23, 2019, 03:24 PM
Registered User
Thread OP
Hi Andy Borys

Have you given the GPS sufficient time to obtain lock? Depending on a number of factors this can take a few minutes.

Cheers

Jase

Quote:
Originally Posted by Andy Borys
Hello Jase,

Thanks for the quick reply! The same result in open field. I use EagleTree Vector, and it doesn't have such problem in the same places.
Aug 24, 2019, 02:28 AM
Registered User
Hi Jase,
thanks again! Now I have to wait and see how fast BG is able to deliver... Really looking forward for this project.
Cheers
Ingo
Aug 24, 2019, 03:40 AM
Registered User
Andy Borys's Avatar
Quote:
Originally Posted by jwtfpv
Hi Andy Borys

Have you given the GPS sufficient time to obtain lock? Depending on a number of factors this can take a few minutes.

Cheers

Jase

The problem seems to be solved. The GPS requires so a long time for signal lock. At least in my place. It took ~20min first time. Thank you for your help and advises.
Aug 24, 2019, 06:52 AM
'Extreme Fabricator'
Quote:
Originally Posted by Andy Borys
The problem seems to be solved. The GPS requires so a long time for signal lock. At least in my place. It took ~20min first time. Thank you for your help and advises.
That is a common problem but one thing I would suggest to users is to take the assembled system outside and leave it plugged in for at least an hour, preferably longer (make sure battery is up to it) as this will give the gps time to update the almanac, as well as charge its almanac backup battery. They are sometimes shipped flat, and letting it achieve charge will make future starts much faster for getting gps lock. Its also a good way of passing the bathtub failure curve for the rest of the electronics before flight.
Aug 25, 2019, 09:12 PM
Registered User
Hi Jase (or anyone who may be able to help)
I have a SN-Lts V4.0 LEFEI-RC Flight Controller Firmware V5.8
I have read your articles with great interest but I am not having the kind of luck you have had.
My setup...
Transmitter: OrangeRX Tx6i
Receiver: Orange R620X v2-sbus
Plane: Bixler
Goggles: Eachine EV800D
Camera: 600TVL 1.8mm CMOS FPV 170deg NTSC (powered direct from VTX)
VTX: Eachine TX805 V2.0

My problem...
After setting up I can only get an output to AIL servos, No output to THR, ELE or RUD.
Is it something I am doing wrong or a faulty item?

New model set up in Tx. Reset to defaults. CH5 to switch S3, CH6 to S2 (3 position switches)
On screen display works well as expected. GPS works as expected, correct home coordinates.
All tests done in Manual mode.
PWM values are not as expected – range from Low330, Mid1029, High1754
Sticks calibrated many times. All 4 stick channels working correctly in OSD.
AIL and ELE sticks work OK in OSD Menu.

Things I have tried...
Wait for 7 or more Satellites.
Unplug all FC components and try direct from receiver – All servos now working correctly including motor spinning/revving. But not when FC plugged back in.
Tried changing end ranges in transmitter to get PWM values nearer expected – No Change to outputs.
Upgrade Firmware to 6.1 – No Change
Calibrate GYRO, Level GYRO, Compass – No Change
Calibrated Throttle to ESC. - No Change
Move Throttle trim down to bottom – No Change
Pulled out all servo plugs from FC, measured voltage signal to neg – 0v on THR,ELE, RUD. 0.58v AC/0.25v DC AIL only.
Checked 5.05v THR from BEC/ESC
Plugged THR back into FC – Pos to Neg rail now 5.04v
Check, no signal from THR,ELE,RUD signal pins
Swap plugs around. Plug ELE or RUD into AIL . Either works with AIL stick. Motor doesn't.
Replace all servo plugs back into FC. Still same result. ELE and RUD move slightly as plugged in, not THR, but as THR replaced all other servos liven up or lock to end of travel and won't move by Tx Sticks.
Turn off all flight modes/failsafe except manual – Still No Change.
Tried turning off Telemetry(Battery voltage) from Rx – No Change
Using my friends Spektrum DX6 transmitter – No Change
Changed receiver to R615x with cPPM output. This increased PWM values to Low1094 Mid1519 High1958.
Still No Change to servo outputs, ie no Motor ELE or RUD.

Summary – All tests tried could not get it to work – no output THR,ELE or RUD.
I do know this is a bit longwinded, but I am letting you know as much as I can remember in order to help you to help me.

Cheers David
Aug 25, 2019, 11:59 PM
Registered User
Thread OP
Hi Justrelaxing

Can you post some photos?

Cheers

Jase


Quote:
Originally Posted by Justrelaxing
Hi Jase (or anyone who may be able to help)
I have a SN-Lts V4.0 LEFEI-RC Flight Controller Firmware V5.8
I have read your articles with great interest but I am not having the kind of luck you have had.
My setup...
Transmitter: OrangeRX Tx6i
Receiver: Orange R620X v2-sbus
Plane: Bixler
Goggles: Eachine EV800D
Camera: 600TVL 1.8mm CMOS FPV 170deg NTSC (powered direct from VTX)
VTX: Eachine TX805 V2.0

My problem...
After setting up I can only get an output to AIL servos, No output to THR, ELE or RUD.
Is it something I am doing wrong or a faulty item?

New model set up in Tx. Reset to defaults. CH5 to switch S3, CH6 to S2 (3 position switches)
On screen display works well as expected. GPS works as expected, correct home coordinates.
All tests done in Manual mode.
PWM values are not as expected range from Low330, Mid1029, High1754
Sticks calibrated many times. All 4 stick channels working correctly in OSD.
AIL and ELE sticks work OK in OSD Menu.

Things I have tried...
Wait for 7 or more Satellites.
Unplug all FC components and try direct from receiver All servos now working correctly including motor spinning/revving. But not when FC plugged back in.
Tried changing end ranges in transmitter to get PWM values nearer expected No Change to outputs.
Upgrade Firmware to 6.1 No Change
Calibrate GYRO, Level GYRO, Compass No Change
Calibrated Throttle to ESC. - No Change
Move Throttle trim down to bottom No Change
Pulled out all servo plugs from FC, measured voltage signal to neg 0v on THR,ELE, RUD. 0.58v AC/0.25v DC AIL only.
Checked 5.05v THR from BEC/ESC
Plugged THR back into FC Pos to Neg rail now 5.04v
Check, no signal from THR,ELE,RUD signal pins
Swap plugs around. Plug ELE or RUD into AIL . Either works with AIL stick. Motor doesn't.
Replace all servo plugs back into FC. Still same result. ELE and RUD move slightly as plugged in, not THR, but as THR replaced all other servos liven up or lock to end of travel and won't move by Tx Sticks.
Turn off all flight modes/failsafe except manual Still No Change.
Tried turning off Telemetry(Battery voltage) from Rx No Change
Using my friends Spektrum DX6 transmitter No Change
Changed receiver to R615x with cPPM output. This increased PWM values to Low1094 Mid1519 High1958.
Still No Change to servo outputs, ie no Motor ELE or RUD.

Summary All tests tried could not get it to work no output THR,ELE or RUD.
I do know this is a bit longwinded, but I am letting you know as much as I can remember in order to help you to help me.

Cheers David
Aug 26, 2019, 03:41 AM
Registered User
That's a similar story to mine so far.
I still haven't managed to load the firmware on to the FC due to issues with my pc but with everything plugged in mine is showing the same results.
I was assuming it was due to not having been able to set it up because of the Chinese script and it requiring things like the "Delta" wing not yet being set but reading the above I'm beginning to think it maybe a faulty unit?
I'm having my PC sorted out on Thursday (hopefully) so keeping my finger's crossed it'll all come out in the wash ok
Aug 26, 2019, 03:42 AM
'Extreme Fabricator'
Justrelaxing did you try an external BEC and plug a servo into the throttle channel for testing? also confirm with a meter that your servo signal wires are running to the isolated pins on the FC? Also check all servo ground wires are connected to battery negative when plugged in to the FC and all servo's are getting 5v with respect to that ground..
Aug 26, 2019, 10:18 PM
Registered User
Thank you for your prompt replies.
Jase - I am attaching two images. Wiring is as I have set it up. Let me know if you need more.

Drambuidhe - I hope you can get it working. I can get the Menu working OK after calibrating all the sticks (although I had to do that a few times before I could get that to work smoothly. Going through the channel calibrations I had to flick the 3pos switch only from 0 to 1 twice fast. Not the full way or it will jump past some required settings and miss out a channel. Then the sticks cannot operate the menu. This now works fine, all without a computer.

Alicecooper - I think I have done all you suggest. Throttle is supplying 5v from ESC BEC. Voltmeter test shows 5v across "+" to "-" rails on both FC and Receiver. Signal, positive and ground wires from servos are connected through their standard 3 pin plugs to the FC same as if tested connected to the receiver direct. (All working OK if plugged direct to receiver).
Aug 26, 2019, 10:52 PM
Registered User
Thread OP
Hi Justrelaxing

What happens if you move the RCTX AIL stick full left?

Cheers

Jase

Quote:
Originally Posted by Justrelaxing
Thank you for your prompt replies.
Jase - I am attaching two images. Wiring is as I have set it up. Let me know if you need more.

Drambuidhe - I hope you can get it working. I can get the Menu working OK after calibrating all the sticks (although I had to do that a few times before I could get that to work smoothly. Going through the channel calibrations I had to flick the 3pos switch only from 0 to 1 twice fast. Not the full way or it will jump past some required settings and miss out a channel. Then the sticks cannot operate the menu. This now works fine, all without a computer.

Alicecooper - I think I have done all you suggest. Throttle is supplying 5v from ESC BEC. Voltmeter test shows 5v across "+" to "-" rails on both FC and Receiver. Signal, positive and ground wires from servos are connected through their standard 3 pin plugs to the FC same as if tested connected to the receiver direct. (All working OK if plugged direct to receiver).


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion SN Sparrow Flight Controller ralfrcgroups FPV Equipment 108 Today 05:29 PM