Thread Tools
Apr 20, 2001, 07:18 AM
Registered User

LS motor performance probs


I recently had to purchase a replacment motor for my LiteStik as my original motor suffered a literal high-temp "meltdown." The new motor has a slightly different gear mechanism but doesn't seem to attain the necessary RPM's to fly the plane. Any help would be most appreciated.
Sign up now
to remove ads between posts
Apr 20, 2001, 07:35 AM
Registered User
What type of battery pack are you using?
Apr 20, 2001, 07:48 AM
Registered User
Steve McBride's Avatar
There are about 5 or so different litestik gearboxes available. They are actually 'GWS DX-A, B, C, D, E, etc.' If you have the original packaging for the motor/gearbox, there should be a recommended prop range. You probably picked up a unit designed to swing a larger prop.

Let us know what you find!

Steve McBride
Apr 20, 2001, 08:11 AM
Registered User
I am using a 6-cell NiMH pack which worked great with the original motor swinging the original prop. The new motor I believe is the E type as I recall the last box on the package being marked.
Apr 20, 2001, 10:22 AM
characters welcome!
Mark Wood's Avatar
Bingo! The LS comes with an "A" pinion at 5:1 ratio. The "E" is considerably higher. Look at the back of the packaging for the recommended prop.

mw
Apr 20, 2001, 02:15 PM
Our Daddy and Heli Junkie
Fred Bronk's Avatar
6 cells nimh is also on the border for the LS. You may want to try 7 or even 8 cells if you stay with nimh.
Then try an APC prop of the same size. They seem to work much better than the GWS props!
Apr 21, 2001, 12:24 AM
Registered User
Man, you guys are awesome. I wish I was half as smart as you. I will let you know how things work with the correct prop.
Regards,
T. S. Derse, MD
Apr 21, 2001, 01:35 AM
Flying slowly along..
I use 8 nimh cells on mine. I've got about 20 flights on this motor with no burn problems. Shame on me though, I had to steal the radio gear off of it tonight for my first scratch built. I'll prolly crash it right away and put the gear back on my Stick ---Rob
Apr 21, 2001, 03:40 AM
characters welcome!
Mark Wood's Avatar
Quote:
Originally posted by tderse:
Man, you guys are awesome. I wish I was half as smart as you.
Stick around, Grasshopper. Many of us found our enlightenment right here.
My package says use a 12x6 for the E drive, but I think I'd bump the batt pack to 7 Nicads or 8 cells of Nimh and swing an 11x4.7 maybe? I run the A drive in my LS with 8x500 AAA NiMhs and a 10x4.7 APC. Great flyer and no problems with burnt motors yet after ~20 flights like slowflyer. Got a carbon brush motor sitting here waiting for the inevitable, though.

mw


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Brushed motor starting probs jbird Power Systems 2 Apr 27, 2003 08:42 PM
Corona Motor Performance? jrb Electric Heli Talk 13 Dec 04, 2002 11:55 AM
new motor performance to increase over time? burgan Parkflyers 5 Jun 05, 2002 04:55 PM
need help interpreting motor performance tests joey221 Power Systems 7 Apr 13, 2002 10:50 AM
TR389 (M100) motor performance? KatManDEW Parkflyers 0 Oct 21, 2001 09:29 AM