Thread Tools
Apr 22, 2019, 10:56 PM
Registered User
Thread OP
Help!

Kingtech Turbine 180G


Hello,

I'm having trouble starting my Kingtech Turbine 180G First Gen it has been sitting a few months everything is on factory settings and having trouble starting the turbine I'm getting a Ignition Failed message Any suggestion on the different settings I should try I've tried different combo's I've seen on different blogs and forums I'm using Diesel with Kingtech Oil.


Thanks
Sign up now
to remove ads between posts
Apr 23, 2019, 05:49 AM
In search of speed......
Dansy's Avatar
Not much to try, make sure the RJ 45 cable is sitting completely in the turbine.....sometime the little plastic latch doesn’t latch......white dot on the inside. If all this is ok then I would call Dirk and send it in, burned plug would be my guess
Apr 23, 2019, 07:51 AM
Multi-Platform Pilot
barracudahockey's Avatar
Pretty sure the glow test will tell you that, I had a 45 crap a glow element and the error message during startup was BAD GLOW

Do a pump test with the fuel line disconnected and make sure you're getting fuel flow.

I wouldn't go playing with settings w/o talking to Dirk or Barry.

And yes, remove and reinsert the data cable on both ends.
Apr 23, 2019, 08:38 AM
Registered User
Running the pump on test I'd a good idea, they can stick at the low voltage of ignition ramp if the have sat for a while. My k70 pump done this over the winter.
Apr 23, 2019, 11:37 AM
Registered User
Thread OP
Quote:
Originally Posted by Dansy
Not much to try, make sure the RJ 45 cable is sitting completely in the turbine.....sometime the little plastic latch doesnít latch......white dot on the inside. If all this is ok then I would call Dirk and send it in, burned plug would be my guess
I donít think itís the plug because Iím not getting a Bad Plug I believe itís the pump
Apr 23, 2019, 11:42 AM
Registered User
Thread OP
Quote:
Originally Posted by raydar
Running the pump on test I'd a good idea, they can stick at the low voltage of ignition ramp if the have sat for a while. My k70 pump done this over the winter.
Iím going to try the pump test the fuel moves very slow through the pump during ignition Iím guessing itís stuck and thatís my problem because Iím not getting any other errors
Apr 23, 2019, 07:50 PM
Registered User
fenderbean's Avatar
have you checked for slime in the fuel? filter could be all gummed up
Apr 23, 2019, 10:51 PM
Registered User
When in doubt, pull out the KingTech gen 1 instruction manual and rerun the Learn R/C function. I found it on page 25 of the 2015 manual. Only takes a minute or two and can fix many problems that don't seem to have an easy answer.
Apr 24, 2019, 10:46 AM
Registered User
Thread OP
Quote:
Originally Posted by dontop
When in doubt, pull out the KingTech gen 1 instruction manual and rerun the Learn R/C function. I found it on page 25 of the 2015 manual. Only takes a minute or two and can fix many problems that don't seem to have an easy answer.
I will try that because Iím getting good fuel flow I talked to Barry from KingTech sent him a video says that Iím not getting that intial Fire in the Turbine during the ignition process thatís whatís keeping it from not going into the next phase of the ignition process
Apr 27, 2019, 06:29 AM
Registered User
Not being rude cuz I've done it on my 180g1 but it has to be right side up to start.
If it's not, pour out any fuel that's inside it (probably out of the intake) mount the kingtech name centered on top and try again
Last edited by Supersparky; Apr 27, 2019 at 06:32 AM. Reason: Added info


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Xicoy fadec au108k for kingtech 180g? amourjet Jet Turbines 3 Apr 09, 2019 01:35 PM
Discussion Kingtech K80-E Turbine Owners Thread Marty C... Jet Turbines 316 Jul 21, 2017 04:55 PM
Discussion HERE is my NEW F-16 1/6 scale skymaster with kingtech 180g sherlockshah Jet Turbines 2 Feb 26, 2014 07:21 PM
Discussion Kingtech K160-X Turbine Owners Thread Marty C... Jet Turbines 7 Jul 03, 2010 09:34 PM
Discussion Kingtech Turbines BulletMaster Jet Turbines 18 Jan 27, 2010 08:40 AM