Thread Tools
This thread is privately moderated by Watageek, who may elect to delete unwanted replies.
Mar 28, 2019, 01:03 PM
Antequam sciat ego nescibam
Watageek's Avatar
Thread OP
Discussion

Betaflight 4.0 Omnibus F4 Pro V2 Serial_RX DSMX not working on UART1 _ FIXED


My Omnibus F4 Pro V2 have an issue on the BF4.0 Release Candidate with the UART1 connected to the serial RX DSMX. I am too lazy to move the wire to another UART.

Here is a fix that might work for you.

This one...
Last edited by Watageek; Apr 03, 2019 at 11:05 PM.
Sign up now
to remove ads between posts
Apr 13, 2019, 05:48 AM
Antequam sciat ego nescibam
Watageek's Avatar
Thread OP
I cannot test it anymore, no more F4 for the moment. If there is any issues let me know.
Apr 15, 2019, 01:24 PM
Registered User
Quote:
Originally Posted by Watageek
I cannot test it anymore, no more F4 for the moment. If there is any issues let me know.
Thank you. I will test.
Apr 16, 2019, 10:22 AM
Registered User
Quote:
Originally Posted by Watageek
I cannot test it anymore, no more F4 for the moment. If there is any issues let me know.
Thank you. Worked like a charm. Can you tell me what happens in the Next release? Is there something that I should do prior to the update, or is this what I need to go through each time?

Thanks again.
Apr 16, 2019, 04:15 PM
Antequam sciat ego nescibam
Watageek's Avatar
Thread OP
Future will tell. Actually it is solely related to the board design. It just happens that we have the same issue. Pretty sure this HEX file will be all around pretty soon.

Ask if you need help again.

I ditched all telemetry and the protocol I don't use and added all the features ( absolute control, dmin, integrated yaw,etc) on my spracingf3.

And fried the F4.
So I might need you to validate new release each time.


Quick Reply
Message:
Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Omnibus F4 Pro Mag not working danimifs87 FPV Aircraft 2 Aug 31, 2018 03:46 AM
Discussion BF3.2 Omnibus F4 Pro V3 LED_strip not working skyrock Multirotor Drone Electronics 0 Aug 31, 2017 04:39 AM
Help! New build omnibus F4 pro v2 UART1 missing when PPM active. MisterD Beginner Multirotor Drones 2 Jul 15, 2017 10:54 AM
Discussion Omnibus F4 Pro v2.5 Why is the LED-strip port not working? daveflave1275 Multirotor Drone Electronics 5 Jun 26, 2017 06:16 AM
Help! Omnibus F4 Pro v2, DX6i, orange r415x do not work hallux Multirotor Drone Electronics 0 Mar 29, 2017 03:47 PM