Thread Tools
This thread is privately moderated by dpb56, who may elect to delete unwanted replies.
Mar 22, 2019, 11:08 AM
Registered User
Thread OP
Discussion

Futaba 14SG Throttle Curve question


When I view the owner's manual for the 14SG, the throttle curve graph always shows the throttle stick (vertical line) on the left side of the graph. When I open this screen on my 14SG the throttle stick (vertical line) appears 25% from the right hand side of the graph. When I move the stick, toward full throttle, the vertical line only moves to the point which is 25% from the left hand side of the graph. I don't understand why the throttle stick doesn't initially appear on the left side of the graph, on my transmitter screen, and why the throttle stick travel across the graph is only about 50%. Your advice is needed!
Last edited by dpb56; Mar 22, 2019 at 11:37 AM. Reason: clarity
Sign up now
to remove ads between posts
Mar 26, 2019, 08:48 AM
Registered User
If you create a new model or do a full data reset does the throttle curve still behave in the same way?

Does the throttle channel respond correctly to the throttle stick when viewed in the servo monitor?
Mar 26, 2019, 12:59 PM
When creating a new model the throttle behaves the same way. I haven't done a full data reset.
The servo monitor shows the bar moving downward when I push the throttle stick up to full throttle and then upward when moved to closed throttle; the bar does not move to 100 % in either direction or overall. I am using version 8 software which I downloaded about a month ago. This transmitter is a big step up in technology for me so I'm still learning; I'm finding your Kindle publication very helpful but I can't get the throttle to operate the way I think it should. Thanks so much fo weighing in!

Also, I just changed my user ID with RCU; I started as dpb56.
Last edited by 2flaperon22; Mar 26, 2019 at 01:04 PM. Reason: To prevent confusion about my user ID.
Mar 26, 2019, 01:43 PM
Registered User
The fact that you are still getting the same problem with a new model and also that the servo monitor is not showing full travel suggests that there might be a problem with the transmitter.

One thing you could try is calibrating the sticks especially if the radio is not new. This is done via the H/W setting menu and is described on pages 57 and 58 of the manual.
Mar 26, 2019, 05:09 PM
Hi Malcolm; you nailed it!! After calibrating J-3 and J-4 the throttle (motor) and throttle curve work beautifully. I was beginning to think it would take me months to figure this out on my own.

Thanks a bunch!

Doug
Mar 27, 2019, 03:59 AM
Registered User
Glad the problem is resolved.

In my experience it is highly unusual for the calibration to be so badly out. To avoid the loss of a model or possible injury it may be worth having the transmitter checked out at a service centre.
Mar 27, 2019, 01:13 PM
Good advise; I will follow up.

Thank you,

Doug


Quick Reply
Message:
Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Futaba 14SG Tx and FM800 Rx - Binding & Hookup Questions DJI27 Radios 5 Jan 18, 2018 03:34 PM
Discussion Futaba 14sg throttle cut in PROG. MIX ckeller Multirotor Drone Talk 0 Jun 04, 2016 12:41 PM
Discussion Futaba 14SG RX Voltage sensor question. helipilot2 Radios 1 Feb 05, 2016 04:09 PM
Question Futaba 14SG learning curve zippogeek Radios 2 May 08, 2014 08:13 AM
Discussion Dumb question - Futaba 9CA throttle reverse curve - Revo CP sheerLuck Mini Helis 3 May 04, 2006 07:22 PM