Thread Tools
Jan 21, 2005, 08:40 PM
Rat
Rat
Come get me if you can
Rat's Avatar
Thread OP

E flite Ultimate 3D with E flite 370 BL startup ????


I finished the assembly on my Ultimate last night and hooked up a Kan 1050 to check servos etc. I ran the motor for just a few seconds but I am concerned. When the motor starts up it vibrates something fierce. This is just on the initial start up and it goes away once it reaches slightly higher rpm. I am afraid that it is going to twist off the carbon fiber motor mount.

I am running the E flite Park 370 4100 kv brushless motor and a phoenix 25 speed control. I have the brake disabled in the speed control and have it set up for soft start.

Also any other ideas on how how to set up the programming of the speed control would be very helpful. I plan on using a 3s Li-Po when I find one so I set the low voltage cut off for 9(I think that is what it is, I used what the guide recomended for this) volts already. How about the timing advance etc?????
Sign up now
to remove ads between posts
Jan 21, 2005, 09:17 PM
Electric since 1990
Foamaholic's Avatar
Try the timing, but these motors often jerk at startup. Just advance the throttle quickly and it won't do it. I wouldn't worry about it.
Right to set 9 volt cutoff for 3 cells. Use soft cutoff. You can disable the brake if you want.
Jan 21, 2005, 10:02 PM
Rat
Rat
Come get me if you can
Rat's Avatar
Thread OP
I have the timiing set at option 2 which is 5*-20*. Is this correct for this motor?????
Also should I mess with the current limiting or just set it at what castle had it set at which is standard ( moderate over-current threshold,will shut off after slight delay)???

Also any other recomendations that people can think of.
Jan 21, 2005, 10:11 PM
i have mine on a hacker 4900, and i have it cut off at 9, soft start, and current limiting is off.... but be careful if you disable current limiting...
it flies awesome, hover at 1/3 and LAUNCH out! I love it.... great plane i just got a tribute and startin it tonight or tomorrow... dunno yet
Jan 21, 2005, 10:21 PM
Gotta have more cowbell!!
MTwallet's Avatar
Rat, leave the current limiting alone, set it for fast start, for 3D you want fast start trust me. Set the cutoff at 7.2V and hard cutoff. When the battery starts to sag, land or fly at a higher altitude so you can recover from the cutoff. If you have a Phx link, use 8.0 Volts, I don't like 9.0V 'cause if you are drawing a lot of current you might hit cutoff prematurely. I don't like soft cutoff because it allows you to fly even after you have reached the cutoff voltage. With todays power systems you are able now to hover usually at or below 1/2 throttle, you might not even know that you have reached cutoff if you are flying conservativly until it's too late and your lipos look like Jiffy Pop. You can set the timing to "advanced" if you like, it might start a little better and run with a little more power but it's not very noticable and will reduce flight time due to higher current draw.


Mike
Jan 21, 2005, 10:21 PM
Electric since 1990
Foamaholic's Avatar
Can just leave everthing default, escept for cutoff and cutoff type. Should be fine.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
F/S E-flight 370 BL and Tower Tx and Rx Opie818 Aircraft - Electric - Airplanes (FS/W) 6 Feb 28, 2005 09:03 PM
E-Flite 370 4100kv on Ultimate? RickC2009 Power Systems 3 Sep 11, 2004 12:23 AM
E-Flite 370 4100kv on Ultimate? RickC2009 3D Flying 1 Sep 10, 2004 12:43 PM
E-flite Ultimate 3D bipe kit. NIB Gerald Aircraft - Electric - Airplanes (FS/W) 12 Jun 28, 2004 09:25 AM
E-Flite 370 BL @ Horizon Hobby..? Boss248 Power Systems 0 Apr 21, 2004 01:15 AM