Thread Tools
Feb 09, 2019, 02:19 AM
Registered User
Thread OP
Discussion

8 Channel receiver problem


Hi Jim,
I had my gear in storage after returned from Xps after a flash upgrade to 3.8.
One of my 8 channel receivers can't be seen by Xdp.
The other 14 receivers work fine on xdp.
If i apply power reversed to the port it works as it should every time apart from the reversed battery connection.
What's the fix for this problem?
Sign up now
to remove ads between posts
Feb 09, 2019, 04:01 AM
Registered User
Thread OP
Closed the previous thread as it was inaccurate.The problem there was when selecting at top of screen next device.Opened back to a 8 channel receiver that i had connected previously instead of a blank start.
Feb 09, 2019, 11:50 AM
You should never be plugging power in backwards!
Feb 10, 2019, 01:45 AM
Registered User
Thread OP
Yes i know that Jim.In your manual or on the forum is where i read it you stated the receiver will work although not correctly with reversed power.
Why is it i need to connect the power reversed to be able to access the Xdp functions on the receiver is my question ?
And how to correct it?
The receiver in question has never been used except for now when taken out of the sealed bag as received from you.
Feb 10, 2019, 02:40 PM
You don't need power in backwards... in fact, that should not work. Just press and HOLD the programming button and apply the power into the 'B' port (the correct direction).

After that, the XDP will see the receiver. Make sure it is not too close (at least 3 feet between the receiver and XDP). it could be that with the power in backwards that the power output (and sensitivity) is extremely low.
Feb 10, 2019, 11:38 PM
Registered User
Thread OP
Receiver finally seen after several tries.Battery in correct orientation in the battery port.
Select view/change setting and got this popup.
Have tried to reconnect several times since and unable to.
Last edited by Craig 01; Feb 11, 2019 at 12:08 AM.
Feb 11, 2019, 12:43 AM
Move the reciever further away from the XDP. That's a Windows/VB6 message. Pay attention to the LED on the receiver. If it turns green, even though it is not connecting to the XDP software, it means the RF is working. You could try doing a reset of the receiver.
Feb 11, 2019, 03:11 AM
Registered User
Thread OP
Thanks Jim,all is good now.Appreciate your patience and help.
Feb 11, 2019, 12:18 PM
So, what solved this.. moving the receiver further away or doing a reset?
Feb 12, 2019, 06:52 AM
Registered User
Thread OP
Didn't do a reset.
Charged the battery above 5v and it seemed to work.
Checked again today with battery above 5v and its playing up again.
5 foot plus separation.
It either doesnt see the receiver or shows the 8 channel receiver pic with no data or if it does see receiver and shows data then when select view/change button then doesnt see receiver.
Compared to the rest of the receivers that connect without fail this problem receiver is doing my head in.
Almost want to throw it in the bin being honest!
Feb 12, 2019, 01:18 PM
Battery voltage won't matter. Anything above 2.1 volts will work (as long as there are no servos drawing excessive current). This problem is almost always a RF issue where the receiver is too close to the XDP or too close to a 2.4GHz router, microwave oven (while running), or 2.4GHz video transmitter.
Feb 13, 2019, 12:55 AM
Registered User
Thread OP
Tried again today several times until i'd had enough.
Keeps coming up with "No extremelink device detected"
Just for for comparison,i connected at random other 8,10,nano,park flier and sail plane receivers with not one problem in the exact same layout,distance and location to xdp.
Connect problem receiver and back to not wanting to show itself to Xdp.
Feb 13, 2019, 01:59 AM
Try doing a RESET on the receiver. .. you can do that by holding down the programming button and applying power. Do not release the programming button until you see the LED flashing red. Once it's stopped flashing red, remove the power.
Feb 13, 2019, 02:20 AM
Registered User
Thread OP
First connection after reset xdp could see receiver/data,select view/change button got the runtime error 364.
Start again and Xdp unable to see receiver.
Feb 13, 2019, 01:54 PM
it seems it is having a communications issue. Does this receiver range test ok?


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion PCTX Servo commander 25 channels (3) 8 channel receivers any one familiar? born2dive9702 FPV Equipment 0 Nov 29, 2016 11:19 PM
Help! Problem with 8 channel Turnigy receiver and Bananahobby ESC eotto Radios 3 Aug 15, 2011 02:26 AM
Any problems using a 4 channel receiver with a 7 channel radio? bluex Power Systems 6 Jul 06, 2001 12:23 AM