Thread Tools
Nov 26, 2018, 12:48 PM
Registered User
Thread OP
Discussion

Horus X10S Opentx Throttle stopped working Help!


I have been using Opentx for several years.

I just upgraded to a Horus X10S, and loaded Opentx 2.2.

I set up my airplane, and the throttle has been working for my setup.

All of a sudden my throttle no longer works. I did make a few changes to the settings to read the telemetry.

I thought maybe I fried my ESC as it no longer makes any noise. Usually it makes a series of beeps.
I bought a new ESC, and that didn't change anything.

It appears that the ESC is not receiving signal from the receiver.

I double checked that I am still in mode 2, and I am.

I must have changed something, but after hours of looking through my set up, I cannot find it.

Does this ring a bell to anyone? I did a search, but could not find anything that helped.

I'm sure it's something simple, but I'm going crazy trying to figure this out.

Please help.
Sign up now
to remove ads between posts


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Durafly Tundra on OpenTx/Horus-Taranis IntheTubeDeep Electric Plane Talk 1426 Jul 07, 2019 06:07 AM
Discussion Is Horus x10 compatible with Opentx? Slopewind FrSky 2 Nov 20, 2018 02:10 PM
Discussion Horus X10S, OpenTX 2.2.1, SxR Lua script issues Kfab1202 Radios 5 Sep 15, 2018 10:10 AM
Help! reciever stops working at full throttle steve282 Electric Plane Talk 11 Jul 04, 2016 12:31 PM