Thread Tools
Jul 13, 2019, 08:38 AM
Registered User

FC pinouts for UART


For Cygnet 3 owners with original STABLE MiniTower (I'm focusing to ones who have FC revision 1.4 or newer), it has UART1/3/6 pinouts. TX3/RX3 and TX6/RX6 are used by VTX and receiver. Leaving you a free UART1 to meet your need. It can be used for:
  1. Control for RunCam Split Mini 2 (ie: run/stop recording)
  2. GPS module
  3. Receiver's smart feature (ie: S.Port for FrSky R-XSR)

I don't think you need to re-wire R9MM - it's already correct out of box.. right? Just need to re-flash with matching firmware with R9M module. And you get full telemetry with whole sensors discoverable on Taranis?
Sign up now
to remove ads between posts
Jul 13, 2019, 10:47 AM
Registered User

connect 4649T


what cable do I need to connect a spektrum 4649T to the cygnet 3 ?
Jul 13, 2019, 12:48 PM
RCholic
So I have followed @flycrashfly guide,
and managed to get the telemetry data to my X-Lite Pro.
However, I cant get any PID readings or VTX data?

I have Frsky X-Lite Pro TX (ACCESS) Firmware
RX4R RX (ACCESS) Firmware
And of-course BF LUA scripts installed.

Any one encountered such problem?
Jul 13, 2019, 02:11 PM
Registered User
Quote:
Originally Posted by kibbycabbit
For Cygnet 3 owners with original STABLE MiniTower (I'm focusing to ones who have FC revision 1.4 or newer), it has UART1/3/6 pinouts. TX3/RX3 and TX6/RX6 are used by VTX and receiver. Leaving you a free UART1 to meet your need. It can be used for:
  1. Control for RunCam Split Mini 2 (ie: run/stop recording)
  2. GPS module
  3. Receiver's smart feature (ie: S.Port for FrSky R-XSR)

I don't think you need to re-wire R9MM - it's already correct out of box.. right? Just need to re-flash with matching firmware with R9M module. And you get full telemetry with whole sensors discoverable on Taranis?
I was reading FrSky documentation FrSky FPort Protocol. The page said a signal from R9MM's inverted F.Port was indeed bidirectional (aka full duplex aka combo of TX/RX in one wire). How come people still rewire F.Port for S.Bus and S.Port? Didn't the most recent firmware fix the telemetry issue that you could just use GND/5V/Inverted F.Port?

Quoting from https://oscarliang.com/setup-frsky-fport/:

Quote:
Why Is FPort Better?

From now on, I will be using FPort over SBUS and SmartPort whenever I can, because:
  • FPort combines SBUS and Smarport Telemetry into one single wire
    1. cutting down cable management and soldering
    2. save a UART port because SBUS and Smartport take up two separate UART’s
  • FPort is an uninverted protocol **, so hopefully we don’t have to worry about doing “uninversion hacks” on F4 FC in future Frsky receivers
  • FPort is slightly faster than SBUS
  • RSSI works automatically (no need to pass through a channel)
In a nutshell, RX JST socket already provides all the necessary connections for your R9MM (GND,5V,RX6,3.3V). No rewiring needed, right?
Last edited by kibbycabbit; Jul 13, 2019 at 02:51 PM. Reason: Clarification
Jul 14, 2019, 03:20 AM
Registered User
I've wired my r9mm to the TX6 pad to the r9mms inverted and I get telemetry but I can't change any of the values when using the lua scripts, I make changes but nothing is stored. I've played with the cli command for half duplex but it seems to make no difference. Any ideas?

Sent from my SM-G975F using Tapatalk
Jul 16, 2019, 02:38 AM
Registered User

unable to change the rssi channel


Hi here, I have the same still rssi problem with my cx3 pro xm+. I flashed the xm+ with D16, now I can see in BT/reciever tab that something is recieved on the aux12. but when I change the rssi channel to aux12 on the right of that page and then save, after reboot, rssi channel stay undefined...
I tried everything even from CLI (invert, scale, max aux ...) these settings are saved correctly but impossible to save the rssi channel.
Is someone experimenting the same issue, and how to solve that? Thanks
Jul 16, 2019, 02:59 PM
Registered User
Quote:
Originally Posted by rcflyers
5v taken from the V pad at the rear of the F4 board, next to the rx connector socket.
Ground taken from the G pad next to the V pad.
Video feed taken from the video pad next to the 10 pin socket that the otiginal VTX plugs into
Smartaudio wire soldered to the outer rearmost 10 pin socket connector that the otiginal VTX plugs into (The one closest to the 'u' in 'audio' printed on the board)
That’s great! I’ve been thinking of doing the same. Do you mind take a picture of it next time you have it open? Thx
Jul 16, 2019, 03:06 PM
Registered User
Quote:
Originally Posted by Rob974
Hi here, I have the same still rssi problem with my cx3 pro xm+. I flashed the xm+ with D16, now I can see in BT/reciever tab that something is recieved on the aux12. but when I change the rssi channel to aux12 on the right of that page and then save, after reboot, rssi channel stay undefined...
I tried everything even from CLI (invert, scale, max aux ...) these settings are saved correctly but impossible to save the rssi channel.
Is someone experimenting the same issue, and how to solve that? Thanks
In the configuration tab, check if your rssi_adc switch are on, (on the right side) it supposed to be off! Otherwise it will not work, it will just reset back.
Jul 21, 2019, 04:27 PM
Registered User
Quote:
Originally Posted by Spesh
I've wired my r9mm to the TX6 pad to the r9mms inverted and I get telemetry but I can't change any of the values when using the lua scripts, I make changes but nothing is stored. I've played with the cli command for half duplex but it seems to make no difference. Any ideas?

Sent from my SM-G975F using Tapatalk
Just a heads up in case anyone finds this and has been dumb as me, you need to press RIGHT on the menu selection sick on the x lite pro and choose SAVE PAGE, just going exit + ok does not save!

So it turns out wiring inverted pin of r9mm to TX6 of the FC makes telemetry work perfect. Remember to add vtx tramp to UART 3 (I think) to get that also working.

Sent from my SM-G975F using Tapatalk
Jul 23, 2019, 12:02 PM
Toycar racer
Dbz619's Avatar
what kind of flight times are you guys getting on the cygnet 3? and what type of flight times are you getting on the cygnet pro? which has more jello or do both film great? debating if I want the cygnet 3, cygnet pro, or cygnet cinepro 4k.... anyone have any feedback, suggestions?
Jul 23, 2019, 08:29 PM
NYC
My frustration with this quad continues. After learning how to get it set up with telemetry and GPS my r9 receiver refuses to bind regardless of firmware.... and I've just fried the replacement RX trying to flash its firmware :/ quad remains grounded. At least they dropped r9mm prices down to $20 since releasing the OTA access versions.

I've completed three working builds since buying this thing and I may never buy a built quad again considering once it's built you have no idea what parts work and don't work, nor what firmware is on anything.
Aug 08, 2019, 08:40 AM
Registered User
Quote:
Originally Posted by Dbz619
what kind of flight times are you guys getting on the cygnet 3? and what type of flight times are you getting on the cygnet pro? which has more jello or do both film great? debating if I want the cygnet 3, cygnet pro, or cygnet cinepro 4k.... anyone have any feedback, suggestions?
Im getting about 3-4 mins on a 850mah on the Cygnet 3 Pro, no jello what so ever.
Aug 08, 2019, 08:48 AM
Registered User

Weak fram on the Cygnet 3 Pro?


Ok Guys, just a heads up warning about the pro frame.

After flying it, around 15-20 batteries. I was flying and lost my Vtx feed resulting in a crash, the crash wasn't out of the ordinary, 3 meters down into high grass, I didn't even bend a prop. When I picked it up I realized that my F4 stack was a bit loose, resulting the VTX board was disconnected from the FC. (I'd tighten it maybe 10 batteries earlier) Later when I was taking it apart to tighten the screws and washers again I saw that my frame had a crack in it. I would've understood if I'd had it for 2 months or flown it 100 packs, or had a huge crash. But this is not acceptable in my opinion, especially not for a 3 inch when there's no weight behind it.

Anyone have a shortline to Geprc, they seem to ignore my email at [email protected]
Aug 13, 2019, 07:43 AM
"Spark Chaser"
jokeane's Avatar

Some happy videos made with the Cygnet 3"


But I just wanted to say my Cygnet 3" (non-pro) is working fine. Lately I've been chasing my friends airplanes around at the local AMA club field.

https://photos.app.goo.gl/RyVi5dEL96cTiyMq5
https://photos.app.goo.gl/KdiVkDonGygi3Ywa7


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product SPCMaker SPC K1 95mm Omnibus F4 20A BL_S FPV Racing Drone PNP BNF w/ RunCam Split Min Rishi Banggood.com 0 Sep 26, 2018 09:55 AM
New Product GEPRC Hummingbird 110mm FPV Racing Drone Omnibus F4 12A BLHeli_S 5.8G 48CH VTX RunCam Frimen Mini Multirotor Drones 11 May 17, 2018 09:45 PM
New Product FlyFox Blue Fox 145mm FPV RC Drone w/ F4 Built In OSD 20A BLHeli_S RunCam Micro Swift smg24 Banggood.com 0 Jan 24, 2018 09:12 AM
Discussion GEPRC Hummingbird 110mm FPV Racing Drone Omnibus F4 12A BLHeli_S 5.8G 48CH VTX RunCam BobFromMars Banggood.com 0 Dec 27, 2017 11:24 AM
New Product GEPRC Sparrow GEP-MX3 GEP-MSX3 139mm 145mm Carbon Fiber 3mm Arm FPV Racing Frame D Gains Micro Multirotor Drones 0 Jul 04, 2017 05:22 AM