Thread Tools
Nov 02, 2018, 02:30 PM
Registered User
Htcohio's Avatar
Thread OP
Quote:
Originally Posted by BravoGolf
Guys, any thoughts on voltage regulators for both ground Pi and air Pi?

Are certain types better than others for this application? Powering a ground Pi with 3 WiFi cards for example.

They seem to come in all sorts of shapes and sizes and varieties now, are there some that should be avoided?
Thoughts on SBEC's and UBEC's?

I asked over in the other thread but question was never addressed and the wiki while having the subject in the side mast does not, as of this posting, link to anything.

Thanks in Advance,

~BG~
@bravo,

I'm sorry I always try to respond to bec questions. I feel it's the most important part of this project.

I've done a lot of experimenting with the adjustable type. (Shown inside the aluminum RPI case and black plane)..... Surprisingly these large LM2596 type up here to heat up quite a bit with 800mA draw and are audibly noisy....

right now I am switching everything over to these really tiny "adjustable" buck regulator.

I'm simply astonished at how efficient it is and I cannot find one problem.

Here is a temp measurement of 30 minutes running at 800mA.

5v Regulator, DROK https://www.amazon.com/dp/B0758ZTS61..._8kk3BbS9SY58G





Sign up now
to remove ads between posts
Nov 02, 2018, 02:44 PM
Registered User
Htcohio's Avatar
Thread OP
*also I've started to standardize all my builds with these connectors to avoid accidental Short Circuit.

•5v Side
JST-SM 20awg silicone (awesome!!!!)
Wire Cable, 10 Pairs https://www.amazon.com/dp/B074J5498N..._-yk3BbE0G9YGM

•Main V+ 12-24v input
JST regular
20 Gauge Silicone JST https://www.amazon.com/dp/B071XN7C43..._TIk3BbQ7JPXRR

Everybody is different but this has worked out really well for me ))
Nov 02, 2018, 02:52 PM
Spearheading an Alliance
BravoGolf's Avatar
^Thanks for your response, good info.

Also...

Curious if there has been any forward progress in regards to your custom (round) camera cable project, any traction? Not sure what the number$ involved are but would think you could sell every last one through all the various online sales channels nowadays.

~BG~
Nov 02, 2018, 03:26 PM
Registered User
Htcohio's Avatar
Thread OP
Quote:
Originally Posted by BravoGolf
^Thanks for your response, good info.

Also...

Curious if there has been any forward progress in regards to your custom (round) camera cable project, any traction? Not sure what the number$ involved are but would think you could sell every last one through all the various online sales channels nowadays.

~BG~
Hello, actually yes! Unfortunately the first prototype didn't work very well and had significant voltage drop.

So, I designed this breakout board that will instead have a JST-GH 15pin connector (the same type used on the pixhawk 2...

Today I just received a couple parts for making a wire harness to test.

The Prototype PCB breakout board should be here next week.

the manufacturer has already tested it on Raspberry Pi and camera and says it works perfect.

Furthermore, the total manufacturing and shipping cost is about $7.50 for the kit which will include 2x adapter boards and a 150mm or 300mm GH cable...

Once I confirm this for myself, I can then eliminate the rigid PCB adapter board and have the jst-gh female plug soldered directly to a 1mm>>1.25mm FPC ribbon cable.

I think this would be really good because everybody has jst-gh connectors now so it's compatible with a common connector in our Hobby.

This is also significantly cheaper. If I order 3,000 kits the unit cost per kit would be about $5.50. right now my order commitment is 200 kits... So obviously the more you buy the less it costs. Attached a screenshot of the email showing different pricing.

Both options should result in a total cost less that $10

**I definitely plan on giving 20 or so away for free for you and other wfb users to try out and test.




Last edited by Htcohio; Nov 02, 2018 at 03:54 PM.
Nov 02, 2018, 03:33 PM
Build more, websurf less
FlyingW's Avatar
Quote:
Originally Posted by Htcohio
@flyingw,

This is really surprising. I know that you probably feel like you have tested and checked everything. But because this has happened for this and 1.6 rc6. It leads me to believe that it has to be something else related to power or the USB cable going to taranis.

I just recalled that the first time I set up wfb 1.6 I used a really long PlayStation mini USB cable that gave me connection problems.

Do you by chance have a different mini USB you could try to the taranis>>pi?

Also, can you confirm that you disabled 2.4 radio on taranis?
Tried another usb cable without result.

Confirmed that both internal and external RF off in the Taranis.

Will soon re-wire the airpi and its associated Alfa unit with a 20ga usb cable I recently got in the mail.

In the meantime I suppose it is ok, but not as smooth as regular RC control:

control sort of smooth (0 min 13 sec)
Nov 02, 2018, 03:43 PM
Registered User
Htcohio's Avatar
Thread OP
Quote:
Originally Posted by FlyingW
Tried another usb cable without result.

Confirmed that both internal and external RF off in the Taranis.

Will soon re-wire the airpi and its associated Alfa unit with a 20ga usb cable I recently got in the mail.

In the meantime I suppose it is ok, but not as smooth as regular RC control:

https://youtu.be/Et6r1Tyry7s
Hey, thanks for the video, it does look much better. I know this must seem like a bit of a pain in the butt right now but we're all working together to redefine what FPV system might be the norm in the near future.

When you're done soldering the 20awg usb cable, i would recommend setting 115k baud on sd cards and telem 1.

Also setting RC back to 5, that should smooth things out.
Nov 02, 2018, 06:57 PM
Build more, websurf less
FlyingW's Avatar
Just was watching a different WFB video and noticed another field on the OSD that I wasn't seeing in mine: Please see the circled item below - I think it is supposed to be the RSSI of something.
Nov 02, 2018, 07:17 PM
Registered User
Htcohio's Avatar
Thread OP
Quote:
Originally Posted by FlyingW
Just was watching a different WFB video and noticed another field on the OSD that I wasn't seeing in mine: Please see the circled item below - I think it is supposed to be the RSSI of something.
Hey, that would be for like dragonlink or external UHF RSSI.

With usb rc you can comment that out on the OSD config file.

Just type "//" in front of rssi.

I change the layout of my OSD slightly also to demonstrate how you can change the layout. Here is the config txt file as shown.
Last edited by Htcohio; Nov 02, 2018 at 07:34 PM.
Nov 02, 2018, 08:36 PM
Registered User
Hello Htcohio,

I have tried your OPEN-HD mod on my setup, Works great!
I am using :
Air pi3 B
Pi cam,
Alfa AWUS036NHA cards on both side,
Pixhawk mini running last 3.6.0 ( copter)
Mavlink 2,
No RC receiver,
Ground Pi3 B ( B+ on the way for the WIFI 5G),
HDMI to monitor and Ethernet hot spot to QGC on Mac OS,

I am using TBS Tango in simulator mode USB to Ground Pi3 all 8 Channels running, full telemetry from the FC, Video on both, screen and QGC.
The RC is a little "robotic" I will tweak the parameters to see how smooth they can be.
I also plan to build an Remote with joystick and 7 inch screen to make the setup compact.
If you have new stuff to try on different setup let me know
I have one question:

Do you recommend to run multiple card on different frequency connected to each PI for safety range and RF noise?

Thanks again!
Nov 03, 2018, 04:31 AM
Registered User
Hi, Guys!
First of all thank you for level of trust that you giving to us while testing Open-HD system.
I want to say that till Monday, Tuesday I limited in time.
I only can allow to read messages.
But, starting from Monday or Tuesday I will have enough time to start working at Open-HD full-time.
And I will try to check/fix all those bugs that you reported.
Thank you!
Nov 03, 2018, 08:00 AM
Build more, websurf less
FlyingW's Avatar
Quote:
Originally Posted by user1321
Hi, Guys!
First of all thank you for level of trust that you giving to us while testing Open-HD system.
I want to say that till Monday, Tuesday I limited in time.
I only can allow to read messages.
But, starting from Monday or Tuesday I will have enough time to start working at Open-HD full-time.
And I will try to check/fix all those bugs that you reported.
Thank you!
Thank you user1321 for your brilliant work.

Paul
Nov 03, 2018, 08:19 AM
Build more, websurf less
FlyingW's Avatar
Just noticed something: One of the pictures caught the CPU use of the airpi very high. I often see this indicator flashing yellow and red on the OSD.

Looks like it is working very hard. In my setup it is a Pi Zero W.
Last edited by FlyingW; Nov 03, 2018 at 08:41 AM.
Nov 03, 2018, 11:53 AM
Registered User
Htcohio's Avatar
Thread OP
Flyingw,

Is this something new due to some changes that were made to the RC settings and baud rate?

I seem to remember the processing percentage is high during the first 1-2 min on Startup.

Also, changing the FEC video settings to 12/6/800 or increasing the video framerate from 48-60 can increase the CPU usage.

I also remember setting lower frame rates to 30fps sometimes caused problems for some reason with 1.6 rc6. I've been meaning to investigate further but that seems it could be dependent on V1 or V2 cameras...

Have you resolved any other issues?
Nov 03, 2018, 02:38 PM
Build more, websurf less
FlyingW's Avatar
No other issues resolved.

Did not change the FEC or video settings. CPU spikes randomly throughout the session, not just in the first few minutes. To maximize the video processing work I tried moving the camera so it saw different backgrounds but that really didn't increase the CPU spiking.

Still having high telemetry packet loss.

Will redo the airpi-Alfa usb cable (with 20ga power leads) only if the next release does not improve the packet loss.
Nov 03, 2018, 03:01 PM
willfly4$
cleatis's Avatar
I had everything working great for a while but now I'm stuck at this screen, no video. It just stops at "starting RX FEC: 8/4/1024" . As you can see from the top right, I am receiving TX CPU rare and temp though, does anyone have any idea what my problem is? Thanks


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Open 3D Flight Assistant discussion and creation thread racermark DIY Electronics 5 Apr 07, 2018 11:54 PM
New Product <Discussion thread>Hubsan H111C&H111D 720P HD Camera Quadcopter RTF BG Well Mini Multirotor Drones 62 Sep 06, 2016 08:59 PM
New Product Discussion thread---FQ777-124C MINI With 2.0MP HD &Switchable Controller BG Well Micro Multirotor Drones 41 Aug 11, 2016 05:51 PM
Discussion An open discussion about Model Aviation, the FAA, and the AMA dag214 Model Aircraft & Drone Advocacy 46 Dec 24, 2015 11:07 AM
New Product HeadPlay HD FPV Headset w/ 32ch 5.8GHz Receiver - Pre-Order open at GetFPV.com GetFPV FPV Equipment 41 Dec 13, 2015 03:33 PM